summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-08-28 20:38:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-08-28 20:38:39 +0000
commit50bdd33d8bb7ee8517600e8a3886e99ddaa1b105 (patch)
tree179044d00b331f4f9f0b1cd7abb94870454490dd /games-strategy/widelands
parenthttp://my.opera.com/desktopteam/blog/2012/08/28/core (diff)
downloadgentoo-2-50bdd33d8bb7ee8517600e8a3886e99ddaa1b105.tar.gz
gentoo-2-50bdd33d8bb7ee8517600e8a3886e99ddaa1b105.tar.bz2
gentoo-2-50bdd33d8bb7ee8517600e8a3886e99ddaa1b105.zip
set up boost variables to use the right version
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy/widelands')
-rw-r--r--games-strategy/widelands/ChangeLog6
-rw-r--r--games-strategy/widelands/widelands-0.17.ebuild21
2 files changed, 22 insertions, 5 deletions
diff --git a/games-strategy/widelands/ChangeLog b/games-strategy/widelands/ChangeLog
index 82a811a68614..da5d8c820725 100644
--- a/games-strategy/widelands/ChangeLog
+++ b/games-strategy/widelands/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/widelands
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.44 2012/08/04 14:39:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.45 2012/08/28 20:38:39 mr_bones_ Exp $
+
+ 28 Aug 2012; Michael Sterrett <mr_bones_@gentoo.org> widelands-0.17.ebuild:
+ set up boost variables to use the right version
04 Aug 2012; Michael Sterrett <mr_bones_@gentoo.org>
+files/widelands-0.17-gcc47.patch, widelands-0.17.ebuild:
@@ -199,4 +202,3 @@
Initial import. Original ebuild by Elias Kunnas <elias_kunnas@welho.com>.
Ebuild modified by Christoph Brill <egore@gmx.de> and by myself. Original
amd64 patch idea by Peter Roozemaal <mathfox@xs4all.nl>. Closing bug #59674.
-
diff --git a/games-strategy/widelands/widelands-0.17.ebuild b/games-strategy/widelands/widelands-0.17.ebuild
index 2733ab137e12..4f69c4d5a886 100644
--- a/games-strategy/widelands/widelands-0.17.ebuild
+++ b/games-strategy/widelands/widelands-0.17.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.17.ebuild,v 1.4 2012/08/04 14:39:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.17.ebuild,v 1.5 2012/08/28 20:38:39 mr_bones_ Exp $
EAPI=3
-inherit eutils versionator cmake-utils games
+inherit eutils versionator toolchain-funcs flag-o-matic cmake-utils games
MY_PV=build$(get_version_component_range 2)
MY_P=${PN}-${MY_PV}-src
@@ -24,7 +24,7 @@ RDEPEND="dev-lang/lua
media-libs/glew
media-libs/sdl-ttf"
DEPEND="${RDEPEND}
- dev-libs/boost"
+ >=dev-libs/boost-1.37"
S=${WORKDIR}/${MY_P}
@@ -40,6 +40,21 @@ src_prepare() {
sed -i -e '74i#define OF(x) x' src/io/filesystem/{un,}zip.h || die
sed -i -e '22i#define OF(x) x' src/io/filesystem/ioapi.h || die
sed -i -e '/Boost_USE_STATIC_LIBS/s:ON:OFF:' CMakeLists.txt || die
+
+ # how do I hate boost? Let me count the ways...
+ local boost_ver=$(best_version ">=dev-libs/boost-1.37")
+
+ boost_ver=${boost_ver/*boost-/}
+ boost_ver=${boost_ver%.*}
+ boost_ver=${boost_ver/./_}
+
+ einfo "Using boost version ${boost_ver}"
+ append-cxxflags \
+ -I/usr/include/boost-${boost_ver}
+ append-ldflags \
+ -L/usr/$(get_libdir)/boost-${boost_ver}
+ export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
+ export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
}
src_configure() {