summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-07-12 19:34:22 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-07-12 19:34:22 +0000
commit07685837672091a26ee27bbac47c98c84e2b86b1 (patch)
treecd55cde33f4d22459b0a47b0a40a45343cc7b35f /games-strategy/widelands
parentfix glitch in post install instruction, correct printed URL (diff)
downloadgentoo-2-07685837672091a26ee27bbac47c98c84e2b86b1.tar.gz
gentoo-2-07685837672091a26ee27bbac47c98c84e2b86b1.tar.bz2
gentoo-2-07685837672091a26ee27bbac47c98c84e2b86b1.zip
Version bump to 0.16 Bug #361983
(Portage version: 2.1.10.4/cvs/Linux i686)
Diffstat (limited to 'games-strategy/widelands')
-rw-r--r--games-strategy/widelands/ChangeLog8
-rw-r--r--games-strategy/widelands/files/widelands-0.16-goldmine.patch26
-rw-r--r--games-strategy/widelands/widelands-0.16.ebuild60
3 files changed, 93 insertions, 1 deletions
diff --git a/games-strategy/widelands/ChangeLog b/games-strategy/widelands/ChangeLog
index 96f230a8a0fe..159c27382089 100644
--- a/games-strategy/widelands/ChangeLog
+++ b/games-strategy/widelands/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/widelands
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.33 2011/04/26 12:12:49 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.34 2011/07/12 19:34:21 tupone Exp $
+
+*widelands-0.16 (12 Jul 2011)
+
+ 12 Jul 2011; Tupone Alfredo <tupone@gentoo.org> +widelands-0.16.ebuild,
+ +files/widelands-0.16-goldmine.patch:
+ Version bump to 0.16 Bug #361983 by Marshall Banana
26 Apr 2011; Tupone Alfredo <tupone@gentoo.org> widelands-0.15.ebuild,
+files/widelands-0.15-gcc46.patch:
diff --git a/games-strategy/widelands/files/widelands-0.16-goldmine.patch b/games-strategy/widelands/files/widelands-0.16-goldmine.patch
new file mode 100644
index 000000000000..2a2752962e04
--- /dev/null
+++ b/games-strategy/widelands/files/widelands-0.16-goldmine.patch
@@ -0,0 +1,26 @@
+--- tribes/barbarians/deep_goldmine/conf.old 2011-07-12 17:25:38.038927012 +0200
++++ tribes/barbarians/deep_goldmine/conf 2011-07-12 17:26:40.067926999 +0200
+@@ -1,7 +1,7 @@
+ size=mine
+ buildable=no
+ enhanced_building=yes
+-output=gold
++output=goldstone
+ enhancement=deeper_goldmine
+
+ [buildcost]
+@@ -26,11 +26,11 @@
+ sleep=42000
+ consume=snack
+ animate=working 18000
+-mine=coal 2 66 5
+-produce=gold:2
++mine=gold 2 66 5
++produce=goldstone:2
+ animate=working 18000
+ mine=gold 2 66 5
+-produce=gold:2
++produce=goldstone:2
+
+ [idle]
+ pics=deep_goldmine_i_??.png
diff --git a/games-strategy/widelands/widelands-0.16.ebuild b/games-strategy/widelands/widelands-0.16.ebuild
new file mode 100644
index 000000000000..65184b50c94b
--- /dev/null
+++ b/games-strategy/widelands/widelands-0.16.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.16.ebuild,v 1.1 2011/07/12 19:34:21 tupone Exp $
+
+EAPI=3
+
+inherit versionator games cmake-utils
+
+MY_PV=build$(get_version_component_range 2)
+MY_P=${PN}-${MY_PV}-src
+DESCRIPTION="A game similar to Settlers 2"
+HOMEPAGE="http://www.widelands.org/"
+SRC_URI="http://launchpad.net/widelands/${MY_PV}/${MY_PV}/+download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-games/ggz-client-libs
+ dev-lang/lua
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-gfx
+ media-libs/sdl-net
+ media-libs/glew
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+
+S="${WORKDIR}"/${MY_P}
+
+CMAKE_BUILD_TYPE=Release
+PREFIX="${GAMES_DATADIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e 's:__ppc__:__PPC__:' src/s2map.cc \
+ || die "sed s2map.cc failed"
+ epatch "${FILESDIR}"/${P}-goldmine.patch
+}
+
+src_configure() {
+ mycmakeargs+=(
+ '-DWL_VERSION_STANDARD=true'
+ "-DWL_INSTALL_PREFIX=${GAMES_PREFIX}"
+ "-DWL_INSTALL_DATADIR=${GAMES_DATADIR}/${PN}"
+ "-DWL_INSTALL_LOCALEDIR=${GAMES_DATADIR}/${PN}/locale"
+ "-DWL_INSTALL_BINDIR=${GAMES_BINDIR}"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newicon pics/wl-ico-128.png ${PN}.png || die
+ make_desktop_entry ${PN} Widelands
+ dodoc ChangeLog CREDITS
+ prepgamesdirs
+}