summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-02-09 23:11:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-02-09 23:11:56 +0000
commite4ffdcb4a5599ddc02e360b82da516f05454e43f (patch)
treecd6038b9bb7da10306e8cffe09f05ec02d29c005 /games-strategy/wesnoth
parentDrop mask for KDE SC 4.4.0 (diff)
downloadgentoo-2-e4ffdcb4a5599ddc02e360b82da516f05454e43f.tar.gz
gentoo-2-e4ffdcb4a5599ddc02e360b82da516f05454e43f.tar.bz2
gentoo-2-e4ffdcb4a5599ddc02e360b82da516f05454e43f.zip
add dbus support
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog6
-rw-r--r--games-strategy/wesnoth/wesnoth-1.7.12.ebuild8
2 files changed, 11 insertions, 3 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 16d7ee77d5ae..3fe81fb7714f 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.165 2010/01/18 08:08:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.166 2010/02/09 23:11:56 mr_bones_ Exp $
+
+ 09 Feb 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ wesnoth-1.7.12.ebuild:
+ add dbus support
*wesnoth-1.7.12 (18 Jan 2010)
diff --git a/games-strategy/wesnoth/wesnoth-1.7.12.ebuild b/games-strategy/wesnoth/wesnoth-1.7.12.ebuild
index 4a0d6e82979f..901b402047a2 100644
--- a/games-strategy/wesnoth/wesnoth-1.7.12.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.7.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.7.12.ebuild,v 1.1 2010/01/18 08:08:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.7.12.ebuild,v 1.2 2010/02/09 23:11:56 mr_bones_ Exp $
EAPI=2
inherit cmake-utils eutils toolchain-funcs flag-o-matic games
@@ -12,13 +12,16 @@ SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="dedicated doc nls server tinygui"
+IUSE="dbus dedicated doc nls server tinygui"
RDEPEND=">=media-libs/libsdl-1.2.7[video,X]
media-libs/sdl-net
>=media-libs/sdl-ttf-2.0.8
>=media-libs/sdl-mixer-1.2[vorbis]
>=media-libs/sdl-image-1.2[jpeg,png]
+ !dedicated? (
+ dbus? ( sys-apps/dbus )
+ )
dev-libs/boost
sys-libs/zlib
x11-libs/pango
@@ -73,6 +76,7 @@ src_configure() {
$(cmake-utils_use_enable !dedicated GAME)
$(cmake-utils_use_enable !dedicated ENABLE_DESKTOP_ENTRY)
$(cmake-utils_use_enable nls NLS)
+ $(cmake-utils_use_enable dbus NOTIFICATIONS)
-DGUI=$(use tinygui && echo tiny || echo normal)
-DENABLE_FRIBIDI=FALSE
-DENABLE_STRICT_COMPILATION=FALSE