summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-25 08:49:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-25 08:49:14 +0000
commit9cbb8499d2d23e6b9d074157b3c3d93cc47d62ff (patch)
tree565bc2b1817f830a8b4544c79308931fab3bc5e9 /games-strategy/wesnoth
parentmore or less fixed bugs 48694 and 48077 (Manifest recommit) (diff)
downloadgentoo-2-9cbb8499d2d23e6b9d074157b3c3d93cc47d62ff.tar.gz
gentoo-2-9cbb8499d2d23e6b9d074157b3c3d93cc47d62ff.tar.bz2
gentoo-2-9cbb8499d2d23e6b9d074157b3c3d93cc47d62ff.zip
version bump
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog7
-rw-r--r--games-strategy/wesnoth/Manifest2
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.7.51
-rw-r--r--games-strategy/wesnoth/wesnoth-0.7.5.ebuild42
4 files changed, 51 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index f693dcbdbc16..15459efd82b1 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.21 2004/04/21 06:42:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.22 2004/04/25 08:49:14 mr_bones_ Exp $
+
+*wesnoth-0.7.5 (25 Apr 2004)
+
+ 25 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.7.5.ebuild:
+ version bump
20 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.7.3.ebuild:
Work around for broken compile on ppc from Ernst Persson via bug #48326; tidy
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index aa840bbfea87..8215fe7ac265 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -4,7 +4,9 @@ MD5 25b31495b80c6cf66cd73d1e58053201 ChangeLog 3052
MD5 8e682d1d562a88ad935d27893417ffac wesnoth-0.7.2.ebuild 1011
MD5 68343aa5c3c7919a357a99c16b316431 wesnoth-0.7.1.ebuild 957
MD5 e5a28a60716ca01c3d5795c244713c20 wesnoth-0.7.3.ebuild 1089
+MD5 e5a28a60716ca01c3d5795c244713c20 wesnoth-0.7.5.ebuild 1089
MD5 2218dd653ddf591503d9bde5beb4df8c files/digest-wesnoth-0.7 65
MD5 943fc665866e98d256c99403826c7cbd files/digest-wesnoth-0.7.2 67
MD5 eed8758f69d700eedc02234ae1a428d8 files/digest-wesnoth-0.7.1 67
MD5 30a5ab6c2f9337bb39ceb1fa8e5118c7 files/digest-wesnoth-0.7.3 67
+MD5 ff60debaba2a5e123a23173f56bb03e8 files/digest-wesnoth-0.7.5 67
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.7.5 b/games-strategy/wesnoth/files/digest-wesnoth-0.7.5
new file mode 100644
index 000000000000..d5aaf609ab5f
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.7.5
@@ -0,0 +1 @@
+MD5 6f51a8d5cfd32793fa95d1fc036687bb wesnoth-0.7.5.tar.gz 19528534
diff --git a/games-strategy/wesnoth/wesnoth-0.7.5.ebuild b/games-strategy/wesnoth/wesnoth-0.7.5.ebuild
new file mode 100644
index 000000000000..c3ec15f4883b
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.7.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.7.5.ebuild,v 1.1 2004/04/25 08:49:14 mr_bones_ Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc ~sparc"
+IUSE="server editor tools gnome kde"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ virtual/x11"
+
+src_compile() {
+ append-flags -fsigned-char
+
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable gnome) \
+ $(use_enable kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/icons" "${D}/usr/share/"
+ dodoc MANUAL changelog || die "dodoc failed"
+ prepgamesdirs
+}