summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-08-25 08:21:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-08-25 08:21:08 +0000
commit971382affbeb8fd04264c55e3df310acf80e2ce8 (patch)
treeaa63d1c7d460f16b76fc4498929cda436d189e3c /games-strategy/wesnoth
parentStable arm, bug #430346 (diff)
downloadgentoo-2-971382affbeb8fd04264c55e3df310acf80e2ce8.tar.gz
gentoo-2-971382affbeb8fd04264c55e3df310acf80e2ce8.tar.bz2
gentoo-2-971382affbeb8fd04264c55e3df310acf80e2ce8.zip
version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/wesnoth-1.10.4.ebuild117
2 files changed, 123 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index f8b2b8ee66e1..3ce80e1b90e3 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.210 2012/07/11 17:31:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.211 2012/08/25 08:21:08 mr_bones_ Exp $
+
+*wesnoth-1.10.4 (25 Aug 2012)
+
+ 25 Aug 2012; Michael Sterrett <mr_bones_@gentoo.org> +wesnoth-1.10.4.ebuild:
+ version bump
11 Jul 2012; Michael Sterrett <mr_bones_@gentoo.org>
-files/wesnoth-1.10-xdg-path-fix.patch, -wesnoth-1.10.ebuild:
@@ -911,4 +916,3 @@
22 Oct 2003; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.4.8.ebuild:
initial commit; ebuild based on the one provided by Giblets via bug 30603
-
diff --git a/games-strategy/wesnoth/wesnoth-1.10.4.ebuild b/games-strategy/wesnoth/wesnoth-1.10.4.ebuild
new file mode 100644
index 000000000000..e999562406a3
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.10.4.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.10.4.ebuild,v 1.1 2012/08/25 08:21:08 mr_bones_ Exp $
+
+EAPI=2
+inherit cmake-utils eutils multilib toolchain-funcs flag-o-matic games
+
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="dbus dedicated doc nls server"
+
+RDEPEND=">=media-libs/libsdl-1.2.7[video,X]
+ media-libs/sdl-net
+ >=media-libs/sdl-ttf-2.0.8
+ >=media-libs/sdl-mixer-1.2[vorbis]
+ >=media-libs/sdl-image-1.2[jpeg,png]
+ !dedicated? (
+ dbus? ( sys-apps/dbus )
+ )
+ >=dev-libs/boost-1.36
+ sys-libs/zlib
+ x11-libs/pango
+ dev-lang/lua
+ media-libs/fontconfig
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ if use dedicated || use server ; then
+ sed \
+ -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
+ -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
+ -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
+ > "${T}"/wesnothd \
+ || die "sed failed"
+ fi
+ if ! use doc ; then
+ sed -i \
+ -e '/manual/d' \
+ doc/CMakeLists.txt \
+ || die "sed failed"
+ fi
+ # how do I hate boost? Let me count the ways...
+ local boost_ver=$(best_version ">=dev-libs/boost-1.36")
+
+ boost_ver=${boost_ver/*boost-/}
+ boost_ver=${boost_ver%.*}
+ boost_ver=${boost_ver/./_}
+
+ einfo "Using boost version ${boost_ver}"
+ append-cxxflags \
+ -I/usr/include/boost-${boost_ver}
+ append-ldflags \
+ -L/usr/$(get_libdir)/boost-${boost_ver}
+ export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
+ export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
+}
+
+src_configure() {
+ filter-flags -ftracer -fomit-frame-pointer
+ if [[ $(gcc-major-version) -eq 3 ]] ; then
+ filter-flags -fstack-protector
+ append-flags -fno-stack-protector
+ fi
+ if use dedicated || use server ; then
+ mycmakeargs=(
+ "-DENABLE_CAMPAIGN_SERVER=TRUE"
+ "-DENABLE_SERVER=TRUE"
+ "-DSERVER_UID=${GAMES_USER_DED}"
+ "-DSERVER_GID=${GAMES_GROUP}"
+ "-DFIFO_DIR=${GAMES_STATEDIR}/run/wesnothd"
+ )
+ else
+ mycmakeargs=(
+ "-DENABLE_CAMPAIGN_SERVER=FALSE"
+ "-DENABLE_SERVER=FALSE"
+ )
+ fi
+ mycmakeargs+=(
+ $(cmake-utils_use_enable !dedicated GAME)
+ $(cmake-utils_use_enable !dedicated ENABLE_DESKTOP_ENTRY)
+ $(cmake-utils_use_enable nls NLS)
+ $(cmake-utils_use_enable dbus NOTIFICATIONS)
+ "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
+ "-DENABLE_FRIBIDI=FALSE"
+ "-DENABLE_STRICT_COMPILATION=FALSE"
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
+ "-DDATAROOTDIR=${GAMES_DATADIR}"
+ "-DBINDIR=${GAMES_BINDIR}"
+ "-DICONDIR=/usr/share/pixmaps"
+ "-DDESKTOPDIR=/usr/share/applications"
+ "-DMANDIR=/usr/share/man"
+ "-DDOCDIR=/usr/share/doc/${PF}"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="README changelog players_changelog" cmake-utils_src_install
+ if use dedicated || use server; then
+ keepdir "${GAMES_STATEDIR}/run/wesnothd"
+ doinitd "${T}"/wesnothd || die "doinitd failed"
+ fi
+ prepgamesdirs
+}