summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-02-25 05:01:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-02-25 05:01:10 +0000
commit012dc93bd8aa23b1366a665b7aca043a0cec76df (patch)
treea72d93509b88ea8e6ee777f0f7021d307036fb87 /games-strategy/wesnoth
parentFix assertion failure in set_prolog_IO/3 (diff)
downloadgentoo-2-012dc93bd8aa23b1366a665b7aca043a0cec76df.tar.gz
gentoo-2-012dc93bd8aa23b1366a665b7aca043a0cec76df.tar.bz2
gentoo-2-012dc93bd8aa23b1366a665b7aca043a0cec76df.zip
old
(Portage version: 2.1.2-r9)
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-1.0.23
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-1.2.13
-rw-r--r--games-strategy/wesnoth/wesnoth-1.0.2.ebuild83
-rw-r--r--games-strategy/wesnoth/wesnoth-1.2.1.ebuild93
4 files changed, 0 insertions, 182 deletions
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-1.0.2 b/games-strategy/wesnoth/files/digest-wesnoth-1.0.2
deleted file mode 100644
index 47a10ed48665..000000000000
--- a/games-strategy/wesnoth/files/digest-wesnoth-1.0.2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 1d2a26062ce1c90cbf10845023f9435c wesnoth-1.0.2.tar.gz 40034289
-RMD160 20ba5be7078224f65a37d268eaf95be79e0e57c2 wesnoth-1.0.2.tar.gz 40034289
-SHA256 b5201943017e892230cfb1f09a6860b199cb59255ef6aaa19de6a5d365300ac7 wesnoth-1.0.2.tar.gz 40034289
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-1.2.1 b/games-strategy/wesnoth/files/digest-wesnoth-1.2.1
deleted file mode 100644
index 48859d01620c..000000000000
--- a/games-strategy/wesnoth/files/digest-wesnoth-1.2.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 685deee0f92807eddb2b448c8997cd01 wesnoth-1.2.1.tar.gz 74936071
-RMD160 50b4bb877fd15867b04ca1c2371ce683cac8e02b wesnoth-1.2.1.tar.gz 74936071
-SHA256 e86fb8b9c49fdb5c50df9c1bb38201747253bc19fdbbb64329e14ec2abe0b191 wesnoth-1.2.1.tar.gz 74936071
diff --git a/games-strategy/wesnoth/wesnoth-1.0.2.ebuild b/games-strategy/wesnoth/wesnoth-1.0.2.ebuild
deleted file mode 100644
index 5ba504ee4f89..000000000000
--- a/games-strategy/wesnoth/wesnoth-1.0.2.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.0.2.ebuild,v 1.12 2006/12/06 21:07:59 wolf31o2 Exp $
-
-inherit eutils toolchain-funcs flag-o-matic games
-
-MY_PV=${PV/_/}
-DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
-HOMEPAGE="http://www.wesnoth.org/"
-SRC_URI="mirror://sourceforge/wesnoth/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE="dedicated editor gnome kde lite nls server tools"
-
-DEPEND=">=media-libs/libsdl-1.2.7
- !dedicated? (
- x11-libs/libX11
- >=media-libs/freetype-2 )
- >=media-libs/sdl-mixer-1.2
- >=media-libs/sdl-image-1.2
- media-libs/sdl-net
- sys-libs/zlib"
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-pkg_setup() {
- if ! built_with_use -o media-libs/sdl-mixer vorbis oggvorbis ; then
- die "Please emerge sdl-mixer with USE=vorbis"
- fi
- if ! built_with_use media-libs/sdl-image png ; then
- die "Please emerge sdl-image with USE=png"
- fi
- games_pkg_setup
-}
-
-src_unpack() {
- unpack "${A}"
- if use server ; then
- sed \
- -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
- -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
- -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
- -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
- > "${T}"/wesnothd \
- || die "sed failed"
- fi
-
-}
-src_compile() {
- filter-flags -ftracer -fomit-frame-pointer
- if [[ $(gcc-major-version) -eq 3 ]] ; then
- filter-flags -fstack-protector
- append-flags -fno-stack-protector
- fi
- egamesconf \
- --disable-dependency-tracking \
- $(use_enable lite) \
- $(use_enable server) \
- $(use_enable server campaign-server) \
- $(use server && echo --with-server-uid=${GAMES_USER_DED} --with-server-gid=${GAMES_GROUP}) \
- $(use_enable editor) \
- $(use_enable tools) \
- $(use_enable nls) \
- $(use_enable nls dummy-locales) \
- $(use_enable !dedicated game) \
- $(use_with gnome) \
- $(use_with kde) \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- mv "${D}${GAMES_DATADIR}/"{icons,applnk,applications} "${D}/usr/share/"
- dodoc MANUAL changelog
- if use server; then
- keepdir "${GAMES_STATEDIR}/run/wesnothd"
- doinitd "${T}"/wesnothd || die "doinitd failed"
- fi
- prepgamesdirs
-}
diff --git a/games-strategy/wesnoth/wesnoth-1.2.1.ebuild b/games-strategy/wesnoth/wesnoth-1.2.1.ebuild
deleted file mode 100644
index afc2eb4c534b..000000000000
--- a/games-strategy/wesnoth/wesnoth-1.2.1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.2.1.ebuild,v 1.2 2007/02/02 02:47:54 mr_bones_ Exp $
-
-inherit eutils toolchain-funcs flag-o-matic games
-
-MY_PV=${PV/_/}
-DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
-HOMEPAGE="http://www.wesnoth.org/"
-SRC_URI="mirror://sourceforge/wesnoth/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE="dedicated editor gnome kde lite nls server tools"
-
-RDEPEND=">=media-libs/libsdl-1.2.7
- !dedicated? (
- x11-libs/libX11
- >=media-libs/freetype-2 )
- >=media-libs/sdl-mixer-1.2
- >=media-libs/sdl-image-1.2
- media-libs/sdl-net
- nls? ( virtual/libintl )"
-# the configure script is broken and checks for freetype even if
-# it won't be used. until it's either patched out or upstream fixes
-# it, just make it a DEPEND.
-# reported by Miika Linnapuomi
-DEPEND="${RDEPEND}
- dedicated? ( >=media-libs/freetype-2 )
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-pkg_setup() {
- if ! built_with_use -o media-libs/sdl-mixer vorbis oggvorbis ; then
- die "Please emerge sdl-mixer with USE=vorbis"
- fi
- if ! built_with_use media-libs/sdl-image png ; then
- die "Please emerge sdl-image with USE=png"
- fi
- games_pkg_setup
-}
-
-src_unpack() {
- unpack "${A}"
- if use server ; then
- sed \
- -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
- -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
- -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
- -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
- > "${T}"/wesnothd \
- || die "sed failed"
- fi
-}
-
-src_compile() {
- filter-flags -ftracer -fomit-frame-pointer
- if [[ $(gcc-major-version) -eq 3 ]] ; then
- filter-flags -fstack-protector
- append-flags -fno-stack-protector
- fi
- egamesconf \
- --disable-dependency-tracking \
- --without-fribidi \
- --with-localedir=/usr/share/locale \
- --with-icondir=/usr/share/icons \
- --with-desktopdir=/usr/share/applications \
- $(use_enable lite) \
- $(use_enable server) \
- $(use_enable server campaign-server) \
- $(use server && echo --with-server-uid=${GAMES_USER_DED} --with-server-gid=${GAMES_GROUP}) \
- $(use_enable editor) \
- $(use_enable tools) \
- $(use_enable nls) \
- $(use_enable nls dummy-locales) \
- $(use_enable !dedicated game) \
- $(use_with gnome) \
- $(use_with kde) \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc MANUAL changelog
- if use server; then
- keepdir "${GAMES_STATEDIR}/run/wesnothd"
- doinitd "${T}"/wesnothd || die "doinitd failed"
- fi
- prepgamesdirs
-}