summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-11-15 22:00:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-11-15 22:00:09 +0000
commit8c14b8b897223d1e0669096bb4349a3adf71eeec (patch)
treee28923187f5ce4261a056ac1de6ee1dcc8ba050d /games-strategy/warzone2100
parentfix for building gnat when older version is already installed (#86484). No -r... (diff)
downloadgentoo-2-8c14b8b897223d1e0669096bb4349a3adf71eeec.tar.gz
gentoo-2-8c14b8b897223d1e0669096bb4349a3adf71eeec.tar.bz2
gentoo-2-8c14b8b897223d1e0669096bb4349a3adf71eeec.zip
fix compile with USE=-mp3. Patch from Harald van Dijk via bug #112483
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'games-strategy/warzone2100')
-rw-r--r--games-strategy/warzone2100/ChangeLog6
-rw-r--r--games-strategy/warzone2100/files/warzone2100-0.2.2-headers.patch21
-rw-r--r--games-strategy/warzone2100/warzone2100-0.2.2.ebuild26
3 files changed, 40 insertions, 13 deletions
diff --git a/games-strategy/warzone2100/ChangeLog b/games-strategy/warzone2100/ChangeLog
index a43e72952f9b..86ea7f74b299 100644
--- a/games-strategy/warzone2100/ChangeLog
+++ b/games-strategy/warzone2100/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/warzone2100
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.2 2005/10/12 03:09:58 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.3 2005/11/15 22:00:09 mr_bones_ Exp $
+
+ 15 Nov 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/warzone2100-0.2.2-headers.patch, warzone2100-0.2.2.ebuild:
+ fix compile with USE=-mp3. Patch from Harald van Dijk via bug #112483
12 Oct 2005; Chris Gianelloni <wolf31o2@gentoo.org>
warzone2100-0.2.2.ebuild:
diff --git a/games-strategy/warzone2100/files/warzone2100-0.2.2-headers.patch b/games-strategy/warzone2100/files/warzone2100-0.2.2-headers.patch
new file mode 100644
index 000000000000..8c5f70d2aece
--- /dev/null
+++ b/games-strategy/warzone2100/files/warzone2100-0.2.2-headers.patch
@@ -0,0 +1,21 @@
+--- warzone2100-0.2.2/lib/sound/cdaudio.c
++++ warzone2100-0.2.2/lib/sound/cdaudio.c
+@@ -1,3 +1,7 @@
++#include "frame.h"
++#include "audio.h"
++#include "cdaudio.h"
++
+ #ifdef WZ_CDA
+
+ #include <SDL/SDL.h>
+@@ -19,10 +23,6 @@
+
+ #endif
+
+-#include "frame.h"
+-#include "audio.h"
+-#include "cdaudio.h"
+-
+ #ifdef WZ_CDA
+
+ SDL_CD *cdAudio_dev;
diff --git a/games-strategy/warzone2100/warzone2100-0.2.2.ebuild b/games-strategy/warzone2100/warzone2100-0.2.2.ebuild
index 164b1b2c124a..864d9bcfa2ac 100644
--- a/games-strategy/warzone2100/warzone2100-0.2.2.ebuild
+++ b/games-strategy/warzone2100/warzone2100-0.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-0.2.2.ebuild,v 1.2 2005/10/12 03:09:58 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-0.2.2.ebuild,v 1.3 2005/11/15 22:00:09 mr_bones_ Exp $
inherit eutils games
@@ -23,16 +23,19 @@ DEPEND=">=media-libs/libsdl-1.2.8
src_unpack() {
unpack ${A}
- sed s:DATADIR:"${GAMES_DATADIR}/${PN}/": \
+ sed -e "s:DATADIR:${GAMES_DATADIR}/${PN}/:" \
"${FILESDIR}"/${PV}-clparse.c.patch > \
- ${T}/${PV}-clparse.c.patch \
- || die "sed failed"
-
- sed -i 's: -m32::' ${S}/configure || die
- sed -i 's:-m32::' ${S}/makerules/common.mk || die
-
- cd ${S}
- epatch ${T}/${PV}-clparse.c.patch || die "epatch failed"
+ "${T}"/${PV}-clparse.c.patch \
+ || die "sed failed"
+
+ cd "${S}"
+ sed -i \
+ -e 's: -m32::' configure || die
+ sed -i \
+ -e 's:-m32::' makerules/common.mk || die
+ epatch \
+ "${T}"/${PV}-clparse.c.patch \
+ "${FILESDIR}"/${P}-headers.patch
}
src_compile() {
@@ -43,7 +46,7 @@ src_compile() {
$(use_with mp3) \
CFLAGS="${CFLAGS}" \
CPPFLAGS="${CXXFLAGS}" \
- || die "egamesconf failed"
+ || die "egamesconf failed"
emake || die "emake failed"
}
@@ -52,6 +55,5 @@ src_install() {
insinto "${GAMES_DATADIR}"/${PN}
doins -r data/* || die "install data failed"
dodoc AUTHORS CHANGELOG README || "install doc failed"
-
prepgamesdirs
}