summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-01-23 06:29:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-01-23 06:29:25 +0000
commit8af5101646a346044ad1afc84c3852659ae8e774 (patch)
treee9e4305f30bd313e8b13a5c49c36c4deda54e142 /games-strategy/warzone2100
parentAdd new package (phonon split), live ebuild from kde overlay, fixed by me (diff)
downloadgentoo-2-8af5101646a346044ad1afc84c3852659ae8e774.tar.gz
gentoo-2-8af5101646a346044ad1afc84c3852659ae8e774.tar.bz2
gentoo-2-8af5101646a346044ad1afc84c3852659ae8e774.zip
version bump
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-strategy/warzone2100')
-rw-r--r--games-strategy/warzone2100/ChangeLog8
-rw-r--r--games-strategy/warzone2100/warzone2100-2.3.7.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/games-strategy/warzone2100/ChangeLog b/games-strategy/warzone2100/ChangeLog
index 2786011c168b..55db64ce4403 100644
--- a/games-strategy/warzone2100/ChangeLog
+++ b/games-strategy/warzone2100/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/warzone2100
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.59 2011/01/11 22:34:35 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.60 2011/01/23 06:29:25 mr_bones_ Exp $
+
+*warzone2100-2.3.7 (23 Jan 2011)
+
+ 23 Jan 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ +warzone2100-2.3.7.ebuild:
+ version bump
11 Jan 2011; Brent Baude <ranger@gentoo.org> warzone2100-2.3.6.ebuild:
Marking warzone2100-2.3.6 ppc for bug 350429
diff --git a/games-strategy/warzone2100/warzone2100-2.3.7.ebuild b/games-strategy/warzone2100/warzone2100-2.3.7.ebuild
new file mode 100644
index 000000000000..6683fbe63df4
--- /dev/null
+++ b/games-strategy/warzone2100/warzone2100-2.3.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-2.3.7.ebuild,v 1.1 2011/01/23 06:29:25 mr_bones_ Exp $
+
+EAPI=2
+inherit versionator games
+
+MY_PV=$(get_version_component_range -2)
+VIDEOS_PV=2.2
+VIDEOS_P=${PN}-videos-${VIDEOS_PV}.wz
+DESCRIPTION="3D real-time strategy game"
+HOMEPAGE="http://wz2100.net/"
+SRC_URI="mirror://sourceforge/warzone2100/${P}.tar.gz
+ videos? ( mirror://sourceforge/warzone2100/warzone2100/Videos/${VIDEOS_PV}/high-quality-en/sequences.wz -> ${VIDEOS_P} )"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+# upstream requested debug support
+IUSE="debug nls videos"
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-games/physfs-2[zip]
+ dev-libs/popt
+ media-libs/libogg
+ media-libs/libpng
+ media-libs/libsdl[opengl,video]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl-net
+ media-libs/quesoglc
+ virtual/glu
+ virtual/opengl
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/zip
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ media-fonts/dejavu"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ --localedir=/usr/share/locale \
+ --with-distributor="Gentoo ${PF}" \
+ --with-icondir=/usr/share/pixmaps \
+ --with-applicationdir=/usr/share/applications \
+ $(use_enable debug debug relaxed) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING*
+ if use videos ; then
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins "${DISTDIR}"/${VIDEOS_P} sequences.wz || die
+ fi
+ doman pkg/dpkg/warzone2100.6
+ prepgamesdirs
+}