summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-02-05 06:31:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-02-05 06:31:29 +0000
commit28a2ef899ebbc4b2ce58c6cc5ea8b4116233351a (patch)
tree9e3308a188a0f99a5d2141b48cbfc99de14f6b4c /games-strategy/warzone2100
parentVersion bump for Rubicon 1.1; remove obsolete version. (diff)
downloadgentoo-2-28a2ef899ebbc4b2ce58c6cc5ea8b4116233351a.tar.gz
gentoo-2-28a2ef899ebbc4b2ce58c6cc5ea8b4116233351a.tar.bz2
gentoo-2-28a2ef899ebbc4b2ce58c6cc5ea8b4116233351a.zip
version bump (bug #500228)
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy/warzone2100')
-rw-r--r--games-strategy/warzone2100/ChangeLog10
-rw-r--r--games-strategy/warzone2100/files/warzone2100-3.1.1-pkgconf.patch14
-rw-r--r--games-strategy/warzone2100/warzone2100-3.1.1.ebuild105
3 files changed, 127 insertions, 2 deletions
diff --git a/games-strategy/warzone2100/ChangeLog b/games-strategy/warzone2100/ChangeLog
index 55af2a5b0193..21890446880a 100644
--- a/games-strategy/warzone2100/ChangeLog
+++ b/games-strategy/warzone2100/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/warzone2100
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.82 2013/11/07 03:53:08 mr_bones_ Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.83 2014/02/05 06:31:29 mr_bones_ Exp $
+
+*warzone2100-3.1.1 (05 Feb 2014)
+
+ 05 Feb 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/warzone2100-3.1.1-pkgconf.patch, +warzone2100-3.1.1.ebuild:
+ version bump (bug #500228)
07 Nov 2013; Michael Sterrett <mr_bones_@gentoo.org>
-files/warzone2100-2.3.9-pkgconf.patch, -warzone2100-2.3.9.ebuild:
diff --git a/games-strategy/warzone2100/files/warzone2100-3.1.1-pkgconf.patch b/games-strategy/warzone2100/files/warzone2100-3.1.1-pkgconf.patch
new file mode 100644
index 000000000000..0149ea776528
--- /dev/null
+++ b/games-strategy/warzone2100/files/warzone2100-3.1.1-pkgconf.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/show_bug.cgi?id=428494
+
+should be obsolete with >=dev-util/pkgconf-0.8.4
+
+--- warzone2100-3.1.0/configure.ac
++++ warzone2100-3.1.0/configure.ac
+@@ -89,7 +89,6 @@
+
+ # Check for pkg-config
+ PKG_PROG_PKG_CONFIG
+-AC_PROG_VERSION_CHECK([pkg-config], [0.9])
+
+ AC_MSG_CHECKING([for backend])
+ AC_ARG_WITH([backend],
diff --git a/games-strategy/warzone2100/warzone2100-3.1.1.ebuild b/games-strategy/warzone2100/warzone2100-3.1.1.ebuild
new file mode 100644
index 000000000000..824548c9393f
--- /dev/null
+++ b/games-strategy/warzone2100/warzone2100-3.1.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-3.1.1.ebuild,v 1.1 2014/02/05 06:31:29 mr_bones_ Exp $
+
+EAPI=5
+inherit autotools toolchain-funcs eutils versionator gnome2-utils games
+
+MY_PV=$(get_version_component_range -2)
+VIDEOS_PV=2.2
+VIDEOS_P=${PN}-videos-${VIDEOS_PV}.wz
+DESCRIPTION="3D real-time strategy game"
+HOMEPAGE="http://wz2100.net/"
+SRC_URI="mirror://sourceforge/warzone2100/${P}.tar.xz
+ videos? ( mirror://sourceforge/warzone2100/warzone2100/Videos/${VIDEOS_PV}/high-quality-en/sequences.wz -> ${VIDEOS_P} )"
+
+LICENSE="GPL-2 CC-BY-SA-3.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+# upstream requested debug support
+IUSE="debug nls qt4 videos"
+
+# TODO: unbundle miniupnpc and quesoglc
+RDEPEND=">=dev-games/physfs-2[zip]
+ dev-libs/fribidi
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/glew
+ media-libs/libogg
+ media-libs/libpng:0
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/openal
+ sys-libs/zlib
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXrandr
+ dev-qt/qtcore:4
+ dev-qt/qtscript:4
+ nls? ( virtual/libintl )
+ qt4? (
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ )
+ !qt4? ( media-libs/libsdl[opengl,video] )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ app-arch/zip
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ media-fonts/dejavu"
+
+src_prepare() {
+ sed -i \
+ -e 's/#top_builddir/top_builddir/' \
+ po/Makevars || die
+
+ epatch "${FILESDIR}"/${P}-pkgconf.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --docdir=/usr/share/doc/${PF} \
+ --localedir=/usr/share/locale \
+ --with-distributor="Gentoo ${PF}" \
+ --with-icondir=/usr/share/icons/hicolor/128x128/apps \
+ --with-applicationdir=/usr/share/applications \
+ $(use_enable debug debug relaxed) \
+ $(use_enable nls) \
+ --with-backend=$(usex qt4 "qt" "sdl")
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING*
+ if use videos ; then
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins "${DISTDIR}"/${VIDEOS_P} sequences.wz
+ fi
+ doman doc/warzone2100.6
+ dodoc doc/quickstartguide.pdf
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}