summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-10-19 22:54:29 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-10-19 22:54:29 +0000
commit53e6f77c25437d3087213952b2c506cf446e050f (patch)
tree0d3411b6aa4d36e77168ad95335c65f83c9a4449 /games-strategy/uqm
parentversion bump (diff)
downloadgentoo-2-53e6f77c25437d3087213952b2c506cf446e050f.tar.gz
gentoo-2-53e6f77c25437d3087213952b2c506cf446e050f.tar.bz2
gentoo-2-53e6f77c25437d3087213952b2c506cf446e050f.zip
fix bug #438992 and #438980
(Portage version: 2.2.0_alpha140/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-strategy/uqm')
-rw-r--r--games-strategy/uqm/ChangeLog7
-rw-r--r--games-strategy/uqm/uqm-0.7.0-r2.ebuild111
2 files changed, 117 insertions, 1 deletions
diff --git a/games-strategy/uqm/ChangeLog b/games-strategy/uqm/ChangeLog
index d7156e388e8f..61e08d7603b6 100644
--- a/games-strategy/uqm/ChangeLog
+++ b/games-strategy/uqm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/uqm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/uqm/ChangeLog,v 1.38 2012/08/24 19:15:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/uqm/ChangeLog,v 1.39 2012/10/19 22:54:29 hasufell Exp $
+
+*uqm-0.7.0-r2 (19 Oct 2012)
+
+ 19 Oct 2012; Julian Ospald <hasufell@gentoo.org> +uqm-0.7.0-r2.ebuild:
+ fix bug #438992 and #438980
24 Aug 2012; Michael Sterrett <mr_bones_@gentoo.org> -uqm-0.7.0.ebuild:
old
diff --git a/games-strategy/uqm/uqm-0.7.0-r2.ebuild b/games-strategy/uqm/uqm-0.7.0-r2.ebuild
new file mode 100644
index 000000000000..6d1bec0d6660
--- /dev/null
+++ b/games-strategy/uqm/uqm-0.7.0-r2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/uqm/uqm-0.7.0-r2.ebuild,v 1.1 2012/10/19 22:54:29 hasufell Exp $
+
+EAPI=2
+inherit eutils multilib toolchain-funcs games
+
+DESCRIPTION="The Ur-Quan Masters: Port of Star Control 2"
+HOMEPAGE="http://sc2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sc2/${P}-source.tgz
+ mirror://sourceforge/sc2/${P}-content.uqm
+ music? ( mirror://sourceforge/sc2/${P}-3domusic.uqm )
+ voice? ( mirror://sourceforge/sc2/${P}-voice.uqm )
+ remix? ( mirror://sourceforge/sc2/${PN}-remix-disc1.uqm \
+ mirror://sourceforge/sc2/${PN}-remix-disc2.uqm \
+ mirror://sourceforge/sc2/${PN}-remix-disc3.uqm )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="music opengl remix voice"
+
+RDEPEND="media-libs/libmikmod
+ media-libs/libogg
+ >=media-libs/libpng-1.4
+ media-libs/libsdl[X,audio,joystick,video]
+ media-libs/libvorbis
+ media-libs/sdl-image[png]
+ sys-libs/zlib
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ local myopengl
+
+ use opengl \
+ && myopengl=opengl \
+ || myopengl=pure
+
+ cat <<-EOF > config.state
+ CHOICE_debug_VALUE='nodebug'
+ CHOICE_graphics_VALUE='${myopengl}'
+ CHOICE_sound_VALUE='mixsdl'
+ CHOICE_accel_VALUE='plainc'
+ INPUT_install_prefix_VALUE='${GAMES_PREFIX}'
+ INPUT_install_bindir_VALUE='\$prefix/bin'
+ INPUT_install_libdir_VALUE='\$prefix/lib'
+ INPUT_install_sharedir_VALUE='${GAMES_DATADIR}/'
+ EOF
+
+ # Take out the read so we can be non-interactive.
+ sed -i \
+ -e '/read CHOICE/d' build/unix/menu_functions \
+ || die "sed menu_functions failed"
+
+ # respect CFLAGS
+ sed -i \
+ -e "s/-O3//" build/unix/build.config \
+ || die "sed build.config failed"
+
+ sed -i \
+ -e "s:@INSTALL_LIBDIR@:$(games_get_libdir)/:g" build/unix/uqm-wrapper.in \
+ || die "sed uqm-wrapper.in failed"
+
+ # respect CC
+ sed -i \
+ -e 's/PROG_gcc_FILE="gcc"/PROG_gcc_FILE="'$(tc-getCC)'"/' \
+ build/unix/config_proginfo_build \
+ || die "sed config_proginfo_build failed"
+}
+
+src_compile() {
+ MAKE_VERBOSE=1 ./build.sh uqm || die "build failed"
+}
+
+src_install() {
+ # Using the included install scripts seems quite painful.
+ # This manual install is totally fragile but maybe they'll
+ # use a sane build system for the next release.
+ newgamesbin uqm-wrapper uqm || die "newgamesbin failed"
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe uqm || die "doexe failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}/content/packages
+ doins "${DISTDIR}"/${P}-content.uqm || die "doins failed"
+ echo ${P} > "${D}${GAMES_DATADIR}"/${PN}/content/version \
+ || die "creating version file failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}/content/addons
+ if use music; then
+ doins "${DISTDIR}"/${P}-3domusic.uqm || die "doins failed"
+ fi
+
+ if use voice; then
+ doins "${DISTDIR}"/${P}-voice.uqm || die "doins failed"
+ fi
+
+ if use remix; then
+ insinto "${GAMES_DATADIR}"/${PN}/content/addons
+ doins "${DISTDIR}"/${PN}-remix-disc{1,2,3}.uqm || die "doins failed"
+ fi
+
+ dodoc AUTHORS ChangeLog Contributing README WhatsNew doc/users/manual.txt
+ docinto devel
+ dodoc doc/devel/[!n]*
+ docinto devel/netplay
+ dodoc doc/devel/netplay/*
+ make_desktop_entry uqm "The Ur-Quan Masters"
+ prepgamesdirs
+}