summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-02-13 01:52:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-02-13 01:52:22 +0000
commitf16b69696126c4239f3008e6d77efaafc3d2f153 (patch)
treeb983247df4be9bc1a767db05b4f446ecb9fc7d88 /games-strategy/ufo2000/ufo2000-0.4.0.334.ebuild
parenthard-masked asterisk-0.7.2 until new zaptel drivers arrive, header fixed in 2... (diff)
downloadgentoo-2-f16b69696126c4239f3008e6d77efaafc3d2f153.tar.gz
gentoo-2-f16b69696126c4239f3008e6d77efaafc3d2f153.tar.bz2
gentoo-2-f16b69696126c4239f3008e6d77efaafc3d2f153.zip
version bump (bug #41325); music patch from Serge Semashko
Diffstat (limited to 'games-strategy/ufo2000/ufo2000-0.4.0.334.ebuild')
-rw-r--r--games-strategy/ufo2000/ufo2000-0.4.0.334.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/games-strategy/ufo2000/ufo2000-0.4.0.334.ebuild b/games-strategy/ufo2000/ufo2000-0.4.0.334.ebuild
new file mode 100644
index 000000000000..d2159fb0e3f0
--- /dev/null
+++ b/games-strategy/ufo2000/ufo2000-0.4.0.334.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo2000/ufo2000-0.4.0.334.ebuild,v 1.1 2004/02/13 01:52:22 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Free multiplayer remake of X-COM (UFO: Enemy Unknown)"
+HOMEPAGE="http://ufo2000.sourceforge.net/"
+SRC_URI="http://ufo2000.lxnt.info/files/${P}-src.tar.bz2
+ ftp://ftp.microprose.com/pub/mps-online/x-com/xcomdemo.zip
+ ftp://ftp.microprose.com/pub/mps-online/demos/terror.zip"
+
+KEYWORDS="-* ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/glibc
+ >=media-libs/allegro-4.0.0
+ >=dev-lang/lua-5.0
+ >=dev-games/hawknl-1.66
+ >=media-libs/aldumb-0.9.2
+ media-libs/libogg
+ media-libs/libvorbis
+ dev-libs/expat"
+
+src_unpack() {
+ unpack ${P}-src.tar.bz2
+
+ cd "${S}/XCOMDEMO"
+ unpack xcomdemo.zip
+ unzip -LL XCOM.EXE -d ..
+ rm XCOM.EXE
+ mv ../xcomdemo/* "${S}/XCOMDEMO/"
+
+ cd "${S}/TFTDDEMO"
+ unpack terror.zip
+ unzip -LL TFTD.ZIP
+ rm TFTD.ZIP
+}
+
+src_compile() {
+ emake \
+ DATA_DIR="${GAMES_DATADIR}/${PN}" \
+ OPTFLAGS="${CXXFLAGS}" \
+ dumbogg=1 \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ufo2000 || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -R arts newmaps newmusic newunits init-scripts script \
+ XCOMDEMO XCOM TFTDDEMO TFTD \
+ *.dat armoury.set ufo2000.ini soundmap.xml \
+ "${D}/${GAMES_DATADIR}/${PN}" \
+ || die "cp failed"
+ keepdir "${GAMES_DATADIR}/${PN}/newmusic"
+ echo "Please copy data files from X-COM here" > \
+ "${D}/${GAMES_DATADIR}/${PN}/XCOM/readme.txt"
+ echo "Please copy data files from TFTD here" > \
+ "${D}/${GAMES_DATADIR}/${PN}/TFTD/readme.txt"
+ dodoc *.txt INSTALL AUTHORS ChangeLog || die "dodoc failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "If you have a full version of X-COM, you can copy all the files"
+ einfo "from the directory where you have it installed into:"
+ einfo " ${GAMES_DATADIR}/${PN}/XCOM"
+ echo
+ einfo "Likewise for Terror From The Deep, but to the directory:"
+ einfo " ${GAMES_DATADIR}/${PN}/TFTD"
+ echo
+ einfo "This will allow you to use more terrain types and units."
+ echo
+}