summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-11-28 18:21:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-11-28 18:21:11 +0000
commitbb249877c40441763046460a6b1a2db3f9ca3f24 (patch)
tree4c49d45d611d0b25b264eb513fe2b3729541e3a7 /games-strategy/ufo-ai
parentAdded block of >=tetex-3.0 as this package is now part of tetex. (diff)
downloadgentoo-2-bb249877c40441763046460a6b1a2db3f9ca3f24.tar.gz
gentoo-2-bb249877c40441763046460a6b1a2db3f9ca3f24.tar.bz2
gentoo-2-bb249877c40441763046460a6b1a2db3f9ca3f24.zip
tidy
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'games-strategy/ufo-ai')
-rw-r--r--games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild b/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild
index d95e8f7cd98f..1764d2135073 100644
--- a/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild
+++ b/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild,v 1.15 2004/11/03 00:33:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ufo-ai-0.10.040218.ebuild,v 1.16 2005/11/28 18:21:11 mr_bones_ Exp $
-inherit eutils games flag-o-matic
+inherit eutils flag-o-matic games
DESCRIPTION="UFO: Alien Invasion - X-COM inspired strategy game"
HOMEPAGE="http://www.ufoai.net/"
@@ -14,25 +14,24 @@ SLOT="0"
KEYWORDS="~ppc ~x86"
IUSE=""
-RDEPEND="virtual/libc
- virtual/x11
+RDEPEND="virtual/x11
media-libs/jpeg
media-libs/libvorbis
media-libs/libogg"
DEPEND="${RDEPEND}
app-arch/unzip"
-S="${WORKDIR}"
+S=${WORKDIR}
src_unpack() {
unpack ${A}
cd source/linux
- epatch "${FILESDIR}/${PV}-Makefile.patch"
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
}
src_compile() {
filter-flags -fstack-protector #51116
- cd "${S}/source/linux"
+ cd "${S}"/source/linux
emake build_release \
OPTCFLAGS="${CFLAGS}" \
|| die "emake failed"
@@ -40,15 +39,15 @@ src_compile() {
src_install() {
dodir "${GAMES_DATADIR}/${PN}"
- cp -rf "${S}/ufo/"* "${D}${GAMES_DATADIR}/${PN}" || die "copying data"
+ cp -rf "${S}"/ufo/* "${D}${GAMES_DATADIR}/${PN}" || die "cp failed"
if use x86 ; then
ARCH=i386
fi
exeinto "${GAMES_DATADIR}/${PN}"
- doexe "${S}/source/linux/release${ARCH}-glibc/"{ref_gl.so,ref_glx.so,ufo} \
+ doexe "${S}"/source/linux/release${ARCH}-glibc/{ref_gl.so,ref_glx.so,ufo} \
|| die "doexe ufo"
exeinto "${GAMES_DATADIR}/${PN}/base"
- doexe "${S}/source/linux/release${ARCH}-glibc/game${ARCH}.so" \
+ doexe "${S}"/source/linux/release${ARCH}-glibc/game${ARCH}.so \
|| die "doexe game${ARCH}.so"
games_make_wrapper ufo-ai ./ufo "${GAMES_DATADIR}/${PN}"
prepgamesdirs