summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-06-05 08:25:24 +0000
committerSergey Popov <pinkbyte@gentoo.org>2015-06-05 08:25:24 +0000
commit0ee893e66a3b58117a4f61aee18b5974c60e3ae2 (patch)
treea635377b1fa26ec57fc7c6bc05fbe17547824e89 /games-strategy/seven-kingdoms
parentMark arm64/m68k/s390/sh stable. (diff)
downloadgentoo-2-0ee893e66a3b58117a4f61aee18b5974c60e3ae2.tar.gz
gentoo-2-0ee893e66a3b58117a4f61aee18b5974c60e3ae2.tar.bz2
gentoo-2-0ee893e66a3b58117a4f61aee18b5974c60e3ae2.zip
Version bump, wrt bug #551234. Thanks to Martin Walch <walch.martin AT web.de> for discovering this issue
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x60C0742D1F357D42)
Diffstat (limited to 'games-strategy/seven-kingdoms')
-rw-r--r--games-strategy/seven-kingdoms/ChangeLog9
-rw-r--r--games-strategy/seven-kingdoms/seven-kingdoms-2.14.5.ebuild56
2 files changed, 64 insertions, 1 deletions
diff --git a/games-strategy/seven-kingdoms/ChangeLog b/games-strategy/seven-kingdoms/ChangeLog
index b8eb3c98f20c..4291ebb24fd2 100644
--- a/games-strategy/seven-kingdoms/ChangeLog
+++ b/games-strategy/seven-kingdoms/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-strategy/seven-kingdoms
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/seven-kingdoms/ChangeLog,v 1.9 2015/05/27 11:00:56 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/seven-kingdoms/ChangeLog,v 1.10 2015/06/05 08:25:24 pinkbyte Exp $
+
+*seven-kingdoms-2.14.5 (05 Jun 2015)
+
+ 05 Jun 2015; Sergey Popov <pinkbyte@gentoo.org>
+ +seven-kingdoms-2.14.5.ebuild:
+ Version bump, wrt bug #551234. Thanks to Martin Walch <walch.martin AT
+ web.de> for discovering this issue
27 May 2015; Agostino Sarubbo <ago@gentoo.org> seven-kingdoms-2.14.4.ebuild:
Stable for x86, wrt bug #550450
diff --git a/games-strategy/seven-kingdoms/seven-kingdoms-2.14.5.ebuild b/games-strategy/seven-kingdoms/seven-kingdoms-2.14.5.ebuild
new file mode 100644
index 000000000000..452a1329d256
--- /dev/null
+++ b/games-strategy/seven-kingdoms/seven-kingdoms-2.14.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/seven-kingdoms/seven-kingdoms-2.14.5.ebuild,v 1.1 2015/06/05 08:25:24 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils games
+
+MY_PN="7kaa"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Seven Kingdoms: Ancient Adversaries"
+HOMEPAGE="http://7kfans.com/"
+SRC_URI="mirror://sourceforge/skfans/${MY_PN}-${PV}.tar.xz
+ http://dev.gentoo.org/~pinkbyte/distfiles/${MY_PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="net-libs/enet:1.3=
+ media-libs/libsdl2[X,video]
+ media-libs/openal
+ !games-strategy/seven-kingdoms-data"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( README )
+
+src_unpack() {
+ unpack ${MY_PN}-${PV}.tar.xz
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ # In current state debugging works only on Windows :-/
+ egamesconf \
+ --disable-debug \
+ --without-wine \
+ --datadir="${GAMES_DATADIR}/${MY_PN}"
+}
+
+src_install() {
+ default
+
+ newgamesbin "src/client/${MY_PN}" "${MY_PN}.bin"
+ doicon "${DISTDIR}/${MY_PN}.png"
+ games_make_wrapper "${MY_PN}" "${GAMES_BINDIR}/${MY_PN}.bin" "${GAMES_DATADIR}/${MY_PN}"
+ make_desktop_entry "${MY_PN}" "Seven Kingdoms: Ancient Adversaries" "${MY_PN}" "Game;StrategyGame"
+
+ prepgamesdirs
+}