summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-02-20 17:48:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-02-20 17:48:06 +0000
commitc27515220aa95aad4555dbc9b8be5fc8e384a22b (patch)
tree9d71d08443574adfe2efc0477f2ee5cb71bf8dc7 /games-strategy/scorched3d
parentadd dev-util/pkgconfig to DEPEND. fix bug #259023 (diff)
downloadgentoo-2-c27515220aa95aad4555dbc9b8be5fc8e384a22b.tar.gz
gentoo-2-c27515220aa95aad4555dbc9b8be5fc8e384a22b.tar.bz2
gentoo-2-c27515220aa95aad4555dbc9b8be5fc8e384a22b.zip
add back gcc43 patch (rerolled by Arttu Valo in bug #259406)
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'games-strategy/scorched3d')
-rw-r--r--games-strategy/scorched3d/ChangeLog6
-rw-r--r--games-strategy/scorched3d/files/scorched3d-42-gcc43.patch101
-rw-r--r--games-strategy/scorched3d/scorched3d-42.ebuild6
3 files changed, 110 insertions, 3 deletions
diff --git a/games-strategy/scorched3d/ChangeLog b/games-strategy/scorched3d/ChangeLog
index 32768a87e770..e6de66e533e3 100644
--- a/games-strategy/scorched3d/ChangeLog
+++ b/games-strategy/scorched3d/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/scorched3d
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/ChangeLog,v 1.59 2009/02/16 03:19:07 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/ChangeLog,v 1.60 2009/02/20 17:48:06 mr_bones_ Exp $
+
+ 20 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/scorched3d-42-gcc43.patch, scorched3d-42.ebuild:
+ add back gcc43 patch (rerolled by Arttu Valo in bug #259406)
*scorched3d-42 (16 Feb 2009)
diff --git a/games-strategy/scorched3d/files/scorched3d-42-gcc43.patch b/games-strategy/scorched3d/files/scorched3d-42-gcc43.patch
new file mode 100644
index 000000000000..6497e3cf5419
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-42-gcc43.patch
@@ -0,0 +1,101 @@
+diff -ur scorched.old/src/client/console/ConsoleImpl.cpp scorched/src/client/console/ConsoleImpl.cpp
+--- scorched.old/src/client/console/ConsoleImpl.cpp 2009-02-18 20:06:23.000000000 +0200
++++ scorched/src/client/console/ConsoleImpl.cpp 2009-02-18 20:39:23.000000000 +0200
+@@ -26,6 +26,7 @@
+ #include <GLEXT/GLViewPort.h>
+ #include <GLW/GLWFont.h>
+ #include <GLW/GLWToolTip.h>
++#include <climits>
+
+ ConsoleImpl::ConsoleImpl() :
+ GameStateI("Console"),
+diff -ur scorched.old/src/common/common/DefinesFile.cpp scorched/src/common/common/DefinesFile.cpp
+--- scorched.old/src/common/common/DefinesFile.cpp 2009-02-18 20:06:22.000000000 +0200
++++ scorched/src/common/common/DefinesFile.cpp 2009-02-18 20:07:58.000000000 +0200
+@@ -24,6 +24,7 @@
+ #include <common/DefinesFile.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <cstring>
+
+ #pragma warning(disable : 4996)
+
+diff -ur scorched.old/src/common/common/LoggerI.cpp scorched/src/common/common/LoggerI.cpp
+--- scorched.old/src/common/common/LoggerI.cpp 2009-02-18 20:06:22.000000000 +0200
++++ scorched/src/common/common/LoggerI.cpp 2009-02-18 20:14:55.000000000 +0200
+@@ -20,6 +20,7 @@
+
+ #include <common/LoggerI.h>
+ #include <time.h>
++#include <cstring>
+
+ LoggerInfo::LoggerInfo(
+ const std::string &message,
+diff -ur scorched.old/src/common/common/main.h scorched/src/common/common/main.h
+--- scorched.old/src/common/common/main.h 2009-02-18 20:06:22.000000000 +0200
++++ scorched/src/common/common/main.h 2009-02-18 20:07:18.000000000 +0200
+@@ -40,7 +40,7 @@
+ void _no_storage()
+ {
+ printf("Failed to allocate memory!!");
+- std::exit(1);
++ exit(1);
+ }
+
+ void run_main(int argc, char *argv[], OptionsParameters &params)
+diff -ur scorched.old/src/common/common/sha2.h scorched/src/common/common/sha2.h
+--- scorched.old/src/common/common/sha2.h 2009-02-18 20:06:22.000000000 +0200
++++ scorched/src/common/common/sha2.h 2009-02-18 20:24:57.000000000 +0200
+@@ -46,6 +46,7 @@
+
+ #include <string>
+ #include <stdexcept>
++#include <cstring>
+
+ // NOTE: You may need to define things by hand for your system:
+ typedef unsigned char sha_byte; // Exactly 1 byte
+diff -ur scorched.old/src/common/landscapemap/HeightMapModifier.cpp scorched/src/common/landscapemap/HeightMapModifier.cpp
+--- scorched.old/src/common/landscapemap/HeightMapModifier.cpp 2009-02-18 20:06:22.000000000 +0200
++++ scorched/src/common/landscapemap/HeightMapModifier.cpp 2009-02-18 20:28:50.000000000 +0200
+@@ -26,6 +26,7 @@
+ #include <image/ImageBitmap.h>
+ #include <image/ImageFactory.h>
+ #include <lang/LangResource.h>
++#include <climits>
+
+ void HeightMapModifier::levelSurround(HeightMap &hmap)
+ {
+diff -ur scorched.old/src/common/lang/LangParam.cpp scorched/src/common/lang/LangParam.cpp
+--- scorched.old/src/common/lang/LangParam.cpp 2009-02-18 20:06:22.000000000 +0200
++++ scorched/src/common/lang/LangParam.cpp 2009-02-18 20:22:06.000000000 +0200
+@@ -20,6 +20,7 @@
+
+ #include <lang/LangParam.h>
+ #include <common/DefinesString.h>
++#include <cstdlib>
+
+ LangParam::LangParam(const LangStringConverter &convValue)
+ {
+diff -ur scorched.old/src/common/lang/ResourceBundle.h scorched/src/common/lang/ResourceBundle.h
+--- scorched.old/src/common/lang/ResourceBundle.h 2009-02-18 20:06:22.000000000 +0200
++++ scorched/src/common/lang/ResourceBundle.h 2009-02-18 20:20:12.000000000 +0200
+@@ -23,6 +23,7 @@
+
+ #include <set>
+ #include <lang/ResourceBundleEntry.h>
++#include <cstring>
+
+ class ResourceBundle
+ {
+diff -ur scorched.old/src/common/porting/windows.h scorched/src/common/porting/windows.h
+--- scorched.old/src/common/porting/windows.h 2009-02-18 20:06:22.000000000 +0200
++++ scorched/src/common/porting/windows.h 2009-02-18 20:06:46.000000000 +0200
+@@ -20,7 +20,7 @@
+ typedef unsigned short WORD;
+ typedef unsigned char BYTE;
+
+-typedef int HWND;
++// typedef int HWND;
+ typedef void * HINSTANCE;
+ typedef int WPARAM;
+ typedef int LPARAM;
diff --git a/games-strategy/scorched3d/scorched3d-42.ebuild b/games-strategy/scorched3d/scorched3d-42.ebuild
index ed6b5c89a71d..e876f10de3f4 100644
--- a/games-strategy/scorched3d/scorched3d-42.ebuild
+++ b/games-strategy/scorched3d/scorched3d-42.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/scorched3d-42.ebuild,v 1.1 2009/02/16 03:19:07 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/scorched3d-42.ebuild,v 1.2 2009/02/20 17:48:06 mr_bones_ Exp $
EAPI=2
inherit autotools eutils wxwidgets games
@@ -35,7 +35,9 @@ DEPEND="media-libs/libsdl
S=${WORKDIR}/scorched
src_prepare() {
- epatch "${FILESDIR}"/${P}-fixups.patch
+ epatch \
+ "${FILESDIR}"/${P}-fixups.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
eautoreconf
}