summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-05-03 17:02:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-05-03 17:02:43 +0000
commit65ab44fc07dfa78f600271eab112bb7c8bd71b11 (patch)
treeb02bbaf1493cf8b89faacbec25cfc28794dbbfc3 /games-strategy/scorched3d
parentBump for #317955 with compile fix by Kerin Millar (diff)
downloadgentoo-2-65ab44fc07dfa78f600271eab112bb7c8bd71b11.tar.gz
gentoo-2-65ab44fc07dfa78f600271eab112bb7c8bd71b11.tar.bz2
gentoo-2-65ab44fc07dfa78f600271eab112bb7c8bd71b11.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-strategy/scorched3d')
-rw-r--r--games-strategy/scorched3d/ChangeLog11
-rw-r--r--games-strategy/scorched3d/files/scorched3d-43.1c-fixups.patch58
-rw-r--r--games-strategy/scorched3d/files/scorched3d-43.1c-gcc43.patch24
-rw-r--r--games-strategy/scorched3d/files/scorched3d-43.1c-libpng14.patch40
-rw-r--r--games-strategy/scorched3d/files/scorched3d-43.1c-odbc.patch17
-rw-r--r--games-strategy/scorched3d/files/scorched3d-43.1c-win32.patch19
-rw-r--r--games-strategy/scorched3d/scorched3d-43.1c.ebuild64
7 files changed, 232 insertions, 1 deletions
diff --git a/games-strategy/scorched3d/ChangeLog b/games-strategy/scorched3d/ChangeLog
index e5e523e00e4d..a70f3cf88c80 100644
--- a/games-strategy/scorched3d/ChangeLog
+++ b/games-strategy/scorched3d/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for games-strategy/scorched3d
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/ChangeLog,v 1.70 2010/04/07 20:07:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/ChangeLog,v 1.71 2010/05/03 17:02:43 mr_bones_ Exp $
+
+*scorched3d-43.1c (03 May 2010)
+
+ 03 May 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +scorched3d-43.1c.ebuild, +files/scorched3d-43.1c-fixups.patch,
+ +files/scorched3d-43.1c-gcc43.patch,
+ +files/scorched3d-43.1c-libpng14.patch,
+ +files/scorched3d-43.1c-odbc.patch, +files/scorched3d-43.1c-win32.patch:
+ version bump
*scorched3d-43.1b (07 Apr 2010)
diff --git a/games-strategy/scorched3d/files/scorched3d-43.1c-fixups.patch b/games-strategy/scorched3d/files/scorched3d-43.1c-fixups.patch
new file mode 100644
index 000000000000..36a027cb60cc
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-43.1c-fixups.patch
@@ -0,0 +1,58 @@
+diff -ru scorched.orig/configure-al.m4 scorched/configure-al.m4
+--- scorched.orig/configure-al.m4 2008-03-03 16:17:18.000000000 -0500
++++ scorched/configure-al.m4 2009-02-15 20:43:35.000000000 -0500
+@@ -7,25 +7,9 @@
+ [ --disable-openaltest Do not try to compile and run a test OpenAL program],
+ , enable_openaltest=yes)
+ AC_MSG_CHECKING(for OpenAL support)
+-AC_PATH_PROG(OPENAL_CONFIG, openal-config, no)
+-if test x$OPENAL_CONFIG = xno; then
+- echo "*** The openal-config script installed by OpenAL could not be found"
+- echo "*** Make sure openal-config is in your path, or set the OPENAL_CONFIG"
+- echo "*** environment variable to the full path to openal-config."
+-
+- AC_MSG_ERROR([*** Can't find the openal library. Try: http://www.openal.org/])
+-else
+-
+- if test x"$use_static_openal" = x"yes"; then
+- AL_LIBS="/usr/local/lib/libopenal.a"
+- else
+- AL_LIBS="`$OPENAL_CONFIG --libs`"
+- fi
+-
+- AL_CFLAGS="`$OPENAL_CONFIG --cflags`"
+-
+- AC_MSG_RESULT(yes)
+-fi
++AL_LIBS="-lopenal"
++AL_CFLAGS="-I/usr/include/AL"
++AC_MSG_RESULT(yes)
+
+ AC_MSG_CHECKING(for Freealut support)
+ AC_PATH_PROG(FREEALUT_CONFIG, freealut-config, no)
+diff -ru scorched.orig/configure.ac scorched/configure.ac
+--- scorched.orig/configure.ac 2008-03-03 16:17:18.000000000 -0500
++++ scorched/configure.ac 2009-02-15 20:40:30.000000000 -0500
+@@ -13,22 +13,6 @@
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+
+-LDFLAGS="-L/usr/X11R6/lib -L/usr/X11R6"
+-CPPFLAGS="-I/usr/X11R6/include -I/usr/X11R6"
+-
+-if test `uname` == Darwin; then
+-LDFLAGS="$LDFLAGS -lmx"
+-CPPFLAGS="$CPPFLAGS -DFFTW_USE_DOUBLE -D__DARWIN__ -D__MACOSX__"
+-else
+-LDFLAGS="$LDFLAGS -L/usr/local/lib"
+-CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+-fi
+-
+-AC_CHECK_LIB(fridge, beer, echo "Hmm?!",[
+- echo "Warning: No beer found in fridge!";
+- echo "We highly suggest that you rectify this situation immediately."
+-])
+-
+ AC_ARG_ENABLE(serveronly,
+ [ --enable-serveronly Enable server only compilation],
+ , enable_serveronly=no,
diff --git a/games-strategy/scorched3d/files/scorched3d-43.1c-gcc43.patch b/games-strategy/scorched3d/files/scorched3d-43.1c-gcc43.patch
new file mode 100644
index 000000000000..b235f07c585f
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-43.1c-gcc43.patch
@@ -0,0 +1,24 @@
+diff -ur scorched.old/src/common/common/main.h scorched/src/common/common/main.h
+--- scorched.old/src/common/common/main.h 2009-02-18 20:06:22.000000000 +0200
++++ scorched/src/common/common/main.h 2009-02-18 20:07:18.000000000 +0200
+@@ -40,7 +40,7 @@
+ void _no_storage()
+ {
+ printf("Failed to allocate memory!!");
+- std::exit(1);
++ exit(1);
+ }
+
+ void run_main(int argc, char *argv[], OptionsParameters &params)
+diff -ur scorched.old/src/common/porting/windows.h scorched/src/common/porting/windows.h
+--- scorched.old/src/common/porting/windows.h 2009-02-18 20:06:22.000000000 +0200
++++ scorched/src/common/porting/windows.h 2009-02-18 20:06:46.000000000 +0200
+@@ -20,7 +20,7 @@
+ typedef unsigned short WORD;
+ typedef unsigned char BYTE;
+
+-typedef int HWND;
++// typedef int HWND;
+ typedef void * HINSTANCE;
+ typedef int WPARAM;
+ typedef int LPARAM;
diff --git a/games-strategy/scorched3d/files/scorched3d-43.1c-libpng14.patch b/games-strategy/scorched3d/files/scorched3d-43.1c-libpng14.patch
new file mode 100644
index 000000000000..d61a2b6ac485
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-43.1c-libpng14.patch
@@ -0,0 +1,40 @@
+http://bugs.gentoo.org/show_bug.cgi?id=308867
+
+--- src/common/image/ImagePng.cpp
++++ src/common/image/ImagePng.cpp
+@@ -189,7 +189,7 @@ bool ImagePng::loadFromBuffer(NetBuffer
+ info_ptr = png_create_info_struct(png_ptr);
+ if (info_ptr == NULL)
+ {
+- png_destroy_read_struct(&png_ptr, png_infopp_NULL, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, NULL, NULL);
+ return false;
+ }
+
+@@ -200,7 +200,7 @@ bool ImagePng::loadFromBuffer(NetBuffer
+ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ /* If we get here, we had a problem reading the file */
+ return false;
+ }
+@@ -258,7 +258,7 @@ bool ImagePng::loadFromBuffer(NetBuffer
+ }
+ else
+ {
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+
+ Logger::log(S3D::formatStringBuffer(
+ "Invalid PNG format.\n"
+@@ -272,7 +272,7 @@ bool ImagePng::loadFromBuffer(NetBuffer
+ // END NEW CODE
+
+ /* clean up after the read, and free any memory allocated - REQUIRED */
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+
+ /* that's it */
+ return true;
diff --git a/games-strategy/scorched3d/files/scorched3d-43.1c-odbc.patch b/games-strategy/scorched3d/files/scorched3d-43.1c-odbc.patch
new file mode 100644
index 000000000000..355755e7cdb0
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-43.1c-odbc.patch
@@ -0,0 +1,17 @@
+When x11-libs/wxGTK is built with the odbc use flag, scorched3d fails to build.
+bug #285384 - patch from Bob Johnson
+
+diff -urN scorched/src/common/porting/windows.h fix_scorched/src/common/porting/windows.h
+--- scorched/src/common/porting/windows.h 2009-09-21 10:21:16.000000000 -0700
++++ fix_scorched/src/common/porting/windows.h 2009-09-21 10:39:02.000000000 -0700
+@@ -11,8 +11,8 @@
+
+ typedef char * LPSTR;
+ typedef const char * LPCTSTR;
+-typedef unsigned int DWORD;
+-typedef unsigned int * LPDWORD;
++typedef unsigned long DWORD;
++typedef DWORD * LPDWORD;
+ typedef unsigned char * LPBYTE;
+ typedef int INT;
+ typedef long LONG;
diff --git a/games-strategy/scorched3d/files/scorched3d-43.1c-win32.patch b/games-strategy/scorched3d/files/scorched3d-43.1c-win32.patch
new file mode 100644
index 000000000000..8b63d509147c
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-43.1c-win32.patch
@@ -0,0 +1,19 @@
+diff -ur scorched.old/src/common/porting/windows.h scorched/src/common/porting/windows.h
+--- scorched.old/src/common/porting/windows.h 2009-12-17 15:18:41.000000000 +0200
++++ scorched/src/common/porting/windows.h 2009-12-17 15:22:20.000000000 +0200
+@@ -9,6 +9,7 @@
+ #include <ctype.h>
+ #include <common/Defines.h>
+
++#ifdef _WIN32
+ typedef char * LPSTR;
+ typedef const char * LPCTSTR;
+ typedef unsigned int DWORD;
+@@ -27,6 +28,7 @@
+ typedef int LRESULT;
+ typedef void * HDC;
+ typedef void * HGLRC;
++#endif /* _WIN32 */
+
+ #define _strnicmp(a,b,c) strncasecmp(a,b,c)
+ #define stricmp(a,b) strcasecmp(a,b)
diff --git a/games-strategy/scorched3d/scorched3d-43.1c.ebuild b/games-strategy/scorched3d/scorched3d-43.1c.ebuild
new file mode 100644
index 000000000000..c6c0ae4cbfb0
--- /dev/null
+++ b/games-strategy/scorched3d/scorched3d-43.1c.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/scorched3d-43.1c.ebuild,v 1.1 2010/05/03 17:02:43 mr_bones_ Exp $
+
+EAPI=2
+WX_GTK_VER=2.8
+inherit autotools eutils wxwidgets games
+
+DESCRIPTION="Multi-player tank battle in 3D (OpenGL)"
+HOMEPAGE="http://www.scorched3d.co.uk/"
+SRC_URI="mirror://sourceforge/${PN}/Scorched3D-${PV}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="dedicated mysql"
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-net
+ media-libs/libpng
+ media-libs/jpeg:0
+ dev-libs/expat
+ !dedicated? (
+ virtual/opengl
+ virtual/glu
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/freealut
+ x11-libs/wxGTK:2.8[X]
+ media-libs/freetype:2
+ sci-libs/fftw:3.0
+ )
+ mysql? ( virtual/mysql )"
+
+S=${WORKDIR}/scorched
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-*.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-fftw=/usr \
+ --with-ogg=/usr \
+ --with-vorbis=/usr \
+ --datadir="${GAMES_DATADIR}/${PN}" \
+ --with-docdir="/usr/share/doc/${PF}" \
+ --with-wx-config="${WX_CONFIG}" \
+ --without-pgsql \
+ $(use_with mysql) \
+ $(use_enable dedicated serveronly)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if ! use dedicated ; then
+ newicon data/images/tank.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Scorched 3D" /usr/share/pixmaps/${PN}.bmp
+ fi
+ prepgamesdirs
+}