summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-04 20:46:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-04 20:46:55 +0000
commitf170ac8c8dae0ec516a962eea7267503373414b4 (patch)
treeb4f1e55f987726562abbc102b69b90489b1ace8f /games-strategy/scorched3d/files
parentFix usage of python.eclass, thanks to Arfrever for mentioning it. (diff)
downloadgentoo-2-f170ac8c8dae0ec516a962eea7267503373414b4.tar.gz
gentoo-2-f170ac8c8dae0ec516a962eea7267503373414b4.tar.bz2
gentoo-2-f170ac8c8dae0ec516a962eea7267503373414b4.zip
version bump
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-strategy/scorched3d/files')
-rw-r--r--games-strategy/scorched3d/files/scorched3d-43-fixups.patch58
-rw-r--r--games-strategy/scorched3d/files/scorched3d-43-gcc43.patch24
-rw-r--r--games-strategy/scorched3d/files/scorched3d-43-libpng14.patch40
-rw-r--r--games-strategy/scorched3d/files/scorched3d-43-odbc.patch17
-rw-r--r--games-strategy/scorched3d/files/scorched3d-43-win32.patch19
5 files changed, 158 insertions, 0 deletions
diff --git a/games-strategy/scorched3d/files/scorched3d-43-fixups.patch b/games-strategy/scorched3d/files/scorched3d-43-fixups.patch
new file mode 100644
index 000000000000..36a027cb60cc
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-43-fixups.patch
@@ -0,0 +1,58 @@
+diff -ru scorched.orig/configure-al.m4 scorched/configure-al.m4
+--- scorched.orig/configure-al.m4 2008-03-03 16:17:18.000000000 -0500
++++ scorched/configure-al.m4 2009-02-15 20:43:35.000000000 -0500
+@@ -7,25 +7,9 @@
+ [ --disable-openaltest Do not try to compile and run a test OpenAL program],
+ , enable_openaltest=yes)
+ AC_MSG_CHECKING(for OpenAL support)
+-AC_PATH_PROG(OPENAL_CONFIG, openal-config, no)
+-if test x$OPENAL_CONFIG = xno; then
+- echo "*** The openal-config script installed by OpenAL could not be found"
+- echo "*** Make sure openal-config is in your path, or set the OPENAL_CONFIG"
+- echo "*** environment variable to the full path to openal-config."
+-
+- AC_MSG_ERROR([*** Can't find the openal library. Try: http://www.openal.org/])
+-else
+-
+- if test x"$use_static_openal" = x"yes"; then
+- AL_LIBS="/usr/local/lib/libopenal.a"
+- else
+- AL_LIBS="`$OPENAL_CONFIG --libs`"
+- fi
+-
+- AL_CFLAGS="`$OPENAL_CONFIG --cflags`"
+-
+- AC_MSG_RESULT(yes)
+-fi
++AL_LIBS="-lopenal"
++AL_CFLAGS="-I/usr/include/AL"
++AC_MSG_RESULT(yes)
+
+ AC_MSG_CHECKING(for Freealut support)
+ AC_PATH_PROG(FREEALUT_CONFIG, freealut-config, no)
+diff -ru scorched.orig/configure.ac scorched/configure.ac
+--- scorched.orig/configure.ac 2008-03-03 16:17:18.000000000 -0500
++++ scorched/configure.ac 2009-02-15 20:40:30.000000000 -0500
+@@ -13,22 +13,6 @@
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+
+-LDFLAGS="-L/usr/X11R6/lib -L/usr/X11R6"
+-CPPFLAGS="-I/usr/X11R6/include -I/usr/X11R6"
+-
+-if test `uname` == Darwin; then
+-LDFLAGS="$LDFLAGS -lmx"
+-CPPFLAGS="$CPPFLAGS -DFFTW_USE_DOUBLE -D__DARWIN__ -D__MACOSX__"
+-else
+-LDFLAGS="$LDFLAGS -L/usr/local/lib"
+-CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+-fi
+-
+-AC_CHECK_LIB(fridge, beer, echo "Hmm?!",[
+- echo "Warning: No beer found in fridge!";
+- echo "We highly suggest that you rectify this situation immediately."
+-])
+-
+ AC_ARG_ENABLE(serveronly,
+ [ --enable-serveronly Enable server only compilation],
+ , enable_serveronly=no,
diff --git a/games-strategy/scorched3d/files/scorched3d-43-gcc43.patch b/games-strategy/scorched3d/files/scorched3d-43-gcc43.patch
new file mode 100644
index 000000000000..b235f07c585f
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-43-gcc43.patch
@@ -0,0 +1,24 @@
+diff -ur scorched.old/src/common/common/main.h scorched/src/common/common/main.h
+--- scorched.old/src/common/common/main.h 2009-02-18 20:06:22.000000000 +0200
++++ scorched/src/common/common/main.h 2009-02-18 20:07:18.000000000 +0200
+@@ -40,7 +40,7 @@
+ void _no_storage()
+ {
+ printf("Failed to allocate memory!!");
+- std::exit(1);
++ exit(1);
+ }
+
+ void run_main(int argc, char *argv[], OptionsParameters &params)
+diff -ur scorched.old/src/common/porting/windows.h scorched/src/common/porting/windows.h
+--- scorched.old/src/common/porting/windows.h 2009-02-18 20:06:22.000000000 +0200
++++ scorched/src/common/porting/windows.h 2009-02-18 20:06:46.000000000 +0200
+@@ -20,7 +20,7 @@
+ typedef unsigned short WORD;
+ typedef unsigned char BYTE;
+
+-typedef int HWND;
++// typedef int HWND;
+ typedef void * HINSTANCE;
+ typedef int WPARAM;
+ typedef int LPARAM;
diff --git a/games-strategy/scorched3d/files/scorched3d-43-libpng14.patch b/games-strategy/scorched3d/files/scorched3d-43-libpng14.patch
new file mode 100644
index 000000000000..d61a2b6ac485
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-43-libpng14.patch
@@ -0,0 +1,40 @@
+http://bugs.gentoo.org/show_bug.cgi?id=308867
+
+--- src/common/image/ImagePng.cpp
++++ src/common/image/ImagePng.cpp
+@@ -189,7 +189,7 @@ bool ImagePng::loadFromBuffer(NetBuffer
+ info_ptr = png_create_info_struct(png_ptr);
+ if (info_ptr == NULL)
+ {
+- png_destroy_read_struct(&png_ptr, png_infopp_NULL, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, NULL, NULL);
+ return false;
+ }
+
+@@ -200,7 +200,7 @@ bool ImagePng::loadFromBuffer(NetBuffer
+ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ /* If we get here, we had a problem reading the file */
+ return false;
+ }
+@@ -258,7 +258,7 @@ bool ImagePng::loadFromBuffer(NetBuffer
+ }
+ else
+ {
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+
+ Logger::log(S3D::formatStringBuffer(
+ "Invalid PNG format.\n"
+@@ -272,7 +272,7 @@ bool ImagePng::loadFromBuffer(NetBuffer
+ // END NEW CODE
+
+ /* clean up after the read, and free any memory allocated - REQUIRED */
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+
+ /* that's it */
+ return true;
diff --git a/games-strategy/scorched3d/files/scorched3d-43-odbc.patch b/games-strategy/scorched3d/files/scorched3d-43-odbc.patch
new file mode 100644
index 000000000000..355755e7cdb0
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-43-odbc.patch
@@ -0,0 +1,17 @@
+When x11-libs/wxGTK is built with the odbc use flag, scorched3d fails to build.
+bug #285384 - patch from Bob Johnson
+
+diff -urN scorched/src/common/porting/windows.h fix_scorched/src/common/porting/windows.h
+--- scorched/src/common/porting/windows.h 2009-09-21 10:21:16.000000000 -0700
++++ fix_scorched/src/common/porting/windows.h 2009-09-21 10:39:02.000000000 -0700
+@@ -11,8 +11,8 @@
+
+ typedef char * LPSTR;
+ typedef const char * LPCTSTR;
+-typedef unsigned int DWORD;
+-typedef unsigned int * LPDWORD;
++typedef unsigned long DWORD;
++typedef DWORD * LPDWORD;
+ typedef unsigned char * LPBYTE;
+ typedef int INT;
+ typedef long LONG;
diff --git a/games-strategy/scorched3d/files/scorched3d-43-win32.patch b/games-strategy/scorched3d/files/scorched3d-43-win32.patch
new file mode 100644
index 000000000000..8b63d509147c
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-43-win32.patch
@@ -0,0 +1,19 @@
+diff -ur scorched.old/src/common/porting/windows.h scorched/src/common/porting/windows.h
+--- scorched.old/src/common/porting/windows.h 2009-12-17 15:18:41.000000000 +0200
++++ scorched/src/common/porting/windows.h 2009-12-17 15:22:20.000000000 +0200
+@@ -9,6 +9,7 @@
+ #include <ctype.h>
+ #include <common/Defines.h>
+
++#ifdef _WIN32
+ typedef char * LPSTR;
+ typedef const char * LPCTSTR;
+ typedef unsigned int DWORD;
+@@ -27,6 +28,7 @@
+ typedef int LRESULT;
+ typedef void * HDC;
+ typedef void * HGLRC;
++#endif /* _WIN32 */
+
+ #define _strnicmp(a,b,c) strncasecmp(a,b,c)
+ #define stricmp(a,b) strcasecmp(a,b)