summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-30 21:25:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-30 21:25:15 +0000
commit919a1ade48384e3d429580c762aa2bf2a6a48a0d (patch)
tree7fb8467ba8a09c91824042d5c2c0e2d5529e9d05 /games-strategy/netherearth
parentFix examples install location (diff)
downloadgentoo-2-919a1ade48384e3d429580c762aa2bf2a6a48a0d.tar.gz
gentoo-2-919a1ade48384e3d429580c762aa2bf2a6a48a0d.tar.bz2
gentoo-2-919a1ade48384e3d429580c762aa2bf2a6a48a0d.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy/netherearth')
-rw-r--r--games-strategy/netherearth/ChangeLog7
-rw-r--r--games-strategy/netherearth/netherearth-0.52.ebuild28
2 files changed, 20 insertions, 15 deletions
diff --git a/games-strategy/netherearth/ChangeLog b/games-strategy/netherearth/ChangeLog
index 9242471768d2..b25c3e030a3a 100644
--- a/games-strategy/netherearth/ChangeLog
+++ b/games-strategy/netherearth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/netherearth
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/netherearth/ChangeLog,v 1.10 2014/08/10 21:21:05 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/netherearth/ChangeLog,v 1.11 2015/03/30 21:25:15 mr_bones_ Exp $
+
+ 30 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org> netherearth-0.52.ebuild:
+ EAPI=5
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> netherearth-0.52.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/games-strategy/netherearth/netherearth-0.52.ebuild b/games-strategy/netherearth/netherearth-0.52.ebuild
index 9a8f51f0d2b8..304f4be0c900 100644
--- a/games-strategy/netherearth/netherearth-0.52.ebuild
+++ b/games-strategy/netherearth/netherearth-0.52.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/netherearth/netherearth-0.52.ebuild,v 1.10 2014/08/10 21:21:05 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/netherearth/netherearth-0.52.ebuild,v 1.11 2015/03/30 21:25:15 mr_bones_ Exp $
+EAPI=5
inherit eutils games
MY_PV="${PV/./}"
@@ -19,7 +20,6 @@ RESTRICT="mirror bindist"
RDEPEND=">=media-libs/libsdl-1.2.6-r3
>=media-libs/sdl-mixer-1.2.5-r1
media-libs/freeglut"
-
DEPEND="${RDEPEND}
app-arch/unzip"
@@ -28,12 +28,14 @@ S=${WORKDIR}/sources
data=../nether\ earth\ v${PV}
src_unpack() {
+ unzip -LL "${DISTDIR}/${PN}${MY_PV}.zip" >/dev/null || die
+ unzip -LL "${DISTDIR}/sources.zip" >/dev/null || die
+}
+
+src_prepare() {
DATA_DIR=${GAMES_DATADIR}/${PN}
- unzip -LL "${DISTDIR}/${PN}${MY_PV}.zip" >/dev/null || die "unzip ${PN}${MY_PV} failed"
- unzip -LL "${DISTDIR}/sources.zip" >/dev/null || die "unzip sources.zip failed"
- cd "${S}"
- cp "${FILESDIR}/Makefile" . || die "Makefile copying failed"
+ cp "${FILESDIR}/Makefile" . || die
# Fix compilation errors/warnings
epatch "${FILESDIR}"/${P}-linux.patch
@@ -49,29 +51,29 @@ src_unpack() {
-e "s:textures:${DATA_DIR}/textures:" \
-e "s:maps/\*:${DATA_DIR}/maps/\*:" \
-e "s:\./maps:${DATA_DIR}/maps:" \
- mainmenu.cpp || die "sed mainmenu.cpp failed"
+ mainmenu.cpp || die
sed -i \
-e "s:models:${DATA_DIR}/models:g" \
-e "s:textures:${DATA_DIR}/textures:" \
-e "s:sound/:${DATA_DIR}/sound/:" \
- nether.cpp || die "sed nether.cpp failed"
+ nether.cpp || die
sed -i -e "s:maps:${DATA_DIR}/maps:" \
- main.cpp || die "sed main.cpp failed"
+ main.cpp || die
sed -i -e "s:textures/:${DATA_DIR}/textures/:" \
- myglutaux.cpp || die "sed myglutaux.cpp failed"
+ myglutaux.cpp || die
cd "${data}"
rm textures/thumbs.db
}
src_install() {
- dogamesbin nether_earth || die "dogamesbin failed"
+ dogamesbin nether_earth
cd "${data}"
# Install all game data
insinto "${DATA_DIR}"
- doins -r maps models sound textures || die "doins failed"
+ doins -r maps models sound textures
dodoc readme.txt