summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-02 19:48:00 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-02 19:48:00 +0000
commit7a6f83559a024efcbb2bb0b47539ce26a7292db9 (patch)
treeac1a820f9862577b40f569f0bcdb79433f202605 /games-strategy/gwp
parentMove masking to package.mask and remove redundant entries from packages. (diff)
downloadgentoo-2-7a6f83559a024efcbb2bb0b47539ce26a7292db9.tar.gz
gentoo-2-7a6f83559a024efcbb2bb0b47539ce26a7292db9.tar.bz2
gentoo-2-7a6f83559a024efcbb2bb0b47539ce26a7292db9.zip
CFLAGS fix
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'games-strategy/gwp')
-rw-r--r--games-strategy/gwp/gwp-0.4.0-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/games-strategy/gwp/gwp-0.4.0-r1.ebuild b/games-strategy/gwp/gwp-0.4.0-r1.ebuild
index 722062688d87..b85c14e8e566 100644
--- a/games-strategy/gwp/gwp-0.4.0-r1.ebuild
+++ b/games-strategy/gwp/gwp-0.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/gwp/gwp-0.4.0-r1.ebuild,v 1.1 2006/10/02 19:21:53 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/gwp/gwp-0.4.0-r1.ebuild,v 1.2 2006/10/02 19:48:00 nyhm Exp $
inherit eutils gnome2
@@ -27,6 +27,11 @@ DEPEND="${RDEPEND}
src_unpack() {
gnome2_src_unpack
epatch "${FILESDIR}/${P}-gcc41.patch"
+ sed -i \
+ -e '/ -O1/d' \
+ -e '/ -g$/d' \
+ src/Makefile.in \
+ || die "sed failed"
}
src_compile() {