summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-02-24 23:48:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-02-24 23:48:06 +0000
commit39a8c07b7c71f9de3828074913481a26f31cdf3e (patch)
tree7d67d1641199520f4847f1a7043eef989be4c6b8 /games-strategy/glob2
parentMask x11-themes/qtcurve-qt4-0.61.2 for compilation failure (diff)
downloadgentoo-2-39a8c07b7c71f9de3828074913481a26f31cdf3e.tar.gz
gentoo-2-39a8c07b7c71f9de3828074913481a26f31cdf3e.tar.bz2
gentoo-2-39a8c07b7c71f9de3828074913481a26f31cdf3e.zip
version bump
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'games-strategy/glob2')
-rw-r--r--games-strategy/glob2/ChangeLog9
-rw-r--r--games-strategy/glob2/glob2-0.9.4.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/games-strategy/glob2/ChangeLog b/games-strategy/glob2/ChangeLog
index c1ca49295bd8..9c7788c297b0 100644
--- a/games-strategy/glob2/ChangeLog
+++ b/games-strategy/glob2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/glob2
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.43 2008/05/22 18:41:51 maekke Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.44 2009/02/24 23:48:06 mr_bones_ Exp $
+
+*glob2-0.9.4 (24 Feb 2009)
+
+ 24 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org> +glob2-0.9.4.ebuild:
+ version bump
22 May 2008; Markus Meier <maekke@gentoo.org> glob2-0.9.3.ebuild:
x86 stable, bug #223097
diff --git a/games-strategy/glob2/glob2-0.9.4.ebuild b/games-strategy/glob2/glob2-0.9.4.ebuild
new file mode 100644
index 000000000000..ea5da5b87612
--- /dev/null
+++ b/games-strategy/glob2/glob2-0.9.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.9.4.ebuild,v 1.1 2009/02/24 23:48:06 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Real Time Strategy (RTS) game involving a brave army of globs"
+HOMEPAGE="http://globulation2.org/"
+SRC_URI="http://dl.sv.nongnu.org/releases/glob2/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ >=dev-libs/boost-1.34
+ media-libs/libsdl
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ media-libs/libvorbis
+ dev-libs/fribidi
+ media-libs/speex"
+DEPEND="${RDEPEND}
+ >=dev-util/scons-1"
+
+src_compile() {
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -e "s/.*\(-j[0-9]\+\).*/\1/")
+
+ scons \
+ ${sconsopts} \
+ CXXFLAGS="${CXXFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ INSTALLDIR="${GAMES_DATADIR}"/${PN} \
+ DATADIR="${GAMES_DATADIR}"/${PN} \
+ || die "scons failed again"
+}
+
+src_install() {
+ dogamesbin src/${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r campaigns data maps scripts || die "doins failed"
+ find "${D}/${GAMES_DATADIR}"/${PN} -name SConscript -exec rm -f {} +
+ newicon data/icons/glob2-icon-48x48.png ${PN}.png
+ make_desktop_entry glob2 "Globulation 2"
+ dodoc README*
+ prepgamesdirs
+}