summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-30 08:08:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-30 08:08:36 +0000
commit2941a35d354c95c283fd29e37a16a5d71e1ca9bc (patch)
tree6988f226ed1466e7db4d33b04a60012fb5d7060b /games-strategy/glob2
parentFixed broken Manifest. (Manifest recommit) (diff)
downloadgentoo-2-2941a35d354c95c283fd29e37a16a5d71e1ca9bc.tar.gz
gentoo-2-2941a35d354c95c283fd29e37a16a5d71e1ca9bc.tar.bz2
gentoo-2-2941a35d354c95c283fd29e37a16a5d71e1ca9bc.zip
version bump
Diffstat (limited to 'games-strategy/glob2')
-rw-r--r--games-strategy/glob2/ChangeLog7
-rw-r--r--games-strategy/glob2/Manifest4
-rw-r--r--games-strategy/glob2/files/digest-glob2-0.8.101
-rw-r--r--games-strategy/glob2/glob2-0.8.10.ebuild40
4 files changed, 50 insertions, 2 deletions
diff --git a/games-strategy/glob2/ChangeLog b/games-strategy/glob2/ChangeLog
index ad7e4c2a2b2d..2827f946fc7c 100644
--- a/games-strategy/glob2/ChangeLog
+++ b/games-strategy/glob2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/glob2
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.16 2004/11/24 21:30:15 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.17 2004/12/30 08:08:36 mr_bones_ Exp $
+
+*glob2-0.8.10 (30 Dec 2004)
+
+ 30 Dec 2004; Michael Sterrett <mr_bones_@gentoo.org> +glob2-0.8.10.ebuild:
+ version bump
07 Nov 2004; Joseph Jezak <josejx@gentoo.org> glob2-0.8.9.ebuild:
Marked ppc stable.
diff --git a/games-strategy/glob2/Manifest b/games-strategy/glob2/Manifest
index c2d2714df23a..ee16af89556b 100644
--- a/games-strategy/glob2/Manifest
+++ b/games-strategy/glob2/Manifest
@@ -1,8 +1,10 @@
MD5 d5833899c0b44998ab48e68bebd08f18 ChangeLog 1851
MD5 5aa338ac457c802d85f84394932f46ad glob2-0.8.7.ebuild 959
+MD5 be3faa436a456146cab34d1a7ba5e534 metadata.xml 546
MD5 86bbee1610aedd934e30870b03b54b38 glob2-0.8.8.ebuild 1017
MD5 91b861e606812a2c5b70caa6df209ac7 glob2-0.8.9.ebuild 1277
-MD5 be3faa436a456146cab34d1a7ba5e534 metadata.xml 546
+MD5 91b861e606812a2c5b70caa6df209ac7 glob2-0.8.10.ebuild 1277
MD5 43e352a12416a207b6b3375c57086637 files/digest-glob2-0.8.7 64
MD5 8bc921c1e002e9028de41eb49f11e284 files/digest-glob2-0.8.8 64
MD5 de4d5ea54b6291db91857fb227244587 files/digest-glob2-0.8.9 64
+MD5 de372c45a3d3c17421e28b07dbf1f49d files/digest-glob2-0.8.10 65
diff --git a/games-strategy/glob2/files/digest-glob2-0.8.10 b/games-strategy/glob2/files/digest-glob2-0.8.10
new file mode 100644
index 000000000000..f82a93460798
--- /dev/null
+++ b/games-strategy/glob2/files/digest-glob2-0.8.10
@@ -0,0 +1 @@
+MD5 333c7e7df1a6de4640889a05e4f06b2d glob2-0.8.10.tar.gz 8730413
diff --git a/games-strategy/glob2/glob2-0.8.10.ebuild b/games-strategy/glob2/glob2-0.8.10.ebuild
new file mode 100644
index 000000000000..e45667c5345e
--- /dev/null
+++ b/games-strategy/glob2/glob2-0.8.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.8.10.ebuild,v 1.1 2004/12/30 08:08:36 mr_bones_ Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="state of the art Real Time Strategy (RTS) game"
+HOMEPAGE="http://www.ysagoon.com/glob2/"
+SRC_URI="http://www.ysagoon.com/glob2/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc ~amd64"
+IUSE=""
+
+DEPEND="virtual/libc
+ virtual/opengl
+ >=media-libs/libsdl-1.2.0
+ media-libs/libpng
+ media-libs/sdl-net
+ media-libs/sdl-image
+ media-libs/libvorbis
+ =media-libs/freetype-2*
+ sys-libs/zlib"
+
+src_compile() {
+ # comment from bug #64150 to fix compile issue.
+ filter-flags -O?
+ #./configure assumes that vorbis will be installed under PREFIX bug #46352
+ egamesconf \
+ --with-vorbis=/usr \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO
+ prepgamesdirs
+}