summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-10 04:42:43 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-10 04:42:43 +0000
commit369cd62dff5427b1b8d0a57c7dd33b3271524c4a (patch)
tree8dae65ad00e7cc041da286e22eb9c38cdadf01ab /games-strategy/glest
parentAdd >=net-firewall/firestarter-1.0 for testing purposes; remove old (diff)
downloadgentoo-2-369cd62dff5427b1b8d0a57c7dd33b3271524c4a.tar.gz
gentoo-2-369cd62dff5427b1b8d0a57c7dd33b3271524c4a.tar.bz2
gentoo-2-369cd62dff5427b1b8d0a57c7dd33b3271524c4a.zip
initial ebuild #84419
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-strategy/glest')
-rw-r--r--games-strategy/glest/ChangeLog8
-rw-r--r--games-strategy/glest/Manifest2
-rw-r--r--games-strategy/glest/files/digest-glest-1.0.10_p75
-rw-r--r--games-strategy/glest/files/glest23
-rw-r--r--games-strategy/glest/glest-1.0.10_p7.ebuild69
-rw-r--r--games-strategy/glest/metadata.xml5
6 files changed, 112 insertions, 0 deletions
diff --git a/games-strategy/glest/ChangeLog b/games-strategy/glest/ChangeLog
new file mode 100644
index 000000000000..6648b2541062
--- /dev/null
+++ b/games-strategy/glest/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-strategy/glest
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/ChangeLog,v 1.1 2005/04/10 04:42:43 vapier Exp $
+
+*glest-1.0.10_p7 (10 Apr 2004)
+
+ 10 Apr 2004; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Bob Ziuchkovski et al #84419.
diff --git a/games-strategy/glest/Manifest b/games-strategy/glest/Manifest
new file mode 100644
index 000000000000..d4544f3ba3ee
--- /dev/null
+++ b/games-strategy/glest/Manifest
@@ -0,0 +1,2 @@
+MD5 b72e8199995ea07333544ed699ed4266 glest-1.0.10_p7.ebuild 2147
+MD5 704449ca017fe5f35a53024e3daa2a4c files/digest-glest-1.0.10_p7 306
diff --git a/games-strategy/glest/files/digest-glest-1.0.10_p7 b/games-strategy/glest/files/digest-glest-1.0.10_p7
new file mode 100644
index 000000000000..6c27dd2422ae
--- /dev/null
+++ b/games-strategy/glest/files/digest-glest-1.0.10_p7
@@ -0,0 +1,5 @@
+MD5 43c9e355776194c9813781ecfcee3e45 glest-1.0.10-r7-source.tar.bz2 319692
+MD5 9e9c64b774a315d2a74328837a042a0c glest-1.0.10-data.tar.bz2 43251901
+MD5 4bfe6d6fa50c30f881376b85b53f1a0b german.lng 3573
+MD5 902eaa96b6ee22f50b342367ccb63b19 russian.lng 3519
+MD5 cbd43da7628d87d37d505b620ba2a99e dansk.lng 3423
diff --git a/games-strategy/glest/files/glest b/games-strategy/glest/files/glest
new file mode 100644
index 000000000000..de0c3985cf0c
--- /dev/null
+++ b/games-strategy/glest/files/glest
@@ -0,0 +1,23 @@
+#!/bin/bash
+
+GAMESDIR="GENTOO_DATADIR"
+GLESTDIR="$GAMESDIR/glest"
+
+if [ ! -d ~/.glest ]; then
+ mkdir ~/.glest
+fi
+for d in data Tech map tileset lib/glest ; do
+ if [ ! -L ~/.glest/${d} ] ; then
+ ln -s "${GLESTDIR}"/${d} ~/.glest/${d##*/}
+ fi
+done
+if [ ! -e ~/.glest/glest.ini ] ; then
+ cp "${GLESTDIR}"/config/glest.ini ~/.glest/glest.ini
+fi
+if [ ! -e ~/.glest/glest.log ] ; then
+ touch ~/.glest/glest.log
+fi
+
+export LD_LIBRARY_PATH=${GLESTDIR}/lib:${LD_LIBRARY_PATH}
+cd ~/.glest
+exec ./glest "$@"
diff --git a/games-strategy/glest/glest-1.0.10_p7.ebuild b/games-strategy/glest/glest-1.0.10_p7.ebuild
new file mode 100644
index 000000000000..e41e32325046
--- /dev/null
+++ b/games-strategy/glest/glest-1.0.10_p7.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/glest-1.0.10_p7.ebuild,v 1.1 2005/04/10 04:42:43 vapier Exp $
+
+inherit eutils games
+
+DATAVERSION="${PV/_p?/}"
+SOURCEVERSION="${PV/_p/-r}"
+DESCRIPTION="Cross-platform 3D realtime strategy game"
+HOMEPAGE="http://www.stud.uni-karlsruhe.de/~uxsm/glest/"
+SRC_URI="http://www.stud.uni-karlsruhe.de/~uxsm/glest-${SOURCEVERSION}-source.tar.bz2
+ http://www.stud.uni-karlsruhe.de/~unatc/glest/glest-${DATAVERSION}-data.tar.bz2
+ linguas_de? ( http://www.stud.uni-karlsruhe.de/~uxsm/german.lng )
+ linguas_ru? ( http://www.stud.uni-karlsruhe.de/~uxsm/russian.lng )
+ linguas_dk? ( http://www.stud.uni-karlsruhe.de/~uxsm/dansk.lng )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libsdl-1.2.5
+ media-libs/libogg
+ media-libs/libvorbis
+ >=media-libs/openal-20040303
+ dev-libs/xerces-c
+ virtual/opengl
+ virtual/x11"
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-3.2
+ >=dev-util/jam-2.5"
+
+S=${WORKDIR}/${PN}-${DATAVERSION}
+
+src_unpack() {
+ unpack glest-${SOURCEVERSION}-source.tar.bz2 glest-${DATAVERSION}-data.tar.bz2
+ cd "${S}"
+ # sometimes they package configure, sometimes they dont
+ if [[ ! -e configure ]] ; then
+ ./autogen.sh || die "autogen failed"
+ fi
+}
+
+src_compile() {
+ egamesconf || die
+ jam || die "jam failed"
+}
+
+src_install() {
+ dogamesbin "${FILESDIR}"/glest || die "couldn't install launcher"
+ dosed "s:GENTOO_DATADIR:${GAMES_DATADIR}:" "${GAMES_BINDIR}"/glest
+
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r Tech data map tileset "${D}/${GAMES_DATADIR}"/${PN}/ || die "data copy failed"
+ insinto "${GAMES_DATADIR}"/${PN}/config
+ doins glest.ini || die "config copy failed"
+ insinto "${GAMES_DATADIR}/${PN}"/lib
+ doins out/*-linux-gnu/opt/lib/sources/libglestlib.a || die "doins lib.a failed"
+ exeinto "${GAMES_DATADIR}/${PN}"/lib
+ doexe glest || die "doexe failed"
+
+ use linguas_de && cp "${DISTDIR}"/german.lng "${D}/${GAMES_DATADIR}"/${PN}/data/lang/
+ use linguas_ru && cp "${DISTDIR}"/russian.lng "${D}/${GAMES_DATADIR}"/${PN}/data/lang/
+ use linguas_dk && cp "${DISTDIR}"/dansk.lng "${D}/${GAMES_DATADIR}"/${PN}/data/lang/
+
+ make_desktop_entry glest Glest
+
+ prepgamesdirs
+}
diff --git a/games-strategy/glest/metadata.xml b/games-strategy/glest/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-strategy/glest/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>