summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-04-07 01:43:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-04-07 01:43:53 +0000
commit225500345dc8eeb00b848a87deb8a4dca2e1637c (patch)
tree5a524260e7aab02eaf234d478764212a730bf132 /games-strategy/asc
parentamd64 stable, bug #212643 (diff)
downloadgentoo-2-225500345dc8eeb00b848a87deb8a4dca2e1637c.tar.gz
gentoo-2-225500345dc8eeb00b848a87deb8a4dca2e1637c.tar.bz2
gentoo-2-225500345dc8eeb00b848a87deb8a4dca2e1637c.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-strategy/asc')
-rw-r--r--games-strategy/asc/ChangeLog7
-rw-r--r--games-strategy/asc/asc-2.1.0.0.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/games-strategy/asc/ChangeLog b/games-strategy/asc/ChangeLog
index 6fbdc6173ad7..3bd2a35e5e15 100644
--- a/games-strategy/asc/ChangeLog
+++ b/games-strategy/asc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/asc
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/ChangeLog,v 1.24 2008/01/22 08:07:43 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/ChangeLog,v 1.25 2008/04/07 01:43:53 mr_bones_ Exp $
+
+*asc-2.1.0.0 (07 Apr 2008)
+
+ 07 Apr 2008; Michael Sterrett <mr_bones_@gentoo.org> +asc-2.1.0.0.ebuild:
+ version bump
22 Jan 2008; Tristan Heaven <nyhm@gentoo.org> asc-2.0.1.0.ebuild:
Add sdl-sound dep, bug #206419
diff --git a/games-strategy/asc/asc-2.1.0.0.ebuild b/games-strategy/asc/asc-2.1.0.0.ebuild
new file mode 100644
index 000000000000..cd3d530eb626
--- /dev/null
+++ b/games-strategy/asc/asc-2.1.0.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/asc-2.1.0.0.ebuild,v 1.1 2008/04/07 01:43:53 mr_bones_ Exp $
+
+inherit toolchain-funcs flag-o-matic games
+
+DESCRIPTION="turn based strategy game designed in the tradition of the Battle Isle series"
+HOMEPAGE="http://www.asc-hq.org/"
+SRC_URI="mirror://sourceforge/asc-hq/${P}.tar.bz2
+ http://www.asc-hq.org/music/frontiers.ogg
+ http://www.asc-hq.org/music/time_to_strike.ogg
+ http://www.asc-hq.org/music/machine_wars.ogg"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-arch/bzip2
+ media-libs/jpeg
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-sound
+ dev-libs/boost
+ dev-games/physfs
+ media-libs/smpeg
+ media-libs/libvorbis
+ dev-libs/expat
+ media-libs/freetype
+ =dev-libs/libsigc++-1.2*"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/pkgconfig"
+
+src_unpack() {
+ local f
+
+ for f in ${A}
+ do
+ case ${f} in
+ *ogg)
+ cp "${DISTDIR}/${f}" "${S}/data/music" || die "cp music failed"
+ ;;
+ *) unpack ${f}
+ esac
+ done
+}
+
+src_compile() {
+ # Added --disable-paraguitest for bugs 26402 and 4488
+ # Added --disable-paragui for bug 61154 since it's not really used much
+ # and the case is well documented at http://www.asc-hq.org/
+ if [[ $(gcc-major-version) -eq 4 ]] ; then
+ replace-flags -O3 -O2
+ fi
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-paraguitest \
+ --disable-paragui \
+ --datadir="${GAMES_DATADIR_BASE}" \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ dohtml -r doc/*
+ prepgamesdirs
+}