summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-03-20 21:24:48 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-03-20 21:24:48 +0000
commitf11ecdffcb72a7eac0181b009e20d1d56f1c0c8b (patch)
treeed68d66b9104222beef685dd2ea414d455a50cef /games-sports
parentx86 stable (diff)
downloadgentoo-2-f11ecdffcb72a7eac0181b009e20d1d56f1c0c8b.tar.gz
gentoo-2-f11ecdffcb72a7eac0181b009e20d1d56f1c0c8b.tar.bz2
gentoo-2-f11ecdffcb72a7eac0181b009e20d1d56f1c0c8b.zip
version bump, bug 171559
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/xmoto/ChangeLog7
-rw-r--r--games-sports/xmoto/files/digest-xmoto-0.2.76
-rw-r--r--games-sports/xmoto/xmoto-0.2.7.ebuild64
3 files changed, 76 insertions, 1 deletions
diff --git a/games-sports/xmoto/ChangeLog b/games-sports/xmoto/ChangeLog
index 11b90d616180..861f72b6e0e6 100644
--- a/games-sports/xmoto/ChangeLog
+++ b/games-sports/xmoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-sports/xmoto
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.11 2007/03/06 15:05:21 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.12 2007/03/20 21:24:48 genstef Exp $
+
+*xmoto-0.2.7 (20 Mar 2007)
+
+ 20 Mar 2007; <stefan@gentoo.org> +xmoto-0.2.7.ebuild:
+ version bump, bug 171559
*xmoto-0.2.6 (06 Mar 2007)
diff --git a/games-sports/xmoto/files/digest-xmoto-0.2.7 b/games-sports/xmoto/files/digest-xmoto-0.2.7
new file mode 100644
index 000000000000..6665ee2386bc
--- /dev/null
+++ b/games-sports/xmoto/files/digest-xmoto-0.2.7
@@ -0,0 +1,6 @@
+MD5 fce995d497841ef4f51ebbf3f6e510cc svg2lvl-0.3.0.tar.gz 40660
+RMD160 4cc783c0388e39429062540324e86599f9d950f5 svg2lvl-0.3.0.tar.gz 40660
+SHA256 2e63ca642075bee4e685a55e560533aac2b9ac9606eafa8262b6cf8207138f50 svg2lvl-0.3.0.tar.gz 40660
+MD5 4b079ea010561584a61b3d6384b942fc xmoto-0.2.7-src.tar.gz 12399222
+RMD160 278e21492ec7ed7dc75a0a5f85ce588b6a9f4a7c xmoto-0.2.7-src.tar.gz 12399222
+SHA256 6764a7e9148af801eef4870ddab2c2109665d5760acb3d805f073449a83e4e54 xmoto-0.2.7-src.tar.gz 12399222
diff --git a/games-sports/xmoto/xmoto-0.2.7.ebuild b/games-sports/xmoto/xmoto-0.2.7.ebuild
new file mode 100644
index 000000000000..08b9a914e192
--- /dev/null
+++ b/games-sports/xmoto/xmoto-0.2.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/xmoto-0.2.7.ebuild,v 1.1 2007/03/20 21:24:48 genstef Exp $
+
+inherit eutils games
+
+LVL_N="svg2lvl"
+LVL_V="0.3.0"
+
+DESCRIPTION="A challenging 2D motocross platform game"
+HOMEPAGE="http://xmoto.tuxfamily.org"
+SRC_URI="http://download.tuxfamily.org/${PN}/${PN}/${PV}/${P}-src.tar.gz
+ editor? ( mirror://sourceforge/${PN}/${LVL_N}-${LVL_V}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls editor"
+
+RDEPEND="media-libs/jpeg
+ media-libs/libpng
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ net-misc/curl
+ dev-lang/lua
+ dev-games/ode
+ virtual/opengl
+ virtual/glu
+ nls? ( virtual/libintl )
+ editor? ( >=media-gfx/inkscape-0.45 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:$(localedir):/usr/share/locale:' po/Makefile.in.in \
+ || die "sed Makefile.in.in failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-localesdir=/usr/share/locale \
+ $(use_enable nls) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README TODO ChangeLog
+
+ doicon extra/xmoto.xpm
+ domenu extra/xmoto{,-edit}.desktop
+
+ prepgamesdirs
+
+ if use editor; then
+ insinto /usr/share/inkscape/extensions
+ doins ${WORKDIR}/${LVL_N}-${LVL_V}/*
+ fi
+}