summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-13 05:56:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-13 05:56:44 +0000
commitcd9c8c92e2146efac18deabb570c1f49f984a88a (patch)
treef0f7aa6721cba9f95db261dfad3dc7c45880d41d /games-sports
parentVersion bump, install example configs from contrib. (diff)
downloadgentoo-2-cd9c8c92e2146efac18deabb570c1f49f984a88a.tar.gz
gentoo-2-cd9c8c92e2146efac18deabb570c1f49f984a88a.tar.bz2
gentoo-2-cd9c8c92e2146efac18deabb570c1f49f984a88a.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/trigger/ChangeLog9
-rw-r--r--games-sports/trigger/trigger-0.6.1.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/games-sports/trigger/ChangeLog b/games-sports/trigger/ChangeLog
index 34bfd5935198..e944b06f4272 100644
--- a/games-sports/trigger/ChangeLog
+++ b/games-sports/trigger/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-sports/trigger
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/trigger/ChangeLog,v 1.27 2013/01/20 01:21:00 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/trigger/ChangeLog,v 1.28 2015/03/13 05:56:44 mr_bones_ Exp $
+
+*trigger-0.6.1 (13 Mar 2015)
+
+ 13 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org> +trigger-0.6.1.ebuild:
+ version bump
20 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
-files/trigger-0.5.2.1-ldflags.patch, -trigger-0.5.2.1.ebuild:
diff --git a/games-sports/trigger/trigger-0.6.1.ebuild b/games-sports/trigger/trigger-0.6.1.ebuild
new file mode 100644
index 000000000000..4b194d3685e1
--- /dev/null
+++ b/games-sports/trigger/trigger-0.6.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/trigger/trigger-0.6.1.ebuild,v 1.1 2015/03/13 05:56:44 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils games
+
+MY_PN=${PN}-rally
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Free OpenGL rally car racing game"
+HOMEPAGE="http://www.positro.net/trigger/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer
+ media-libs/openal
+ media-libs/freealut
+ dev-games/physfs"
+DEPEND="${RDEPEND}
+ dev-util/ftjam"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ egamesconf --datadir="${GAMES_DATADIR}"/${PN}
+}
+
+src_compile() {
+ AR="${AR} cru" jam -dx -qa || die
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/*
+ newicon data/textures/life_helmet.png ${PN}.png
+ make_desktop_entry ${PN} Trigger
+ dodoc doc/*.txt
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "After running ${PN} for the first time, a config file is"
+ elog "available in ~/.trigger/trigger.config"
+}