summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-10-01 22:24:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-10-01 22:24:06 +0000
commitab40e70d8e381745574fe7accd3236a635cc763d (patch)
treef1160b97253feed3b574624d15550f06daa55263 /games-sports
parentAdded ~hppa, bug #148659 (diff)
downloadgentoo-2-ab40e70d8e381745574fe7accd3236a635cc763d.tar.gz
gentoo-2-ab40e70d8e381745574fe7accd3236a635cc763d.tar.bz2
gentoo-2-ab40e70d8e381745574fe7accd3236a635cc763d.zip
fixup nvidia detection and add fbsd support - patch from Diego Pettenò (bug #149718)
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/foobillard/ChangeLog7
-rw-r--r--games-sports/foobillard/files/digest-foobillard-3.0a2
-rw-r--r--games-sports/foobillard/files/foobillard-3.0a-fbsd.patch29
-rw-r--r--games-sports/foobillard/foobillard-3.0a.ebuild35
4 files changed, 55 insertions, 18 deletions
diff --git a/games-sports/foobillard/ChangeLog b/games-sports/foobillard/ChangeLog
index 8f843d718d4c..d4d4c1630251 100644
--- a/games-sports/foobillard/ChangeLog
+++ b/games-sports/foobillard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-sports/foobillard
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/ChangeLog,v 1.10 2006/01/29 08:04:42 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/ChangeLog,v 1.11 2006/10/01 22:24:06 mr_bones_ Exp $
+
+ 01 Oct 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/foobillard-3.0a-fbsd.patch, foobillard-3.0a.ebuild:
+ fixup nvidia detection and add fbsd support - patch from Diego Pettenà (bug
+ #149718)
29 Jan 2006; Joshua Baergen <joshuabaergen@gentoo.org>
foobillard-3.0a.ebuild:
diff --git a/games-sports/foobillard/files/digest-foobillard-3.0a b/games-sports/foobillard/files/digest-foobillard-3.0a
index 124f20c827b6..727d0b80b2de 100644
--- a/games-sports/foobillard/files/digest-foobillard-3.0a
+++ b/games-sports/foobillard/files/digest-foobillard-3.0a
@@ -1 +1,3 @@
MD5 c2d92edeaaf8bfb18aa26f1c79931b7d foobillard-3.0a.tar.gz 1138477
+RMD160 9d5a2d271ca270563592c5f6cf23533447c51483 foobillard-3.0a.tar.gz 1138477
+SHA256 d05807077bdba32c4ca1d369344ac983675dc859cb7b192fca4196f23b89b137 foobillard-3.0a.tar.gz 1138477
diff --git a/games-sports/foobillard/files/foobillard-3.0a-fbsd.patch b/games-sports/foobillard/files/foobillard-3.0a-fbsd.patch
new file mode 100644
index 000000000000..301260cb8360
--- /dev/null
+++ b/games-sports/foobillard/files/foobillard-3.0a-fbsd.patch
@@ -0,0 +1,29 @@
+Index: foobillard-3.0a/configure.in
+===================================================================
+--- foobillard-3.0a.orig/configure.in
++++ foobillard-3.0a/configure.in
+@@ -13,7 +13,7 @@ dnl Checks for libraries.
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS(limits.h unistd.h math.h stdlib.h stdio.h ft2build.h)
++AC_CHECK_HEADERS(limits.h unistd.h math.h stdlib.h stdio.h ft2build.h endian.h sys/endian.h)
+
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+Index: foobillard-3.0a/src/billard3d.c
+===================================================================
+--- foobillard-3.0a.orig/src/billard3d.c
++++ foobillard-3.0a/src/billard3d.c
+@@ -24,7 +24,11 @@
+ #include <string.h>
+ #include <math.h>
+ #include <unistd.h>
++#ifdef HAVE_ENDIAN_H
+ #include <endian.h>
++#elif defined(HAVE_SYS_ENDIAN_H)
++#include <sys/endian.h>
++#endif
+
+ #ifndef USE_SDL
+ #include <GL/glut.h>
diff --git a/games-sports/foobillard/foobillard-3.0a.ebuild b/games-sports/foobillard/foobillard-3.0a.ebuild
index 69b160722da6..45938ac3e1ab 100644
--- a/games-sports/foobillard/foobillard-3.0a.ebuild
+++ b/games-sports/foobillard/foobillard-3.0a.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-3.0a.ebuild,v 1.7 2006/01/29 08:04:42 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-3.0a.ebuild,v 1.8 2006/10/01 22:24:06 mr_bones_ Exp $
-inherit eutils games
+inherit eutils autotools games
DESCRIPTION="8ball, 9ball, snooker and carambol game"
HOMEPAGE="http://foobillard.sunsite.dk/"
@@ -13,10 +13,8 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="sdl"
-DEPEND="|| ( ( x11-libs/libXaw
- x11-libs/libXi )
- virtual/x11
- )
+RDEPEND="x11-libs/libXaw
+ x11-libs/libXi
virtual/opengl
>=media-libs/freetype-2.0.9
>=media-libs/libpng-1.2.1
@@ -26,18 +24,24 @@ DEPEND="|| ( ( x11-libs/libXaw
virtual/glu
virtual/glut )
)"
+DEPEND="${RDEPEND}
+ app-admin/eselect"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-no_nvidia.patch
+ epatch \
+ "${FILESDIR}"/${P}-no_nvidia.patch \
+ "${FILESDIR}"/${P}-fbsd.patch
+
+ eautoreconf
}
src_compile() {
- local myconf=""
- [ "$(ls /usr/include/GL/gl.h -al | awk '{print $NF}' | cut -d/ -f5)" == "nvidia" ] \
- && myconf="--enable-nvidia=yes" \
- || myconf="--enable-nvidia=no"
+ local myconf
+ [[ "$(eselect opengl show)" == 'nvidia' ]] \
+ && myconf='--enable-nvidia=yes' \
+ || myconf='--enable-nvidia=no'
egamesconf \
--enable-sound \
@@ -49,13 +53,10 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog README README.FONTS
doman foobillard.6
-
- insinto /usr/share/pixmaps
- newins data/full_symbol.png foobillard.png
- make_desktop_entry foobillard Foobillard foobillard.png
-
+ newicon data/full_symbol.png foobillard.png
+ make_desktop_entry foobillard Foobillard
prepgamesdirs
}