summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-03-22 15:05:44 +0000
committerMike Frysinger <vapier@gentoo.org>2012-03-22 15:05:44 +0000
commit927d08a6e2a9f988be272f0111cc3995070e8127 (patch)
treeb1c35ff795e47f48ff0d993f427d5083dc2bf7cf /games-sports
parenthttp://my.opera.com/desktopteam/blog/2012/03/22/11-62-is-nearing-release (diff)
downloadgentoo-2-927d08a6e2a9f988be272f0111cc3995070e8127.tar.gz
gentoo-2-927d08a6e2a9f988be272f0111cc3995070e8127.tar.bz2
gentoo-2-927d08a6e2a9f988be272f0111cc3995070e8127.zip
Do not use automake macros #408473 by Piotr Szymaniak.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/torcs/ChangeLog8
-rw-r--r--games-sports/torcs/files/torcs-1.3.1-libpng15.patch24
-rw-r--r--games-sports/torcs/files/torcs-1.3.1-no-automake.patch21
-rw-r--r--games-sports/torcs/torcs-1.3.1.ebuild7
4 files changed, 43 insertions, 17 deletions
diff --git a/games-sports/torcs/ChangeLog b/games-sports/torcs/ChangeLog
index cc7fb458ef1b..acbbd7633584 100644
--- a/games-sports/torcs/ChangeLog
+++ b/games-sports/torcs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-sports/torcs
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/ChangeLog,v 1.34 2011/05/30 01:57:46 mr_bones_ Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/ChangeLog,v 1.35 2012/03/22 15:05:44 vapier Exp $
+
+ 22 Mar 2012; Mike Frysinger <vapier@gentoo.org> torcs-1.3.1.ebuild,
+ files/torcs-1.3.1-libpng15.patch, +files/torcs-1.3.1-no-automake.patch:
+ Do not use automake macros #408473 by Piotr Szymaniak.
30 May 2011; Michael Sterrett <mr_bones_@gentoo.org> torcs-1.3.1.ebuild,
+files/torcs-1.3.1-libpng15.patch:
diff --git a/games-sports/torcs/files/torcs-1.3.1-libpng15.patch b/games-sports/torcs/files/torcs-1.3.1-libpng15.patch
index 6b09ce2a41c8..94f6d6c471e9 100644
--- a/games-sports/torcs/files/torcs-1.3.1-libpng15.patch
+++ b/games-sports/torcs/files/torcs-1.3.1-libpng15.patch
@@ -1,20 +1,20 @@
--- a/src/libs/tgfclient/img.cpp
+++ b/src/libs/tgfclient/img.cpp
@@ -98,7 +98,7 @@
- return (unsigned char *)NULL;
- }
-
+ return (unsigned char *)NULL;
+ }
+
- if (setjmp(png_ptr->jmpbuf))
+ if (setjmp(png_jmpbuf(png_ptr)))
- {
- /* Free all of the memory associated with the png_ptr and info_ptr */
- png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
@@ -229,7 +229,7 @@
- return -1;
- }
-
+ return -1;
+ }
+
- if (setjmp(png_ptr->jmpbuf)) {
+ if (setjmp(png_jmpbuf(png_ptr))) {
- png_destroy_write_struct(&png_ptr, &info_ptr);
- fclose(fp);
- return -1;
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);
+ return -1;
diff --git a/games-sports/torcs/files/torcs-1.3.1-no-automake.patch b/games-sports/torcs/files/torcs-1.3.1-no-automake.patch
new file mode 100644
index 000000000000..a7a26f6a1f5c
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.1-no-automake.patch
@@ -0,0 +1,21 @@
+torcs doesn't use automake, so it shouldn't be calling the macro
+
+http://bugs.gentoo.org/408473
+
+--- a/configure.in
++++ b/configure.in
+@@ -14,9 +14,12 @@
+ #
+ ##############################################################################
+
+-AC_INIT(Make-config.in)
++AC_INIT(torcs, 1.3.1)
+ AC_CONFIG_HEADERS(config.h)
+-AM_INIT_AUTOMAKE(torcs, 1.3.1)
++dnl Workaround code using old VERSION instead of new PACKAGE_VERSION
++VERSION=$PACKAGE_VERSION
++AC_DEFINE_UNQUOTED([VERSION], "$VERSION", [old VERSION workaround])
++AC_SUBST(VERSION)
+
+ dnl Checks for programs.
+ AC_PROG_CC
diff --git a/games-sports/torcs/torcs-1.3.1.ebuild b/games-sports/torcs/torcs-1.3.1.ebuild
index 4a4dbb10dbd4..b25a25665fb5 100644
--- a/games-sports/torcs/torcs-1.3.1.ebuild
+++ b/games-sports/torcs/torcs-1.3.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/torcs-1.3.1.ebuild,v 1.9 2011/05/30 01:57:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/torcs-1.3.1.ebuild,v 1.10 2012/03/22 15:05:44 vapier Exp $
EAPI=2
inherit autotools eutils multilib games
@@ -29,7 +29,8 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch \
"${FILESDIR}"/${P}-as-needed.patch \
- "${FILESDIR}"/${P}-libpng15.patch
+ "${FILESDIR}"/${P}-libpng15.patch \
+ "${FILESDIR}"/${P}-no-automake.patch
eautoreconf
ecvs_clean
}