summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-09-11 22:04:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-09-11 22:04:53 +0000
commit555eb107a38886768aecb4cb0f30803c542b039c (patch)
tree03a547ad7962d87afc69f3765512250e9cd1efea /games-sports
parentKeywording for ppc. (diff)
downloadgentoo-2-555eb107a38886768aecb4cb0f30803c542b039c.tar.gz
gentoo-2-555eb107a38886768aecb4cb0f30803c542b039c.tar.bz2
gentoo-2-555eb107a38886768aecb4cb0f30803c542b039c.zip
Add patch for building on 64bit from Franz Fellner (bug #284464)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/xmoto/ChangeLog6
-rw-r--r--games-sports/xmoto/files/xmoto-0.5.2-64bit.patch33
-rw-r--r--games-sports/xmoto/xmoto-0.5.2.ebuild3
3 files changed, 40 insertions, 2 deletions
diff --git a/games-sports/xmoto/ChangeLog b/games-sports/xmoto/ChangeLog
index e305250267d2..0e43490d7585 100644
--- a/games-sports/xmoto/ChangeLog
+++ b/games-sports/xmoto/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-sports/xmoto
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.38 2009/09/09 15:43:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.39 2009/09/11 22:04:53 mr_bones_ Exp $
+
+ 11 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org> xmoto-0.5.2.ebuild,
+ +files/xmoto-0.5.2-64bit.patch:
+ Add patch for building on 64bit from Franz Fellner (bug #284464)
*xmoto-0.5.2 (09 Sep 2009)
diff --git a/games-sports/xmoto/files/xmoto-0.5.2-64bit.patch b/games-sports/xmoto/files/xmoto-0.5.2-64bit.patch
new file mode 100644
index 000000000000..01afb15e0115
--- /dev/null
+++ b/games-sports/xmoto/files/xmoto-0.5.2-64bit.patch
@@ -0,0 +1,33 @@
+--- src/DBuffer.h.org 2009-09-10 11:58:28.000000000 +0200
++++ src/DBuffer.h 2009-09-10 12:07:30.000000000 +0200
+@@ -69,6 +69,8 @@
+ void operator >>(unsigned char &c);
+ void operator <<(unsigned int n);
+ void operator >>(unsigned int &n);
++ void operator <<(unsigned long n);
++ void operator >>(unsigned long &n);
+ void operator <<(float n);
+ void operator >>(float &n);
+ void operator <<(std::string s);
+
+--- src/DBuffer.cpp.org 2009-09-10 11:58:38.000000000 +0200
++++ src/DBuffer.cpp 2009-09-10 12:08:18.000000000 +0200
+@@ -210,6 +210,18 @@
+ n = (unsigned int) sn;
+ }
+
++ void DBuffer::operator <<(unsigned long n) {
++ int sn;
++ sn = (int) (n);
++ *this << sn;
++ }
++
++ void DBuffer::operator >>(unsigned long &n) {
++ int sn;
++ *this >> sn;
++ n = (unsigned long) sn;
++ }
++
+ void DBuffer::operator <<(float n) {
+ writeBuf_LE((char *)&n, sizeof(float));
+ }
diff --git a/games-sports/xmoto/xmoto-0.5.2.ebuild b/games-sports/xmoto/xmoto-0.5.2.ebuild
index e792680748ff..40febdfafc52 100644
--- a/games-sports/xmoto/xmoto-0.5.2.ebuild
+++ b/games-sports/xmoto/xmoto-0.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/xmoto-0.5.2.ebuild,v 1.1 2009/09/09 15:43:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/xmoto-0.5.2.ebuild,v 1.2 2009/09/11 22:04:53 mr_bones_ Exp $
EAPI=2
inherit eutils games
@@ -45,6 +45,7 @@ src_prepare() {
-e '/^gettextsrcdir/s:=.*:= @localedir@/gettext/po:' \
po/Makefile.in.in \
|| die "sed failed"
+ epatch "${FILESDIR}"/${P}-64bit.patch
}
src_configure() {