summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-01-11 21:42:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-01-11 21:42:40 +0000
commit247750174ca6cca5c64b50f845a5e972ed41bf8b (patch)
tree760193fec62cc10e23b4f3f24a46d7928025ab70 /games-sports
parentMask off gcc-4 before it goes ~x86, as it is not yet good for SSP. (diff)
downloadgentoo-2-247750174ca6cca5c64b50f845a5e972ed41bf8b.tar.gz
gentoo-2-247750174ca6cca5c64b50f845a5e972ed41bf8b.tar.bz2
gentoo-2-247750174ca6cca5c64b50f845a5e972ed41bf8b.zip
tidy
(Portage version: 2.0.53)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/gracer/ChangeLog7
-rw-r--r--games-sports/gracer/gracer-0.1.5.ebuild33
2 files changed, 21 insertions, 19 deletions
diff --git a/games-sports/gracer/ChangeLog b/games-sports/gracer/ChangeLog
index b9cc0891b73a..f78a6f71db07 100644
--- a/games-sports/gracer/ChangeLog
+++ b/games-sports/gracer/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-sports/gracer
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/ChangeLog,v 1.11 2005/09/26 18:22:15 wolf31o2 Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/ChangeLog,v 1.12 2006/01/11 21:42:40 mr_bones_ Exp $
+
+ 11 Jan 2006; Michael Sterrett <mr_bones_@gentoo.org> gracer-0.1.5.ebuild:
+ tidy
26 Sep 2005; Chris Gianelloni <wolf31o2@gentoo.org> gracer-0.1.5.ebuild:
Making games last on inherit line.
diff --git a/games-sports/gracer/gracer-0.1.5.ebuild b/games-sports/gracer/gracer-0.1.5.ebuild
index 6fbf15064976..3b35df956121 100644
--- a/games-sports/gracer/gracer-0.1.5.ebuild
+++ b/games-sports/gracer/gracer-0.1.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/gracer-0.1.5.ebuild,v 1.11 2005/09/26 18:22:15 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/gracer-0.1.5.ebuild,v 1.12 2006/01/11 21:42:40 mr_bones_ Exp $
inherit gnuconfig eutils games
@@ -10,10 +10,10 @@ SRC_URI="mirror://sourceforge/gracer/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 sparc ~amd64 ppc"
+KEYWORDS="~amd64 ppc sparc x86"
IUSE="gif jpeg png joystick"
-RDEPEND="virtual/x11
+DEPEND="virtual/x11
virtual/glu
virtual/glut
virtual/opengl
@@ -22,32 +22,31 @@ RDEPEND="virtual/x11
jpeg? ( media-libs/jpeg )
png? ( media-libs/libpng )
media-libs/plib"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch "${FILESDIR}/${PV}-gldefs.patch"
- epatch ${FILESDIR}/${PN}-gcc-3.4.patch
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${PV}-gldefs.patch
+ "${FILESDIR}"/${PN}-gcc-3.4.patch
}
src_compile() {
gnuconfig_update
egamesconf \
- `use_enable joystick` \
- `use_enable gif` \
- `use_enable jpeg` \
- `use_enable png` \
- || die
+ $(use_enable joystick) \
+ $(use_enable gif) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ || die
sed -i \
- -e 's:-lplibsl:-lplibsl -lplibul:' `find -name Makefile` \
+ -e 's:-lplibsl:-lplibsl -lplibul:' $(find -name Makefile) \
|| die "sed Makefiles failed"
emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
prepgamesdirs
}