summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-20 22:57:18 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-20 22:57:18 +0000
commitc5c4d4bfc46c774cdb5906f4be97e0790792583a (patch)
tree8ec8d16cfee1c92c16180a5c84eab07d711cda82 /games-sports/trigger
parentStable on Alpha. (diff)
downloadgentoo-2-c5c4d4bfc46c774cdb5906f4be97e0790792583a.tar.gz
gentoo-2-c5c4d4bfc46c774cdb5906f4be97e0790792583a.tar.bz2
gentoo-2-c5c4d4bfc46c774cdb5906f4be97e0790792583a.zip
Version bump
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'games-sports/trigger')
-rw-r--r--games-sports/trigger/ChangeLog7
-rw-r--r--games-sports/trigger/files/digest-trigger-0.5.2.16
-rw-r--r--games-sports/trigger/trigger-0.5.2.1.ebuild56
3 files changed, 68 insertions, 1 deletions
diff --git a/games-sports/trigger/ChangeLog b/games-sports/trigger/ChangeLog
index b315f3ee30ad..a11012537b92 100644
--- a/games-sports/trigger/ChangeLog
+++ b/games-sports/trigger/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-sports/trigger
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/trigger/ChangeLog,v 1.15 2006/10/17 01:39:31 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/trigger/ChangeLog,v 1.16 2006/10/20 22:57:17 nyhm Exp $
+
+*trigger-0.5.2.1 (20 Oct 2006)
+
+ 20 Oct 2006; Tristan Heaven <nyhm@gentoo.org> +trigger-0.5.2.1.ebuild:
+ Version bump
17 Oct 2006; Tristan Heaven <nyhm@gentoo.org> trigger-0.5.2-r1.ebuild:
Use autotools eclass; fix dependencies
diff --git a/games-sports/trigger/files/digest-trigger-0.5.2.1 b/games-sports/trigger/files/digest-trigger-0.5.2.1
new file mode 100644
index 000000000000..4c12e82d6335
--- /dev/null
+++ b/games-sports/trigger/files/digest-trigger-0.5.2.1
@@ -0,0 +1,6 @@
+MD5 620717e9ad2d6f5e8cf9047f4a33b3ee trigger-0.5.2-data.tar.bz2 6188960
+RMD160 5ff60c0138c4bda16d67493afe71a9a7996aecaa trigger-0.5.2-data.tar.bz2 6188960
+SHA256 c97f339fb5760054eb573eac1576e6b6cec05c5de548636a0bfb7dbc85bdae6b trigger-0.5.2-data.tar.bz2 6188960
+MD5 2b1cf3741b210b0f156f6b15d33e4f0b trigger-0.5.2.1-src.tar.bz2 333592
+RMD160 8419bbd9828fd088a3bec3a8a238f09285fa6c01 trigger-0.5.2.1-src.tar.bz2 333592
+SHA256 0f727f6b02f852018869f21235b208451f0c979a74a3e50e015c982fa4e14b9f trigger-0.5.2.1-src.tar.bz2 333592
diff --git a/games-sports/trigger/trigger-0.5.2.1.ebuild b/games-sports/trigger/trigger-0.5.2.1.ebuild
new file mode 100644
index 000000000000..fd66507a29f2
--- /dev/null
+++ b/games-sports/trigger/trigger-0.5.2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/trigger/trigger-0.5.2.1.ebuild,v 1.1 2006/10/20 22:57:17 nyhm Exp $
+
+inherit eutils games
+
+DATA_V=0.5.2
+DESCRIPTION="Free OpenGL rally car racing game"
+HOMEPAGE="http://www.positro.net/trigger/"
+SRC_URI="mirror://sourceforge/${PN}-rally/${P}-src.tar.bz2
+ mirror://sourceforge/${PN}-rally/${PN}-${DATA_V}-data.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ x11-libs/libX11
+ x11-libs/libXt
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/openal
+ media-libs/freealut
+ dev-games/physfs"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ dev-util/jam"
+
+S=${WORKDIR}/${P}-src
+
+src_compile() {
+ egamesconf --datadir="${GAMES_DATADIR}/${PN}" || die
+ jam -q ${MAKEOPTS} || die "jam failed"
+}
+
+src_install() {
+ dogamesbin trigger || die "dogamesbin failed"
+
+ cd ../${PN}-${DATA_V}-data
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r events maps plugins sounds textures vehicles trigger.config.defs \
+ || die "doins failed"
+
+ dodoc README.txt README-stereo.txt
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "After running ${PN} for the first time, a config file is"
+ elog "available in ~/.trigger/trigger.config"
+ echo
+}