summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-03-12 15:39:27 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-03-12 15:39:27 +0000
commit0b29829651a96d46634dcb0044e1b8a4bed3e365 (patch)
treefbf4a619deb1fc903311602f92edc6b33a52185b /games-sports/trigger
parentx86 stable (diff)
downloadgentoo-2-0b29829651a96d46634dcb0044e1b8a4bed3e365.tar.gz
gentoo-2-0b29829651a96d46634dcb0044e1b8a4bed3e365.tar.bz2
gentoo-2-0b29829651a96d46634dcb0044e1b8a4bed3e365.zip
Install menu entry, bug #160255
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-sports/trigger')
-rw-r--r--games-sports/trigger/ChangeLog7
-rw-r--r--games-sports/trigger/trigger-0.5.2.1.ebuild16
2 files changed, 11 insertions, 12 deletions
diff --git a/games-sports/trigger/ChangeLog b/games-sports/trigger/ChangeLog
index d0f7bf0b4b20..7742edfe92c5 100644
--- a/games-sports/trigger/ChangeLog
+++ b/games-sports/trigger/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-sports/trigger
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/trigger/ChangeLog,v 1.18 2006/11/04 13:53:54 kugelfang Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/trigger/ChangeLog,v 1.19 2007/03/12 15:39:27 nyhm Exp $
+
+ 12 Mar 2007; Tristan Heaven <nyhm@gentoo.org> trigger-0.5.2.1.ebuild:
+ Install menu entry, bug #160255
04 Nov 2006; Danny van Dyk <kugelfang@gentoo.org> trigger-0.5.2.1.ebuild:
Marked stable on amd64.
diff --git a/games-sports/trigger/trigger-0.5.2.1.ebuild b/games-sports/trigger/trigger-0.5.2.1.ebuild
index f154629b3b3d..38c0678afeb3 100644
--- a/games-sports/trigger/trigger-0.5.2.1.ebuild
+++ b/games-sports/trigger/trigger-0.5.2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/trigger/trigger-0.5.2.1.ebuild,v 1.3 2006/11/04 13:53:54 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/trigger/trigger-0.5.2.1.ebuild,v 1.4 2007/03/12 15:39:27 nyhm Exp $
inherit eutils games
@@ -17,8 +17,6 @@ IUSE=""
RDEPEND="virtual/opengl
virtual/glu
- x11-libs/libX11
- x11-libs/libXt
media-libs/libsdl
media-libs/sdl-image
media-libs/sdl-mixer
@@ -26,24 +24,23 @@ RDEPEND="virtual/opengl
media-libs/freealut
dev-games/physfs"
DEPEND="${RDEPEND}
- x11-proto/xproto
dev-util/jam"
S=${WORKDIR}/${P}-src
src_compile() {
- egamesconf --datadir="${GAMES_DATADIR}/${PN}" || die
+ egamesconf --datadir="${GAMES_DATADIR}"/${PN} || die
jam -qa || die "jam failed"
}
src_install() {
dogamesbin trigger || die "dogamesbin failed"
-
cd ../${PN}-${DATA_V}-data
- insinto "${GAMES_DATADIR}/${PN}"
+ insinto "${GAMES_DATADIR}"/${PN}
doins -r events maps plugins sounds textures vehicles trigger.config.defs \
|| die "doins failed"
-
+ newicon textures/life_helmet.png ${PN}.png
+ make_desktop_entry ${PN} Trigger
dodoc README.txt README-stereo.txt
prepgamesdirs
}
@@ -52,5 +49,4 @@ pkg_postinst() {
games_pkg_postinst
elog "After running ${PN} for the first time, a config file is"
elog "available in ~/.trigger/trigger.config"
- echo
}