summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-05-30 01:57:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-05-30 01:57:46 +0000
commit49d7343056b5c727d5249926149d914fb4b48f67 (patch)
tree6745966da7fd896210ca8e1301ade5bf75ebab50 /games-sports/torcs
parentVersion bump (diff)
downloadgentoo-2-49d7343056b5c727d5249926149d914fb4b48f67.tar.gz
gentoo-2-49d7343056b5c727d5249926149d914fb4b48f67.tar.bz2
gentoo-2-49d7343056b5c727d5249926149d914fb4b48f67.zip
add patch for building with libpng from wrstwssr@yahoo.com via bug #369231
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'games-sports/torcs')
-rw-r--r--games-sports/torcs/ChangeLog8
-rw-r--r--games-sports/torcs/files/torcs-1.3.1-libpng15.patch20
-rw-r--r--games-sports/torcs/torcs-1.3.1.ebuild7
3 files changed, 30 insertions, 5 deletions
diff --git a/games-sports/torcs/ChangeLog b/games-sports/torcs/ChangeLog
index d5507ff97a96..cc7fb458ef1b 100644
--- a/games-sports/torcs/ChangeLog
+++ b/games-sports/torcs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-sports/torcs
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/ChangeLog,v 1.33 2010/09/16 17:52:51 scarabeus Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/ChangeLog,v 1.34 2011/05/30 01:57:46 mr_bones_ Exp $
+
+ 30 May 2011; Michael Sterrett <mr_bones_@gentoo.org> torcs-1.3.1.ebuild,
+ +files/torcs-1.3.1-libpng15.patch:
+ add patch for building with libpng from wrstwssr@yahoo.com via bug #369231
16 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org> torcs-1.3.1.ebuild:
virtual/glut -> media-libs/glut
diff --git a/games-sports/torcs/files/torcs-1.3.1-libpng15.patch b/games-sports/torcs/files/torcs-1.3.1-libpng15.patch
new file mode 100644
index 000000000000..6b09ce2a41c8
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.1-libpng15.patch
@@ -0,0 +1,20 @@
+--- a/src/libs/tgfclient/img.cpp
++++ b/src/libs/tgfclient/img.cpp
+@@ -98,7 +98,7 @@
+ return (unsigned char *)NULL;
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+@@ -229,7 +229,7 @@
+ return -1;
+ }
+
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);
+ return -1;
diff --git a/games-sports/torcs/torcs-1.3.1.ebuild b/games-sports/torcs/torcs-1.3.1.ebuild
index e9e283f893f0..4a4dbb10dbd4 100644
--- a/games-sports/torcs/torcs-1.3.1.ebuild
+++ b/games-sports/torcs/torcs-1.3.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/torcs-1.3.1.ebuild,v 1.8 2010/09/16 17:52:51 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/torcs/torcs-1.3.1.ebuild,v 1.9 2011/05/30 01:57:46 mr_bones_ Exp $
EAPI=2
inherit autotools eutils multilib games
@@ -28,7 +28,8 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch \
- "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
eautoreconf
ecvs_clean
}