summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-07-08 15:28:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-07-08 15:28:32 +0000
commit21f916adae49611a44f760535b8ff7557b4078c6 (patch)
tree42ec30559e5a5950e03af5355a083583f43a548b /games-sports/speed-dreams
parentDelete older ebuild. (diff)
downloadgentoo-2-21f916adae49611a44f760535b8ff7557b4078c6.tar.gz
gentoo-2-21f916adae49611a44f760535b8ff7557b4078c6.tar.bz2
gentoo-2-21f916adae49611a44f760535b8ff7557b4078c6.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-sports/speed-dreams')
-rw-r--r--games-sports/speed-dreams/ChangeLog8
-rw-r--r--games-sports/speed-dreams/files/speed-dreams-1.4.0-asneeded.patch110
-rw-r--r--games-sports/speed-dreams/speed-dreams-1.4.0.ebuild80
3 files changed, 197 insertions, 1 deletions
diff --git a/games-sports/speed-dreams/ChangeLog b/games-sports/speed-dreams/ChangeLog
index 885054517f4e..2a3d13aceca7 100644
--- a/games-sports/speed-dreams/ChangeLog
+++ b/games-sports/speed-dreams/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-sports/speed-dreams
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/speed-dreams/ChangeLog,v 1.4 2010/05/02 16:46:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/speed-dreams/ChangeLog,v 1.5 2010/07/08 15:28:32 mr_bones_ Exp $
+
+*speed-dreams-1.4.0 (08 Jul 2010)
+
+ 08 Jul 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +speed-dreams-1.4.0.ebuild, +files/speed-dreams-1.4.0-asneeded.patch:
+ version bump
02 May 2010; Michael Sterrett <mr_bones_@gentoo.org>
speed-dreams-1.4.0_rc1.ebuild:
diff --git a/games-sports/speed-dreams/files/speed-dreams-1.4.0-asneeded.patch b/games-sports/speed-dreams/files/speed-dreams-1.4.0-asneeded.patch
new file mode 100644
index 000000000000..837a2511a191
--- /dev/null
+++ b/games-sports/speed-dreams/files/speed-dreams-1.4.0-asneeded.patch
@@ -0,0 +1,110 @@
+--- configure.in
++++ configure.in
+@@ -123,8 +123,7 @@
+ AC_CHECK_LIB(Xrandr, XRRQueryVersion,,AC_MSG_ERROR([Can't find libXrandr. Please check config.log and if you can't solve the problem send the file to speed-dreams-users@lists.sourceforge.net with the subject \"Speed Dreams compilation problem\"]))
+ AC_CHECK_LIB(openal, alEnable,, AC_MSG_ERROR([Can't find AL/al.h. OpenAL can be found on http://www.openal.org/]))
+ AC_CHECK_LIB(alut, alutLoadWAVFile,
+- LDFLAGS="$LDFLAGS -lalut",
+- LDFLAGS="$LDFLAGS")
++ LIBS="$LIBS -lalut", )
+
+ AC_CHECK_LIB(dl, dlopen)
+ AC_CHECK_FUNC(dlopen,,AC_MSG_ERROR([Can't find dlopen function. Please check config.log and if you can't solve the problem send the file to speed-dreams-users@lists.sourceforge.net with the subject \"Speed Dreams compilation problem\"]))
+@@ -141,7 +140,7 @@
+ AC_CHECK_LIB(glut, glutSwapBuffers,,AC_MSG_ERROR([Can't find libglut. freeglut can be found on http://freeglut.sourceforge.net/]))
+
+ dnl Checks for plib libraries.
+-LDFLAGS="$LDFLAGS -lplibjs"
++AC_CHECK_LIB(plibjs, main,,AC_MSG_ERROR([Can't find libplibjs. PLIB can be found on http://plib.sourceforge.net/]))
+ AC_CHECK_LIB(plibul, main,,AC_MSG_ERROR([Can't find libplibul. PLIB can be found on http://plib.sourceforge.net/]))
+ AC_CHECK_LIB(plibsg, main,,AC_MSG_ERROR([Can't find libplibsg. PLIB can be found on http://plib.sourceforge.net/]))
+ AC_CHECK_LIB(plibsl, main,,AC_MSG_ERROR([Can't find libplibsl. PLIB can be found on http://plib.sourceforge.net/]))
+--- Make-default.mk
++++ Make-default.mk
+@@ -402,7 +402,7 @@
+ ifdef PROGRAM
+
+ ${PROGRAM}: ${OBJECTS} $(subst -l,${EXPORTBASE}/lib/lib, ${LIBS:=.a})
+- ${CXX} ${OBJECTS} ${LDFLAGS} ${LIBS} ${SOLIBS} ${EXT_LIBS} -o $@
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -o $@ ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+
+ installprogram: ${PROGRAM}
+ @ createdir="${INSTLIBBASE}" ; \
+@@ -420,14 +420,14 @@
+ ifdef LOCALTOOLS
+
+ ${LOCALTOOLS}: ${OBJECTS} $(subst -l,${EXPORTBASE}/lib/lib, ${LIBS:=.a})
+- ${CXX} ${OBJECTS} ${LDFLAGS} ${LIBS} ${EXT_LIBS} ${SOLIBS} -o $@
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -o $@ ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+
+ endif
+
+ ifdef TOOLS
+
+ ${TOOLS}: ${OBJECTS} $(subst -l,${EXPORTBASE}/lib/lib, ${LIBS:=.a})
+- ${CXX} ${OBJECTS} ${LDFLAGS} ${LIBS} ${EXT_LIBS} ${SOLIBS} -o $@
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -o $@ ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+
+ installtools: ${TOOLS}
+ @createdir="${INSTBINBASE}/${TOOLSDIR}" ; \
+@@ -478,7 +478,7 @@
+ ifdef SOLIBRARY
+
+ ${SOLIBRARY}: ${OBJECTS}
+- ${CXX} -shared -o ${SOLIBRARY} ${OBJECTS} ${LDFLAGS} ${LIBSPATH} ${LIBS} ${DEBUG_LIBS}
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -shared -o ${SOLIBRARY} ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+ @D=`pwd` ; \
+ createdir="${EXPORTBASE}/lib" ; \
+ $(mkinstalldirs) $$createdir ; \
+@@ -509,7 +509,7 @@
+ ifdef MODULE
+
+ ${MODULE}: ${OBJECTS}
+- ${CXX} -shared -o ${MODULE} ${OBJECTS} ${LDFLAGS} ${LIBSPATH} ${LIBS}
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -shared -o ${MODULE} ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+ @D=`pwd` ; \
+ createdir="${EXPORTBASE}/${MODULEDIR}" ; \
+ $(mkinstalldirs) $$createdir ; \
+--- src/libs/client/Makefile
++++ src/libs/client/Makefile
+@@ -23,6 +23,8 @@
+ SOURCES = entry.cpp mainmenu.cpp splash.cpp exitmenu.cpp \
+ optionmenu.cpp
+
++SOLIBS = -lconfscreens -lraceengine
++
+ LIBS = -lplibssg -lplibsg -lplibul
+
+ EXPDIR = include
+--- src/libs/Makefile
++++ src/libs/Makefile
+@@ -23,7 +23,7 @@
+
+ TOOLSUBDIRS = txml
+
+-SUBDIRS = confscreens racescreens robottools txml tgf tgfclient client raceengineclient learning \
++SUBDIRS = confscreens racescreens robottools txml tgf tgfclient raceengineclient client learning \
+ portability math
+
+ PKGSUBDIRS = $(SUBDIRS)
+--- src/libs/raceengineclient/Makefile
++++ src/libs/raceengineclient/Makefile
+@@ -23,6 +23,8 @@
+ SOURCES = singleplayer.cpp raceinit.cpp racemain.cpp racemanmenu.cpp racestate.cpp racegl.cpp \
+ raceengine.cpp raceresults.cpp
+
++SOLIBS = -lconfscreens -lrobottools -lracescreens
++
+ EXPDIR = include
+
+ EXPORTS = singleplayer.h raceinit.h
+--- src/libs/tgf/Makefile
++++ src/libs/tgf/Makefile
+@@ -29,6 +29,7 @@
+ profiler.cpp \
+ hash.cpp
+
++SOLIBS = -ltxml
+
+ EXPDIR = include
+
diff --git a/games-sports/speed-dreams/speed-dreams-1.4.0.ebuild b/games-sports/speed-dreams/speed-dreams-1.4.0.ebuild
new file mode 100644
index 000000000000..22a2ed2a6d5f
--- /dev/null
+++ b/games-sports/speed-dreams/speed-dreams-1.4.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/speed-dreams/speed-dreams-1.4.0.ebuild,v 1.1 2010/07/08 15:28:32 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils versionator games
+
+DESCRIPTION="A fork of the famous open racing car simulator TORCS"
+HOMEPAGE="http://speed-dreams.sourceforge.net/"
+SRC_URI="mirror://sourceforge/speed-dreams/${P}-r2307-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ virtual/glut
+ >=media-libs/plib-1.8.3
+ media-libs/openal
+ media-libs/freealut
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXt
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ x11-libs/libXrender
+ x11-libs/libXrandr
+ sys-libs/zlib
+ >=media-libs/libpng-1.2.40"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/randrproto"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)-src
+
+# http://sourceforge.net/apps/trac/speed-dreams/ticket/111
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+
+ sed -i \
+ -e '/ADDCFLAGS/s: -O2::' \
+ configure.in || die
+ sed -i \
+ -e '/COPYING/s:=.*:= \\:' \
+ Makefile || die
+ sed -i \
+ -e "/^datadir/s:=.*:= ${GAMES_DATADIR}/${PN}:" \
+ Make-config.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ addpredict $(echo /dev/snd/controlC? | sed 's/ /:/g')
+ [[ -e /dev/dsp ]] && addpredict /dev/dsp
+ egamesconf \
+ --prefix=/usr \
+ --bindir="${GAMES_BINDIR}" \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ emake DESTDIR="${D}" install datainstall || die
+
+ find "${D}" -name Makefile -exec rm -f {} +
+
+ dodoc CHANGES README TODO
+
+ newicon icon.svg ${PN}.svg
+ make_desktop_entry ${PN} "Speed Dreams"
+
+ prepgamesdirs
+}