summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-11-19 22:27:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-11-19 22:27:15 +0000
commit9f0818a313ab67a497cf27f567f41ec56147834c (patch)
treeab9cf1fc0a7f0d090c7be9a323e7e28538a2cc2a /games-simulation
parentVersion bump and remove old. (diff)
downloadgentoo-2-9f0818a313ab67a497cf27f567f41ec56147834c.tar.gz
gentoo-2-9f0818a313ab67a497cf27f567f41ec56147834c.tar.bz2
gentoo-2-9f0818a313ab67a497cf27f567f41ec56147834c.zip
use scons-utils
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/dangerdeep/ChangeLog6
-rw-r--r--games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild21
2 files changed, 12 insertions, 15 deletions
diff --git a/games-simulation/dangerdeep/ChangeLog b/games-simulation/dangerdeep/ChangeLog
index 7f0ef7ae59a0..2907b1ac6e55 100644
--- a/games-simulation/dangerdeep/ChangeLog
+++ b/games-simulation/dangerdeep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/dangerdeep
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/ChangeLog,v 1.12 2010/06/24 17:46:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/ChangeLog,v 1.13 2010/11/19 22:27:15 mr_bones_ Exp $
+
+ 19 Nov 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ dangerdeep-0.3.0.ebuild:
+ use scons-utils
24 Jun 2010; Michael Sterrett <mr_bones_@gentoo.org>
dangerdeep-0.3.0.ebuild, files/dangerdeep-0.3.0-build.patch:
diff --git a/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild b/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
index 7da9ce651256..641f19ecc123 100644
--- a/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
+++ b/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild,v 1.9 2010/07/10 14:54:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild,v 1.10 2010/11/19 22:27:15 mr_bones_ Exp $
EAPI=2
-inherit eutils games
+inherit eutils scons-utils games
DESCRIPTION="a World War II German submarine simulation"
HOMEPAGE="http://dangerdeep.sourceforge.net/"
@@ -18,39 +18,32 @@ IUSE="sse debug"
RDEPEND="virtual/opengl
virtual/glu
sci-libs/fftw:3.0
- media-libs/libsdl[joystick,video]
+ media-libs/libsdl[joystick,opengl,video]
media-libs/sdl-mixer[vorbis]
media-libs/sdl-image[jpeg,png]
media-libs/sdl-net"
DEPEND="${RDEPEND}
- app-arch/unzip
- dev-util/scons"
+ app-arch/unzip"
src_prepare() {
epatch \
"${FILESDIR}"/${P}-build.patch \
"${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/${P}-gcc44.patch
- sed -i \
- -e "/console_log.txt/ s:fopen.*:stderr;:" \
- src/system.cpp \
- || die "sed failed"
+ sed -i -e "/console_log.txt/ s:fopen.*:stderr;:" src/system.cpp || die
}
src_compile() {
local sse=-1
- local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[:space:]*[0-9]\+\).*/\1/; p }")
if use sse ; then
use amd64 && sse=3 || sse=1
fi
- scons \
- ${sconsopts} \
+ escons \
usex86sse=${sse} \
datadir="${GAMES_DATADIR}"/${PN} \
- $(use debug && echo debug=1) \
- || die "scons failed"
+ $(use_scons debug)
}
src_install() {