summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-05-13 01:19:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-05-13 01:19:26 +0000
commit728f3f2730735c4038acfab5b2bbcd2c22f5a304 (patch)
tree7b76fa6891c520505c8f9be326bfa8da4303b1e8 /games-simulation
parentClean up a bit. (diff)
downloadgentoo-2-728f3f2730735c4038acfab5b2bbcd2c22f5a304.tar.gz
gentoo-2-728f3f2730735c4038acfab5b2bbcd2c22f5a304.tar.bz2
gentoo-2-728f3f2730735c4038acfab5b2bbcd2c22f5a304.zip
version bump (bug #82393)
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/searchandrescue/ChangeLog10
-rw-r--r--games-simulation/searchandrescue/Manifest7
-rw-r--r--games-simulation/searchandrescue/files/digest-searchandrescue-0.8.22
-rw-r--r--games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc33.patch31
-rw-r--r--games-simulation/searchandrescue/searchandrescue-0.8.2.ebuild66
5 files changed, 112 insertions, 4 deletions
diff --git a/games-simulation/searchandrescue/ChangeLog b/games-simulation/searchandrescue/ChangeLog
index 12c3a66c3ac3..01d43728c350 100644
--- a/games-simulation/searchandrescue/ChangeLog
+++ b/games-simulation/searchandrescue/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/searchandrescue
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.5 2004/06/24 23:23:15 agriffis Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.6 2005/05/13 01:19:26 mr_bones_ Exp $
+
+*searchandrescue-0.8.2 (13 May 2005)
+
+ 13 May 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/searchandrescue-0.8.2-gcc33.patch, +searchandrescue-0.8.2.ebuild:
+ version bump (bug #82393)
03 Jun 2004; Aron Griffis <agriffis@gentoo.org>
searchandrescue-0.8.1.ebuild:
diff --git a/games-simulation/searchandrescue/Manifest b/games-simulation/searchandrescue/Manifest
index 2364f1c38c0a..0d7ff7fcdcc6 100644
--- a/games-simulation/searchandrescue/Manifest
+++ b/games-simulation/searchandrescue/Manifest
@@ -1,5 +1,8 @@
-MD5 81b7ad22934541fc68584e418f3cbf83 ChangeLog 569
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 827c571c318d6d115a6dc17b0b84f389 searchandrescue-0.8.1.ebuild 1482
-MD5 fb2560ede2f6612695ebd7a69761fcf0 files/digest-searchandrescue-0.8.1 146
+MD5 662e94fb9f7e88ebee4d437ffed92a85 searchandrescue-0.8.2.ebuild 1643
+MD5 81b7ad22934541fc68584e418f3cbf83 ChangeLog 569
MD5 08d186b8d3ec9636687f7453c0981c9b files/searchandrescue-0.8.1-gcc33.patch 883
+MD5 fb2560ede2f6612695ebd7a69761fcf0 files/digest-searchandrescue-0.8.1 146
+MD5 70585567904bf3efb823e6310904356a files/digest-searchandrescue-0.8.2 154
+MD5 08d186b8d3ec9636687f7453c0981c9b files/searchandrescue-0.8.2-gcc33.patch 883
diff --git a/games-simulation/searchandrescue/files/digest-searchandrescue-0.8.2 b/games-simulation/searchandrescue/files/digest-searchandrescue-0.8.2
new file mode 100644
index 000000000000..e0234e832c19
--- /dev/null
+++ b/games-simulation/searchandrescue/files/digest-searchandrescue-0.8.2
@@ -0,0 +1,2 @@
+MD5 f3304fe2e91f329b8494897c398f26f3 SearchAndRescue-0.8.2.tar.bz2 613500
+MD5 3ac0e91b0b3360c4be17fcb5564feca8 SearchAndRescue-data-0.8.2.tar.bz2 7232214
diff --git a/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc33.patch b/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc33.patch
new file mode 100644
index 000000000000..b1cbe3ff9e65
--- /dev/null
+++ b/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc33.patch
@@ -0,0 +1,31 @@
+Work around a gcc-3.3.x bug where redefining prototypes with different
+__THROW / attribute(nonnull) markings throws an error:
+
+string.cpp:31: error: declaration of `char* strcasestr(const char*, const char*)' throws different exceptions
+../include/string.h:46: error: than previous declaration `char* strcasestr(const char*, const char*) throw ()'
+
+basically we just use the glibc strcasestr() instead of the internal one.
+
+http://bugs.gentoo.org/show_bug.cgi?id=85780
+
+--- sar/string.cpp
++++ sar/string.cpp
+@@ -38,3 +38,5 @@
+ #endif
++#ifndef _GNU_SOURCE
+ char *strcasestr(const char *haystack, const char *needle);
++#endif
+ int strpfx(const char *s, const char *pfx);
+@@ -222,3 +223,4 @@
+ */
++#ifndef _GNU_SOURCE
+ char *strcasestr(const char *haystack, const char *needle)
+ {
+@@ -281,6 +281,7 @@
+
+ return(NULL);
+ }
++#endif
+
+ /*
+ * Checks if string pfx is a prefix of string s.
diff --git a/games-simulation/searchandrescue/searchandrescue-0.8.2.ebuild b/games-simulation/searchandrescue/searchandrescue-0.8.2.ebuild
new file mode 100644
index 000000000000..5eda0c679a25
--- /dev/null
+++ b/games-simulation/searchandrescue/searchandrescue-0.8.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/searchandrescue-0.8.2.ebuild,v 1.1 2005/05/13 01:19:26 mr_bones_ Exp $
+
+inherit games eutils
+
+MY_PN=SearchAndRescue
+DESCRIPTION="Helicopter based air rescue flight simulator"
+HOMEPAGE="http://wolfpack.twu.net/SearchAndRescue/"
+SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${MY_PN}-${PV}.tar.bz2
+ ftp://wolfpack.twu.net/users/wolfpack/${MY_PN}-data-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE="joystick"
+
+DEPEND="virtual/x11
+ virtual/opengl
+ media-libs/yiff
+ joystick? ( media-libs/libjsw )"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ unpack ${MY_PN}-${PV}.tar.bz2
+ mkdir data ; cd data
+ unpack ${MY_PN}-data-${PV}.tar.bz2
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc33.patch
+ bunzip2 sar/man/${MY_PN}.6.bz2
+ sed -i \
+ -e '/FeatureCFLAGS.*march/s:=.*:=:g' sar/platforms.ini \
+ || die "sed failed"
+ sed -i \
+ -e "1i\#include <stdio.h>
+ " sar/gctl.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ local myconf
+
+ use joystick \
+ && myconf="--enable=libjsw" \
+ || myconf="--disable=libjsw"
+
+ # NOTE: not an autoconf script
+ ./configure Linux \
+ --prefix="${GAMES_PREFIX}" \
+ ${myconf} \
+ || die
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dogamesbin sar/${MY_PN} || die "dogamesbin failed"
+ doman sar/man/${MY_PN}.6
+ insinto /usr/share/icons/
+ doins sar/icons/*.{ico,xpm}
+ dodoc AUTHORS HACKING README
+ cd "${WORKDIR}/data"
+ dodir "${GAMES_DATADIR}/${MY_PN}"
+ cp -r * "${D}/${GAMES_DATADIR}/${MY_PN}/" || die "cp failed"
+ prepgamesdirs
+}