summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Peterson <lavajoe@gentoo.org>2009-10-23 04:08:02 +0000
committerJoe Peterson <lavajoe@gentoo.org>2009-10-23 04:08:02 +0000
commit71bd2e7b0c1283779a31b8e40430c2b90eb5c18e (patch)
tree506c53e0f371bbc76d5dcfd8bd1efa749613c104 /games-simulation
parentFixed as-needed issues and added dependencies on cholmod and friends (bug #27... (diff)
downloadgentoo-2-71bd2e7b0c1283779a31b8e40430c2b90eb5c18e.tar.gz
gentoo-2-71bd2e7b0c1283779a31b8e40430c2b90eb5c18e.tar.bz2
gentoo-2-71bd2e7b0c1283779a31b8e40430c2b90eb5c18e.zip
Add new 1.23_rc5; remove old
(Portage version: 2.1.7.1/cvs/Linux x86_64)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/secondlife/ChangeLog12
-rw-r--r--games-simulation/secondlife/files/secondlife-1.23_rc5-amd64-audio-streaming-fix.patch26
-rw-r--r--games-simulation/secondlife/files/secondlife-1.23_rc5-fix-memset-error.patch12
-rw-r--r--games-simulation/secondlife/files/secondlife-1.23_rc5-fix-printf-format-error.patch11
-rw-r--r--games-simulation/secondlife/files/secondlife-1.23_rc5-fix-uninitialized-gdkcolor.patch10
-rw-r--r--games-simulation/secondlife/secondlife-1.23_rc5.ebuild (renamed from games-simulation/secondlife/secondlife-1.23_rc4-r1.ebuild)4
6 files changed, 72 insertions, 3 deletions
diff --git a/games-simulation/secondlife/ChangeLog b/games-simulation/secondlife/ChangeLog
index 7404581c05bf..543d8b46219c 100644
--- a/games-simulation/secondlife/ChangeLog
+++ b/games-simulation/secondlife/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for games-simulation/secondlife
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/secondlife/ChangeLog,v 1.5 2009/08/22 21:04:59 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/secondlife/ChangeLog,v 1.6 2009/10/23 04:08:01 lavajoe Exp $
+
+*secondlife-1.23_rc5 (23 Oct 2009)
+
+ 23 Oct 2009; Joe Peterson <lavajoe@gentoo.org>
+ -secondlife-1.23_rc4-r1.ebuild, +secondlife-1.23_rc5.ebuild,
+ +files/secondlife-1.23_rc5-amd64-audio-streaming-fix.patch,
+ +files/secondlife-1.23_rc5-fix-memset-error.patch,
+ +files/secondlife-1.23_rc5-fix-printf-format-error.patch,
+ +files/secondlife-1.23_rc5-fix-uninitialized-gdkcolor.patch:
+ Add new 1.23_rc5; remove old
22 Aug 2009; William Hubbs <williamh@gentoo.org>
secondlife-1.23_rc4-r1.ebuild:
diff --git a/games-simulation/secondlife/files/secondlife-1.23_rc5-amd64-audio-streaming-fix.patch b/games-simulation/secondlife/files/secondlife-1.23_rc5-amd64-audio-streaming-fix.patch
new file mode 100644
index 000000000000..62fd2b40d963
--- /dev/null
+++ b/games-simulation/secondlife/files/secondlife-1.23_rc5-amd64-audio-streaming-fix.patch
@@ -0,0 +1,26 @@
+--- indra/newview/linux_tools/wrapper.sh.old 2009-06-09 08:53:20.000000000 -0600
++++ indra/newview/linux_tools/wrapper.sh 2009-06-14 12:16:32.000000000 -0600
+@@ -5,7 +5,7 @@
+ ## testing phase; you should not usually need to touch them.
+
+ ## - Avoids using any OpenAL audio driver.
+-#export LL_BAD_OPENAL_DRIVER=x
++export LL_BAD_OPENAL_DRIVER=x
+ ## - Avoids using any FMOD audio driver.
+ #export LL_BAD_FMOD_DRIVER=x
+
+@@ -48,10 +48,10 @@
+ ## - GStreamer is automatically disabled - for now - on 64-bit systems due
+ ## to common fatal incompatibilities; remove/comment these lines if you want
+ ## to try anyway.
+-if [ "`uname -m`" = "x86_64" ]; then
+- export LL_DISABLE_GSTREAMER=x
+- echo '64-bit Linux detected: Disabling GStreamer (streaming video and music) by default; edit ./secondlife to re-enable.'
+-fi
++#if [ "`uname -m`" = "x86_64" ]; then
++# export LL_DISABLE_GSTREAMER=x
++# echo '64-bit Linux detected: Disabling GStreamer (streaming video and music) by default; edit ./secondlife to re-enable.'
++#fi
+
+ ## Everything below this line is just for advanced troubleshooters.
+ ##-------------------------------------------------------------------
diff --git a/games-simulation/secondlife/files/secondlife-1.23_rc5-fix-memset-error.patch b/games-simulation/secondlife/files/secondlife-1.23_rc5-fix-memset-error.patch
new file mode 100644
index 000000000000..edff470da052
--- /dev/null
+++ b/games-simulation/secondlife/files/secondlife-1.23_rc5-fix-memset-error.patch
@@ -0,0 +1,12 @@
+--- linden/indra/llmessage/lltemplatemessagereader.cpp~ 2009-05-20 15:26:15.000000000 -0600
++++ linden/indra/llmessage/lltemplatemessagereader.cpp 2009-05-25 21:56:50.000000000 -0600
+@@ -676,8 +676,7 @@
+
+ // default to 0s.
+ U32 size = mvci.getSize();
+- std::vector<U8> data(size);
+- memset(&(data[0]), 0, size);
++ std::vector<U8> data(size, 0);
+ cur_data_block->addData(mvci.getName(), &(data[0]),
+ size, mvci.getType());
+ }
diff --git a/games-simulation/secondlife/files/secondlife-1.23_rc5-fix-printf-format-error.patch b/games-simulation/secondlife/files/secondlife-1.23_rc5-fix-printf-format-error.patch
new file mode 100644
index 000000000000..c99b5302b3da
--- /dev/null
+++ b/games-simulation/secondlife/files/secondlife-1.23_rc5-fix-printf-format-error.patch
@@ -0,0 +1,11 @@
+--- linden/indra/newview/llappviewerlinux.cpp~ 2009-05-20 15:26:19.000000000 -0600
++++ linden/indra/newview/llappviewerlinux.cpp 2009-05-25 23:24:31.000000000 -0600
+@@ -188,7 +188,7 @@
+ for (i = 0; i < size; i++)
+ {
+ // the format of the StraceFile is very specific, to allow (kludgy) machine-parsing
+- fprintf(StraceFile, "%-3d ", i);
++ fprintf(StraceFile, "%-3ld ", (long) i);
+ fprintf(StraceFile, "%-32s\t", "unknown");
+ fprintf(StraceFile, "%p ", stackarray[i]);
+ fprintf(StraceFile, "%s\n", strings[i]);
diff --git a/games-simulation/secondlife/files/secondlife-1.23_rc5-fix-uninitialized-gdkcolor.patch b/games-simulation/secondlife/files/secondlife-1.23_rc5-fix-uninitialized-gdkcolor.patch
new file mode 100644
index 000000000000..e51edaeea883
--- /dev/null
+++ b/games-simulation/secondlife/files/secondlife-1.23_rc5-fix-uninitialized-gdkcolor.patch
@@ -0,0 +1,10 @@
+--- linden/indra/llwindow/llwindowsdl.cpp~ 2009-05-20 15:26:16.000000000 -0600
++++ linden/indra/llwindow/llwindowsdl.cpp 2009-05-25 21:42:55.000000000 -0600
+@@ -2195,6 +2195,7 @@
+ orig_color.red = guint16(65535 * *r);
+ orig_color.green= guint16(65535 * *g);
+ orig_color.blue = guint16(65535 * *b);
++ orig_color.pixel = 0;
+ color = orig_color;
+
+ gtk_color_selection_set_previous_color (colorsel, &color);
diff --git a/games-simulation/secondlife/secondlife-1.23_rc4-r1.ebuild b/games-simulation/secondlife/secondlife-1.23_rc5.ebuild
index 711b4f4e55ad..78f1cde2eaaa 100644
--- a/games-simulation/secondlife/secondlife-1.23_rc4-r1.ebuild
+++ b/games-simulation/secondlife/secondlife-1.23_rc5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/secondlife/secondlife-1.23_rc4-r1.ebuild,v 1.3 2009/08/22 21:04:59 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/secondlife/secondlife-1.23_rc5.ebuild,v 1.1 2009/10/23 04:08:01 lavajoe Exp $
inherit eutils multilib games versionator
-SECONDLIFE_REVISION=123523
+SECONDLIFE_REVISION=136262
SECONDLIFE_MAJOR_VER=$(get_version_component_range 1-2)
SECONDLIFE_MINOR_VER=$(get_version_component_range 3)
SECONDLIFE_MINOR_VER=${SECONDLIFE_MINOR_VER/rc/}