summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-23 05:57:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-23 05:57:08 +0000
commit17d06a17fefc83999ca7a3eb9c924a71874a8180 (patch)
treed3c21302cfb59f9525c37c9515b5435504c6f6a9 /games-simulation/searchandrescue
parentAdd fix from upstream for slow math calls on x86 #431938 by wbrana. (diff)
downloadgentoo-2-17d06a17fefc83999ca7a3eb9c924a71874a8180.tar.gz
gentoo-2-17d06a17fefc83999ca7a3eb9c924a71874a8180.tar.bz2
gentoo-2-17d06a17fefc83999ca7a3eb9c924a71874a8180.zip
version bump (bug #452266)
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-simulation/searchandrescue')
-rw-r--r--games-simulation/searchandrescue/ChangeLog11
-rw-r--r--games-simulation/searchandrescue/files/searchandrescue-1.4.0-build.patch10
-rw-r--r--games-simulation/searchandrescue/files/searchandrescue-1.5.0-build.patch66
-rw-r--r--games-simulation/searchandrescue/searchandrescue-1.5.0.ebuild70
4 files changed, 149 insertions, 8 deletions
diff --git a/games-simulation/searchandrescue/ChangeLog b/games-simulation/searchandrescue/ChangeLog
index 4f79831af327..c9d02ed04c3c 100644
--- a/games-simulation/searchandrescue/ChangeLog
+++ b/games-simulation/searchandrescue/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-simulation/searchandrescue
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.36 2012/07/03 15:55:54 mr_bones_ Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.37 2013/01/23 05:57:08 mr_bones_ Exp $
+
+*searchandrescue-1.5.0 (23 Jan 2013)
+
+ 23 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/searchandrescue-1.5.0-build.patch, +searchandrescue-1.5.0.ebuild,
+ files/searchandrescue-1.4.0-build.patch:
+ version bump (bug #452266)
03 Jul 2012; Michael Sterrett <mr_bones_@gentoo.org>
-files/searchandrescue-1.3.0-build.patch, -searchandrescue-1.1.0.ebuild,
diff --git a/games-simulation/searchandrescue/files/searchandrescue-1.4.0-build.patch b/games-simulation/searchandrescue/files/searchandrescue-1.4.0-build.patch
index fe7236fbced0..40428bade2d7 100644
--- a/games-simulation/searchandrescue/files/searchandrescue-1.4.0-build.patch
+++ b/games-simulation/searchandrescue/files/searchandrescue-1.4.0-build.patch
@@ -1,6 +1,5 @@
-diff -ru searchandrescue_1.3.0.orig/sar/makefile_append.ini searchandrescue_1.3.0/sar/makefile_append.ini
---- searchandrescue_1.3.0.orig/sar/makefile_append.ini 2004-08-05 18:34:15.000000000 -0400
-+++ searchandrescue_1.3.0/sar/makefile_append.ini 2011-04-06 18:12:26.599574441 -0400
+--- searchandrescue_1.3.0.orig/sar/makefile_append.ini
++++ searchandrescue_1.3.0/sar/makefile_append.ini
@@ -3,7 +3,7 @@
@@ -45,9 +44,8 @@ diff -ru searchandrescue_1.3.0.orig/sar/makefile_append.ini searchandrescue_1.3.
- @$(RM) $(RMFLAGS) a.out core *.o $(BIN)
+ $(RM) $(RMFLAGS) a.out core *.o $(BIN)
@echo "Clean done."
-diff -ru searchandrescue_1.3.0.orig/sar/platforms.ini searchandrescue_1.3.0/sar/platforms.ini
---- searchandrescue_1.3.0.orig/sar/platforms.ini 2011-03-08 19:29:52.000000000 -0500
-+++ searchandrescue_1.3.0/sar/platforms.ini 2011-04-06 18:12:11.277632730 -0400
+--- searchandrescue_1.3.0.orig/sar/platforms.ini
++++ searchandrescue_1.3.0/sar/platforms.ini
@@ -102,7 +102,7 @@
FeatureDepend = xf86vidmode-lib
DependType = Library
diff --git a/games-simulation/searchandrescue/files/searchandrescue-1.5.0-build.patch b/games-simulation/searchandrescue/files/searchandrescue-1.5.0-build.patch
new file mode 100644
index 000000000000..40428bade2d7
--- /dev/null
+++ b/games-simulation/searchandrescue/files/searchandrescue-1.5.0-build.patch
@@ -0,0 +1,66 @@
+--- searchandrescue_1.3.0.orig/sar/makefile_append.ini
++++ searchandrescue_1.3.0/sar/makefile_append.ini
+@@ -3,7 +3,7 @@
+
+
+ # C++ flags:
+-CPPFLAGS = -D__cplusplus -Dc_plusplus
++CPPFLAGS += -D__cplusplus -Dc_plusplus
+
+
+ # Source files list:
+@@ -16,14 +16,12 @@
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+ @echo "Compiling module $*.o"
+- @$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++ $(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
+ .cpp.o:
+ @echo "Compiling module $*.o"
+- @$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ $(CPP) -c $*.cpp $(INC_DIRS) $(CPPFLAGS)
+
+ # Programs
+-LS = ls
+-LSFLAGS = -s -h -c --color=auto
+ RM = rm
+ RMFLAGS = -f
+
+@@ -32,9 +30,8 @@
+
+ modules: $(OBJ_C) $(OBJ_CPP)
+ @echo -n "Linking modules..."
+- @$(CPP) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIBS) $(LIB_DIRS)
++ $(CPP) $(OBJ_C) $(OBJ_CPP) $(LDFLAGS) -o $(BIN) $(LIBS) $(LIB_DIRS)
+ @echo -n " "
+- @-$(LS) $(LSFLAGS) $(BIN)
+
+ prebuild:
+ @echo "Building program \"$(BIN)\"..."
+@@ -54,5 +51,5 @@
+ clean:
+ @echo "Cleaning program \"$(BIN)\"..."
+ @echo "Deleting all intermediate files..."
+- @$(RM) $(RMFLAGS) a.out core *.o $(BIN)
++ $(RM) $(RMFLAGS) a.out core *.o $(BIN)
+ @echo "Clean done."
+--- searchandrescue_1.3.0.orig/sar/platforms.ini
++++ searchandrescue_1.3.0/sar/platforms.ini
+@@ -102,7 +102,7 @@
+ FeatureDepend = xf86vidmode-lib
+ DependType = Library
+ MustExist = Yes
+- DependPath = libXxf86vm.a
++ DependPath = libXxf86vm.so
+ DependGrepString = XF86VidModeQueryExtension
+ FeatureDepend = xf86vidmode-devel
+ DependType = Header
+@@ -223,7 +223,7 @@
+ FeatureDepend = xf86vidmode-lib
+ DependType = Library
+ MustExist = Yes
+- DependPath = libXxf86vm.a
++ DependPath = libXxf86vm.so
+ DependGrepString = XF86VidModeQueryExtension
+ FeatureDepend = xf86vidmode-devel
+ DependType = Header
diff --git a/games-simulation/searchandrescue/searchandrescue-1.5.0.ebuild b/games-simulation/searchandrescue/searchandrescue-1.5.0.ebuild
new file mode 100644
index 000000000000..b5170fa533c2
--- /dev/null
+++ b/games-simulation/searchandrescue/searchandrescue-1.5.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/searchandrescue-1.5.0.ebuild,v 1.1 2013/01/23 05:57:08 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils flag-o-matic toolchain-funcs games
+
+MY_DATA_PV=1.3.0
+MY_PN=SearchAndRescue
+DESCRIPTION="Helicopter based air rescue flight simulator"
+HOMEPAGE="http://searchandrescue.sourceforge.net/"
+SRC_URI="mirror://sourceforge/searchandrescue/${MY_PN}-${PV}.tar.gz
+ mirror://sourceforge/searchandrescue/${MY_PN}-data-${MY_DATA_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXxf86vm
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXmu
+ x11-libs/libXi
+ x11-libs/libXpm
+ virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto"
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_unpack() {
+ unpack ${MY_PN}-${PV}.tar.gz
+ mkdir data && cd data && \
+ unpack ${MY_PN}-data-${MY_DATA_PV}.tar.gz
+ bunzip2 "${S}"/sar/man/${MY_PN}.6.bz2 || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_configure() {
+ append-flags -DNEW_GRAPHICS -DHAVE_SDL_MIXER
+ export CPP="$(tc-getCXX)"
+ export CPPFLAGS="${CXXFLAGS}"
+ # NOTE: not an autoconf script
+ ./configure Linux --prefix="${GAMES_PREFIX}" || die
+ sed -i -e 's/@\$/$/' sar/Makefile || die
+}
+
+src_compile() {
+ emake -C sar
+}
+src_install() {
+ dogamesbin sar/${MY_PN}
+ doman sar/man/${MY_PN}.6
+ dodoc AUTHORS HACKING README
+ doicon sar/icons/SearchAndRescue.xpm
+ newicon sar/icons/SearchAndRescue.xpm ${PN}.xpm
+ cd "${WORKDIR}/data"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r * "${D}/${GAMES_DATADIR}/${PN}/" || die
+ make_desktop_entry SearchAndRescue "SearchAndRescue" /usr/share/pixmaps/${PN}.xpm
+ prepgamesdirs
+}