summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-09-04 07:25:00 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-09-04 07:25:00 +0000
commit16a1aaf05f248e4454d0fedaf4edf4285c87a27b (patch)
tree3c6e7e554e3fe476290cb2968887c01c20f4ad42 /games-simulation/searchandrescue
parentForce more compiler/assembler tests to true for cross headers. (diff)
downloadgentoo-2-16a1aaf05f248e4454d0fedaf4edf4285c87a27b.tar.gz
gentoo-2-16a1aaf05f248e4454d0fedaf4edf4285c87a27b.tar.bz2
gentoo-2-16a1aaf05f248e4454d0fedaf4edf4285c87a27b.zip
Fix build with gcc-4.4.1 Bug #283451
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-simulation/searchandrescue')
-rw-r--r--games-simulation/searchandrescue/ChangeLog7
-rw-r--r--games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc441.patch12
-rw-r--r--games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild5
3 files changed, 21 insertions, 3 deletions
diff --git a/games-simulation/searchandrescue/ChangeLog b/games-simulation/searchandrescue/ChangeLog
index f6f122bfc99d..73446d0b5649 100644
--- a/games-simulation/searchandrescue/ChangeLog
+++ b/games-simulation/searchandrescue/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/searchandrescue
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.16 2009/03/18 22:37:49 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.17 2009/09/04 07:25:00 tupone Exp $
+
+ 04 Sep 2009; Tupone Alfredo <tupone@gentoo.org>
+ +files/searchandrescue-0.8.2-gcc441.patch,
+ searchandrescue-0.8.2-r1.ebuild:
+ Fix build with gcc-4.4.1 Bug #283451 by Steffen Schaumburg
18 Mar 2009; Brent Baude <ranger@gentoo.org>
searchandrescue-0.8.2-r1.ebuild:
diff --git a/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc441.patch b/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc441.patch
new file mode 100644
index 000000000000..605c41501718
--- /dev/null
+++ b/games-simulation/searchandrescue/files/searchandrescue-0.8.2-gcc441.patch
@@ -0,0 +1,12 @@
+--- include/string.h.old 2009-09-04 09:18:54.000000000 +0200
++++ include/string.h 2009-09-04 09:19:41.000000000 +0200
+@@ -43,7 +43,9 @@
+ #ifdef __MSW__
+ extern int strcasecmp(const char *s1, const char *s2);
+ #endif
++#ifndef _GNU_SOURCE
+ extern char *strcasestr(const char *haystack, const char *needle);
++#endif
+ extern int strpfx(const char *s, const char *pfx);
+ extern int strcasepfx(const char *s, const char *pfx);
+
diff --git a/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild b/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild
index 29baac2b8f27..71ebecb8dfe2 100644
--- a/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild
+++ b/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild,v 1.4 2009/03/18 22:37:49 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/searchandrescue-0.8.2-r1.ebuild,v 1.5 2009/09/04 07:25:00 tupone Exp $
EAPI=2
inherit eutils games
@@ -39,7 +39,8 @@ src_unpack() {
src_prepare() {
epatch "${FILESDIR}"/${P}-gcc33.patch \
"${FILESDIR}"/${P}-gcc41.patch \
- "${FILESDIR}"/${P}-gcc412.patch
+ "${FILESDIR}"/${P}-gcc412.patch \
+ "${FILESDIR}"/${P}-gcc441.patch
bunzip2 sar/man/${MY_PN}.6.bz2
sed -i \
-e '/FeatureCFLAGS.*march/s:=.*:=:g' sar/platforms.ini \