summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-11-04 19:26:10 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-11-04 19:26:10 +0000
commit033d7055ef99c0fcc240f0fa06117dc3cbf5944f (patch)
tree01356e0154511640286310d9a4fabe7e3794bf51 /games-simulation/planets
parentAdded examples USE flag. Thanks to Johannes Weiner <hnazfoo@gmail.com> for th... (diff)
downloadgentoo-2-033d7055ef99c0fcc240f0fa06117dc3cbf5944f.tar.gz
gentoo-2-033d7055ef99c0fcc240f0fa06117dc3cbf5944f.tar.bz2
gentoo-2-033d7055ef99c0fcc240f0fa06117dc3cbf5944f.zip
Fix built_with_use check, bug #154056
(Portage version: 2.1.2_rc1-r3)
Diffstat (limited to 'games-simulation/planets')
-rw-r--r--games-simulation/planets/ChangeLog6
-rw-r--r--games-simulation/planets/planets-0.1.10.ebuild8
-rw-r--r--games-simulation/planets/planets-0.1.12.ebuild8
3 files changed, 13 insertions, 9 deletions
diff --git a/games-simulation/planets/ChangeLog b/games-simulation/planets/ChangeLog
index 1c840631b28a..9b6e7448dd3d 100644
--- a/games-simulation/planets/ChangeLog
+++ b/games-simulation/planets/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/planets
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/ChangeLog,v 1.10 2006/09/17 10:47:40 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/ChangeLog,v 1.11 2006/11/04 19:26:10 nyhm Exp $
+
+ 04 Nov 2006; Tristan Heaven <nyhm@gentoo.org> planets-0.1.10.ebuild,
+ planets-0.1.12.ebuild:
+ Fix built_with_use check, bug #154056
*planets-0.1.12 (17 Sep 2006)
diff --git a/games-simulation/planets/planets-0.1.10.ebuild b/games-simulation/planets/planets-0.1.10.ebuild
index 70de7621f59d..e08993e23706 100644
--- a/games-simulation/planets/planets-0.1.10.ebuild
+++ b/games-simulation/planets/planets-0.1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/planets-0.1.10.ebuild,v 1.11 2006/05/24 21:44:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/planets-0.1.10.ebuild,v 1.12 2006/11/04 19:26:10 nyhm Exp $
inherit eutils games
@@ -20,10 +20,10 @@ DEPEND="${RDEPEND}
pkg_setup() {
# response to bug #134257
- if ! built_with_use dev-lang/ocaml tcltk ; then
+ if ! built_with_use dev-lang/ocaml tk ; then
eerror "${PN} doesn't build properly if"
- eerror "dev-lang/ocaml is built without tcltk support."
- die "Please emerge dev-lang/ocaml with USE=tcltk"
+ eerror "dev-lang/ocaml is built without tk support."
+ die "Please emerge dev-lang/ocaml with USE=tk"
fi
games_pkg_setup
}
diff --git a/games-simulation/planets/planets-0.1.12.ebuild b/games-simulation/planets/planets-0.1.12.ebuild
index a1a696c7db78..23c3ad03bcad 100644
--- a/games-simulation/planets/planets-0.1.12.ebuild
+++ b/games-simulation/planets/planets-0.1.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/planets-0.1.12.ebuild,v 1.1 2006/09/17 10:47:40 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/planets-0.1.12.ebuild,v 1.2 2006/11/04 19:26:10 nyhm Exp $
inherit eutils games
@@ -20,10 +20,10 @@ DEPEND="${RDEPEND}
pkg_setup() {
# response to bug #134257
- if ! built_with_use dev-lang/ocaml tcltk ; then
+ if ! built_with_use dev-lang/ocaml tk ; then
eerror "${PN} doesn't build properly if"
- eerror "dev-lang/ocaml is built without tcltk support."
- die "Please emerge dev-lang/ocaml with USE=tcltk"
+ eerror "dev-lang/ocaml is built without tk support."
+ die "Please emerge dev-lang/ocaml with USE=tk"
fi
games_pkg_setup
}