summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-28 21:59:13 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-28 21:59:13 +0000
commite647960d7f329d3fe29f6b6391005d10ef15b01a (patch)
treec394c9219501ade95ff369f203456bef70e9cb3a /games-simulation/openttd
parentUnmask some of CPU_FLAGS_X86 in darwin profiles. (diff)
downloadgentoo-2-e647960d7f329d3fe29f6b6391005d10ef15b01a.tar.gz
gentoo-2-e647960d7f329d3fe29f6b6391005d10ef15b01a.tar.bz2
gentoo-2-e647960d7f329d3fe29f6b6391005d10ef15b01a.zip
Switch to CPU_FLAGS_X86.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-simulation/openttd')
-rw-r--r--games-simulation/openttd/ChangeLog5
-rw-r--r--games-simulation/openttd/openttd-1.4.4.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index 4741a756e069..f3d841b219bf 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-simulation/openttd
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.150 2015/01/26 18:10:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.151 2015/01/28 21:59:13 mgorny Exp $
+
+ 28 Jan 2015; Michał Górny <mgorny@gentoo.org> openttd-1.4.4.ebuild:
+ Switch to CPU_FLAGS_X86.
26 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org>
-files/openttd-1.4.2-cflags.patch, -openttd-1.4.2.ebuild:
diff --git a/games-simulation/openttd/openttd-1.4.4.ebuild b/games-simulation/openttd/openttd-1.4.4.ebuild
index b2ba4eb643a7..80bbfcef1c8b 100644
--- a/games-simulation/openttd/openttd-1.4.4.ebuild
+++ b/games-simulation/openttd/openttd-1.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-1.4.4.ebuild,v 1.1 2015/01/10 05:38:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-1.4.4.ebuild,v 1.2 2015/01/28 21:59:13 mgorny Exp $
EAPI=5
inherit eutils gnome2-utils games
@@ -12,7 +12,7 @@ SRC_URI="http://binaries.openttd.org/releases/${PV}/${P}-source.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="aplaymidi debug dedicated iconv icu lzo +openmedia +png sse +timidity +truetype zlib"
+IUSE="aplaymidi debug dedicated iconv icu lzo +openmedia +png cpu_flags_x86_sse +timidity +truetype zlib"
RESTRICT="test" # needs a graphics set in order to test
DEPEND="!dedicated? (
@@ -94,7 +94,7 @@ src_configure() {
${myopts} \
$(use_with iconv) \
$(use_with png) \
- $(use_with sse) \
+ $(use_with cpu_flags_x86_sse sse) \
$(use_with lzo liblzo2) \
|| die
}