summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-09-08 17:18:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-09-08 17:18:14 +0000
commit015c6f094c53bc62b2b73f33b1e029836c941030 (patch)
treec520cf401494150fa56eeccdbaf02dbb6083f3e7 /games-simulation/flightgear
parentTypo (diff)
downloadgentoo-2-015c6f094c53bc62b2b73f33b1e029836c941030.tar.gz
gentoo-2-015c6f094c53bc62b2b73f33b1e029836c941030.tar.bz2
gentoo-2-015c6f094c53bc62b2b73f33b1e029836c941030.zip
fix building with USE=sdl (bug #237020)
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-simulation/flightgear')
-rw-r--r--games-simulation/flightgear/ChangeLog6
-rw-r--r--games-simulation/flightgear/files/flightgear-1.0.0-sdl.patch11
-rw-r--r--games-simulation/flightgear/flightgear-1.0.0.ebuild11
3 files changed, 25 insertions, 3 deletions
diff --git a/games-simulation/flightgear/ChangeLog b/games-simulation/flightgear/ChangeLog
index 0fe39aeb644d..fe99f0469a1c 100644
--- a/games-simulation/flightgear/ChangeLog
+++ b/games-simulation/flightgear/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/flightgear
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/ChangeLog,v 1.32 2008/09/07 13:24:12 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/ChangeLog,v 1.33 2008/09/08 17:18:14 mr_bones_ Exp $
+
+ 08 Sep 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/flightgear-1.0.0-sdl.patch, flightgear-1.0.0.ebuild:
+ fix building with USE=sdl (bug #237020)
07 Sep 2008; Markus Meier <maekke@gentoo.org> flightgear-1.0.0.ebuild:
x86 stable, bug #217505
diff --git a/games-simulation/flightgear/files/flightgear-1.0.0-sdl.patch b/games-simulation/flightgear/files/flightgear-1.0.0-sdl.patch
new file mode 100644
index 000000000000..835d0f4c0006
--- /dev/null
+++ b/games-simulation/flightgear/files/flightgear-1.0.0-sdl.patch
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2008-09-08 12:57:35.000000000 -0400
++++ configure.ac 2008-09-08 12:58:50.000000000 -0400
+@@ -268,6 +268,8 @@
+ AC_SEARCH_LIBS(glutGetModifiers, [ glut freeglut ])
+ if test "x$enable_sdl" = "xyes"; then
+ AC_SEARCH_LIBS(SDL_Init, SDL)
++ CFLAGS="$CFLAGS `sdl-config --cflags`"
++ CXXFLAGS="$CXXFLAGS `sdl-config --cflags`"
+ fi
+ ;;
+
diff --git a/games-simulation/flightgear/flightgear-1.0.0.ebuild b/games-simulation/flightgear/flightgear-1.0.0.ebuild
index ec7481b60e5e..af57c02cb07a 100644
--- a/games-simulation/flightgear/flightgear-1.0.0.ebuild
+++ b/games-simulation/flightgear/flightgear-1.0.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/flightgear-1.0.0.ebuild,v 1.2 2008/09/07 13:24:12 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/flightgear-1.0.0.ebuild,v 1.3 2008/09/08 17:18:14 mr_bones_ Exp $
-inherit eutils games
+inherit autotools eutils games
MY_PN=FlightGear
MY_P=${MY_PN}-${PV}
@@ -24,6 +24,13 @@ DEPEND="virtual/glut
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-sdl.patch"
+ eautoreconf
+}
+
src_compile() {
egamesconf \
--disable-dependency-tracking \