summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-01 00:06:14 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-01 00:06:14 +0000
commit82f3c9200c0a7c2b7462470d78b7d2499ef4eeeb (patch)
tree87292a63489c70aca7e321814279a701623a7c88 /games-simulation/dangerdeep
parentVersion bump. (diff)
downloadgentoo-2-82f3c9200c0a7c2b7462470d78b7d2499ef4eeeb.tar.gz
gentoo-2-82f3c9200c0a7c2b7462470d78b7d2499ef4eeeb.tar.bz2
gentoo-2-82f3c9200c0a7c2b7462470d78b7d2499ef4eeeb.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-simulation/dangerdeep')
-rw-r--r--games-simulation/dangerdeep/ChangeLog6
-rw-r--r--games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild6
-rw-r--r--games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc43.patch80
3 files changed, 89 insertions, 3 deletions
diff --git a/games-simulation/dangerdeep/ChangeLog b/games-simulation/dangerdeep/ChangeLog
index 830686da5850..e6e999bba2d1 100644
--- a/games-simulation/dangerdeep/ChangeLog
+++ b/games-simulation/dangerdeep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/dangerdeep
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/ChangeLog,v 1.7 2008/02/29 19:37:06 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/ChangeLog,v 1.8 2008/05/01 00:06:13 nyhm Exp $
+
+ 01 May 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/dangerdeep-0.3.0-gcc43.patch, dangerdeep-0.3.0.ebuild:
+ Fix building with gcc-4.3
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> dangerdeep-0.3.0.ebuild:
Remove icon extension from desktop entry to match Icon Theme Specification.
diff --git a/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild b/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
index 999a9b29fc79..7ae5aacbca5b 100644
--- a/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
+++ b/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild,v 1.3 2008/02/29 19:37:06 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild,v 1.4 2008/05/01 00:06:13 nyhm Exp $
inherit eutils games
@@ -28,7 +28,9 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}-build.patch"
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
sed -i \
-e "/console_log.txt/ s:fopen.*:stderr;:" \
src/system.cpp \
diff --git a/games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc43.patch b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc43.patch
new file mode 100644
index 000000000000..1588b0bbae07
--- /dev/null
+++ b/games-simulation/dangerdeep/files/dangerdeep-0.3.0-gcc43.patch
@@ -0,0 +1,80 @@
+--- src/bspline_test.cpp
++++ src/bspline_test.cpp
+@@ -1,6 +1,7 @@
+ // some test code for the 2d bsplines!
+ #include "bspline.h"
+ #include <fstream>
++#include <cstdlib>
+ using namespace std;
+
+ double rnd() { return double(rand())/RAND_MAX; }
+--- src/convoy.h
++++ src/convoy.h
+@@ -27,6 +27,7 @@
+ #include "vector2.h"
+ #include <new>
+ #include <list>
++#include <memory>
+ class ship;
+
+ ///\brief Grouping of ships and other objects with central control.
+--- src/date.cpp
++++ src/date.cpp
+@@ -21,6 +21,7 @@
+ // subsim (C)+(W) Markus Petermann and Thorsten Jordan. SEE LICENSE
+
+ #include <iomanip>
++#include <cstdlib>
+ #include "date.h"
+ #include "texts.h"
+
+--- src/ocean_wave_generator.h
++++ src/ocean_wave_generator.h
+@@ -29,6 +29,7 @@
+ #include "environment.h"
+ #include <complex>
+ #include <vector>
++#include <cstdlib>
+
+ // use float fftw (faster) or double (default) ?
+ #ifdef WITH_FLOAT_FFTW
+--- src/ptrlist.h
++++ src/ptrlist.h
+@@ -25,6 +25,7 @@
+
+ #include <list>
+ #include <stdexcept>
++#include <memory>
+
+ // same as std::list regarding the interface (partly), but handles pointers.
+ template <class T>
+--- src/ptrvector.h
++++ src/ptrvector.h
+@@ -25,6 +25,7 @@
+
+ #include <vector>
+ #include <stdexcept>
++#include <memory>
+
+ // same as std::vector regarding the interface, but handles pointers.
+ template <class T>
+--- src/sea_object.h
++++ src/sea_object.h
+@@ -27,6 +27,7 @@
+ #include "ptrvector.h"
+ #include <new>
+ #include <stdexcept>
++#include <memory>
+
+ #include "vector3.h"
+ #include "angle.h"
+--- src/widget.cpp
++++ src/widget.cpp
+@@ -32,6 +32,7 @@
+ #include "datadirs.h"
+ #include <set>
+ #include <sstream>
++#include <algorithm>
+ using std::vector;
+ using std::list;
+ using std::string;