summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-12 01:42:01 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-12 01:42:01 +0000
commit995e8ce49931ef6ada4da7198367c08d2b0f5d73 (patch)
treea8b18a5aa09a89f82cf42359ce4e9e7c381a08c9 /games-server
parentold (diff)
downloadgentoo-2-995e8ce49931ef6ada4da7198367c08d2b0f5d73.tar.gz
gentoo-2-995e8ce49931ef6ada4da7198367c08d2b0f5d73.tar.bz2
gentoo-2-995e8ce49931ef6ada4da7198367c08d2b0f5d73.zip
Version bump #67721 by Mark Burrows.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-server')
-rw-r--r--games-server/hlstats/ChangeLog9
-rw-r--r--games-server/hlstats/files/digest-hlstats-1.301
-rw-r--r--games-server/hlstats/hlstats-1.30.ebuild78
3 files changed, 86 insertions, 2 deletions
diff --git a/games-server/hlstats/ChangeLog b/games-server/hlstats/ChangeLog
index 1bed79d809ea..1ce044de30f6 100644
--- a/games-server/hlstats/ChangeLog
+++ b/games-server/hlstats/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-server/hlstats
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/hlstats/ChangeLog,v 1.6 2004/06/25 03:02:12 agriffis Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/hlstats/ChangeLog,v 1.7 2005/02/12 01:42:01 vapier Exp $
+
+*hlstats-1.30 (11 Feb 2005)
+
+ 11 Feb 2005; Mike Frysinger <vapier@gentoo.org> +hlstats-1.30.ebuild:
+ Version bump #67721 by Mark Burrows.
*hlstats-1.20-r1 (23 Jun 2004)
diff --git a/games-server/hlstats/files/digest-hlstats-1.30 b/games-server/hlstats/files/digest-hlstats-1.30
new file mode 100644
index 000000000000..fd007803a729
--- /dev/null
+++ b/games-server/hlstats/files/digest-hlstats-1.30
@@ -0,0 +1 @@
+MD5 eb62a0b1d802fa8c1afc9b707b033531 hlstats-1.30.tar.gz 1316191
diff --git a/games-server/hlstats/hlstats-1.30.ebuild b/games-server/hlstats/hlstats-1.30.ebuild
new file mode 100644
index 000000000000..9d22f6a78cb7
--- /dev/null
+++ b/games-server/hlstats/hlstats-1.30.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/hlstats/hlstats-1.30.ebuild,v 1.1 2005/02/12 01:42:01 vapier Exp $
+
+inherit games webapp
+
+DESCRIPTION="real-time player rankings/statistics for half-life"
+HOMEPAGE="http://www.hlstats.org/"
+SRC_URI="mirror://sourceforge/hlstats/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="dev-lang/perl
+ dev-db/mysql
+ net-www/apache
+ dev-php/mod_php"
+
+pkg_setup() {
+ webapp_pkg_setup
+ games_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc ChangeLog
+
+ insinto ${GAMES_LIBDIR}/${PN}
+ doins *.{pm,plib}
+ insinto ${GAMES_DATADIR}/${PN}
+ doins *.sql
+
+ sed -i \
+ -e "s:\./hlstats\.conf:${GAMES_SYSCONFDIR}/hlstats.conf:" \
+ -e "/^\$opt_libdir =/s:=.*:=\"${GAMES_LIBDIR}/${PN}/\";:" \
+ *.pl || die "sed pl failed"
+ dogamesbin *.pl || die "dogamesbin failed"
+ dobin ${FILESDIR}/hlstats
+ dosed "s:GENTOO_DIR:${GAMES_BINDIR}:" /usr/bin/hlstats
+ newinitd ${FILESDIR}/hlstats.rc hlstats
+
+ insinto ${GAMES_SYSCONFDIR}
+ doins hlstats.conf
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r hlstats.php hlstatsimg hlstatsinc ${D}/${MY_HTDOCSDIR}/
+ webapp_serverowned ${MY_HTDOCSDIR}
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "To setup:"
+ einfo " 1. \`mysqladmin create hlstats\`"
+ einfo " 2. \`mysql hlstats < ${GAMES_DATADIR}/${PN}/hlstats.sql\`"
+ einfo " 3. \`mysql hlstats < ${GAMES_DATADIR}/${PN}/gamesupport_GAME.sql\`"
+ einfo " so if you want cstrike support, replace 'GAME' with 'cstrike'"
+ einfo " 4. Edit ${GAMES_SYSCONFDIR}/hlstats.conf"
+ einfo " 5. Edit ${MY_HTDOCSDIR}/hlstats.php"
+ einfo " 6. \`rc-update add hlstats default\`"
+ einfo " 7. \`/etc/init.d/hlstats start\`"
+ einfo " 8. Edit the cfg files of the game servers you want to track ..."
+ einfo " add these lines to your config file:"
+ einfo " log on"
+ einfo " logaddress 1.2.3.4 27500"
+ einfo " (replace 1.2.3.4 with the IP of the server hlstats is running on)"
+ einfo " 9. If you want daily awards, setup a cronjob to run hlstats-awards.pl"
+ einfo " for example, run \`crontab -e\` and add this entry:"
+ einfo " 30 00 * * * ${GAMES_BINDIR}/hlstats-awards.pl"
+ einfo " 10. Finally ! Start up the server and after a while goto"
+ einfo " http://1.2.3.4/hlstats.php"
+ einfo " (replace 1.2.3.4 with the IP of the server hlstats is running on)"
+ webapp_pkg_postinst
+}