summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-12-16 23:22:35 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-12-16 23:22:35 +0000
commit78bcff81f750507b0118b0eb4ba635a0d479cd42 (patch)
treee5136f79f9e8cf13828c04ee3fced0c0400ed0ee /games-server
parentDo not export variables in the global scope (bug #527076). (diff)
downloadgentoo-2-78bcff81f750507b0118b0eb4ba635a0d479cd42.tar.gz
gentoo-2-78bcff81f750507b0118b0eb4ba635a0d479cd42.tar.bz2
gentoo-2-78bcff81f750507b0118b0eb4ba635a0d479cd42.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-server')
-rw-r--r--games-server/monopd/ChangeLog11
-rw-r--r--games-server/monopd/files/monopd.in20
-rw-r--r--games-server/monopd/monopd-0.9.7.ebuild39
3 files changed, 67 insertions, 3 deletions
diff --git a/games-server/monopd/ChangeLog b/games-server/monopd/ChangeLog
index f1b23c602eff..47e9aa8b2981 100644
--- a/games-server/monopd/ChangeLog
+++ b/games-server/monopd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-server/monopd
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/monopd/ChangeLog,v 1.22 2011/12/15 17:53:14 mr_bones_ Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/monopd/ChangeLog,v 1.23 2014/12/16 23:22:35 mr_bones_ Exp $
+
+*monopd-0.9.7 (16 Dec 2014)
+
+ 16 Dec 2014; Michael Sterrett <mr_bones_@gentoo.org> +files/monopd.in,
+ +monopd-0.9.7.ebuild:
+ version bump
15 Dec 2011; Michael Sterrett <mr_bones_@gentoo.org> monopd-0.9.3-r1.ebuild:
EAPI=2; tidy
@@ -104,4 +110,3 @@
1 Aug 2002; J. Alberto Suárez López <bass@gentoo.org> monopd-0.4.3.ebuild
First relase
-
diff --git a/games-server/monopd/files/monopd.in b/games-server/monopd/files/monopd.in
new file mode 100644
index 000000000000..0fb613c2d012
--- /dev/null
+++ b/games-server/monopd/files/monopd.in
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/monopd/files/monopd.in,v 1.1 2014/12/16 23:22:35 mr_bones_ Exp $
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting monopd server"
+ start-stop-daemon --start -q -b --exec GENTOO_DIR/monopd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping monopd server"
+ start-stop-daemon --stop -q --exec GENTOO_DIR/monopd
+ eend $?
+}
diff --git a/games-server/monopd/monopd-0.9.7.ebuild b/games-server/monopd/monopd-0.9.7.ebuild
new file mode 100644
index 000000000000..491b52e55f85
--- /dev/null
+++ b/games-server/monopd/monopd-0.9.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/monopd/monopd-0.9.7.ebuild,v 1.1 2014/12/16 23:22:35 mr_bones_ Exp $
+
+EAPI=5
+inherit autotools eutils systemd games
+
+DESCRIPTION="server for atlantik games"
+HOMEPAGE="http://gtkatlantic.gradator.net/"
+SRC_URI="http://download.tuxfamily.org/gtkatlantic/monopd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="systemd"
+
+RDEPEND="systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+ >=sys-libs/libmath++-0.0.3"
+
+src_prepare() {
+ sed "s:GENTOO_DIR:\"${GAMES_BINDIR}\":" \
+ "${FILESDIR}"/monopd.in > "${T}"/monopd || die
+ sed -i \
+ -e '/C_SUBST(CXXFLAGS/s/CFLAGS/CXXFLAGS/' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf $(use_with systemd systemd-daemon)
+}
+
+src_install() {
+ default
+ doinitd "${T}"/monopd
+ systemd_dounit doc/systemd/monopd.s*
+ prepgamesdirs
+}