summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-20 10:28:28 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-20 10:28:28 +0000
commit80881fcf53060c3bdbfc1f9a5f7e19eae90bd9e7 (patch)
tree9808e410c41100655042d0dd2f85c418cf4a1d26 /games-server/cyphesis
parentstable x86, bug 341321 (diff)
downloadgentoo-2-80881fcf53060c3bdbfc1f9a5f7e19eae90bd9e7.tar.gz
gentoo-2-80881fcf53060c3bdbfc1f9a5f7e19eae90bd9e7.tar.bz2
gentoo-2-80881fcf53060c3bdbfc1f9a5f7e19eae90bd9e7.zip
Fix test with sys-devel/gcc-4.5. Bug #339666
(Portage version: 2.1.9.20/cvs/Linux i686)
Diffstat (limited to 'games-server/cyphesis')
-rw-r--r--games-server/cyphesis/ChangeLog6
-rw-r--r--games-server/cyphesis/files/cyphesis-0.5.24-gcc45.patch40
2 files changed, 45 insertions, 1 deletions
diff --git a/games-server/cyphesis/ChangeLog b/games-server/cyphesis/ChangeLog
index 529136736186..355d190d199f 100644
--- a/games-server/cyphesis/ChangeLog
+++ b/games-server/cyphesis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-server/cyphesis
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.13 2010/08/31 06:45:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.14 2010/10/20 10:28:28 tupone Exp $
+
+ 20 Oct 2010; Tupone Alfredo <tupone@gentoo.org>
+ files/cyphesis-0.5.24-gcc45.patch:
+ Fix test with sys-devel/gcc-4.5. Bug #339666 by flameeyes@gentoo.org
31 Aug 2010; Michael Sterrett <mr_bones_@gentoo.org>
+cyphesis-0.5.24.ebuild, +files/cyphesis-0.5.24-gcc45.patch,
diff --git a/games-server/cyphesis/files/cyphesis-0.5.24-gcc45.patch b/games-server/cyphesis/files/cyphesis-0.5.24-gcc45.patch
index 7e5c33da049c..f5bea6e4ee76 100644
--- a/games-server/cyphesis/files/cyphesis-0.5.24-gcc45.patch
+++ b/games-server/cyphesis/files/cyphesis-0.5.24-gcc45.patch
@@ -8,3 +8,43 @@
#include <wfmath/axisbox.h>
#include <map>
+--- tests/Locationtest.cpp.old 2010-10-20 11:55:37.000000000 +0200
++++ tests/Locationtest.cpp 2010-10-20 11:56:55.000000000 +0200
+@@ -25,6 +25,7 @@
+
+ #include <Atlas/Objects/Anonymous.h>
+ #include <Atlas/Objects/SmartPtr.h>
++#include <Atlas/Objects/RootOperation.h>
+
+ #include <cassert>
+
+--- tests/EntityPropertytest.cpp.old 2010-10-20 12:01:39.000000000 +0200
++++ tests/EntityPropertytest.cpp 2010-10-20 12:02:03.000000000 +0200
+@@ -22,6 +22,7 @@
+ #include "rulesets/Entity.h"
+
+ #include <Atlas/Objects/Anonymous.h>
++#include <Atlas/Objects/RootOperation.h>
+
+ #include <cassert>
+
+--- tests/PropertyCoverage.cpp.old 2010-10-20 12:03:23.000000000 +0200
++++ tests/PropertyCoverage.cpp 2010-10-20 12:04:24.000000000 +0200
+@@ -27,6 +27,7 @@
+
+ #include <Atlas/Objects/Anonymous.h>
+ #include <Atlas/Objects/SmartPtr.h>
++#include <Atlas/Objects/RootOperation.h>
+
+ using Atlas::Message::Element;
+ using Atlas::Message::MapType;
+--- tests/EntityBuildertest.cpp.old 2010-10-20 12:07:16.000000000 +0200
++++ tests/EntityBuildertest.cpp 2010-10-20 12:07:40.000000000 +0200
+@@ -41,6 +41,7 @@
+ #include "common/Variable.h"
+
+ #include <Atlas/Objects/Anonymous.h>
++#include <Atlas/Objects/RootOperation.h>
+
+ #include <cstdlib>
+