summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-03 00:15:28 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-03 00:15:28 +0000
commitdd45d56ac785d2e58120ef6b90dd582e9bfee35e (patch)
treefdc526ad704e01233a6fc8879574496f3426fd76 /games-rpg
parentadd python dep (diff)
downloadgentoo-2-dd45d56ac785d2e58120ef6b90dd582e9bfee35e.tar.gz
gentoo-2-dd45d56ac785d2e58120ef6b90dd582e9bfee35e.tar.bz2
gentoo-2-dd45d56ac785d2e58120ef6b90dd582e9bfee35e.zip
version bump, migrate to python-single-r1
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/wastesedge/ChangeLog9
-rw-r--r--games-rpg/wastesedge/wastesedge-0.3.5.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/games-rpg/wastesedge/ChangeLog b/games-rpg/wastesedge/ChangeLog
index 8a9e7f1a0d85..669472d6641a 100644
--- a/games-rpg/wastesedge/ChangeLog
+++ b/games-rpg/wastesedge/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/wastesedge
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/wastesedge/ChangeLog,v 1.16 2012/04/13 19:23:51 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/wastesedge/ChangeLog,v 1.17 2013/02/03 00:15:28 hasufell Exp $
+
+*wastesedge-0.3.5 (03 Feb 2013)
+
+ 03 Feb 2013; Julian Ospald <hasufell@gentoo.org> +wastesedge-0.3.5.ebuild:
+ version bump, migrate to python-single-r1
13 Apr 2012; Ulrich Müller <ulm@gentoo.org> wastesedge-0.3.4.ebuild:
Move EAPI assignment to top of ebuild, bug 411875.
diff --git a/games-rpg/wastesedge/wastesedge-0.3.5.ebuild b/games-rpg/wastesedge/wastesedge-0.3.5.ebuild
new file mode 100644
index 000000000000..ea5e84cfc712
--- /dev/null
+++ b/games-rpg/wastesedge/wastesedge-0.3.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/wastesedge/wastesedge-0.3.5.ebuild,v 1.1 2013/02/03 00:15:28 hasufell Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+inherit eutils python-single-r1 games
+
+DESCRIPTION="role playing game to showcase the adonthell engine"
+HOMEPAGE="http://adonthell.linuxgames.com/"
+SRC_URI="http://savannah.nongnu.org/download/adonthell/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="vorbis nls"
+RESTRICT="userpriv"
+
+RDEPEND="${PYTHON_DEPS}
+ >=games-rpg/adonthell-0.3.5-r1[${PYTHON_USEDEP}]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_configure(){
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ --with-adonthell-binary="${GAMES_BINDIR}/adonthell"
+}
+
+src_install(){
+ emake DESTDIR="${D}" pixmapdir=/usr/share/pixmaps install
+ dodoc AUTHORS ChangeLog NEWS PLAYING README
+ make_desktop_entry adonthell-wastesedge "Waste's Edge" wastesedge_32x32
+ prepgamesdirs
+}