summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-02-13 21:08:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-02-13 21:08:32 +0000
commitc6c70ad8f67d4e3332caf04606eed264a1eabe0d (patch)
tree76941377983d55ea9706b841da852c95d716951a /games-rpg
parentRemove workaround and depend on fix in qt-core (diff)
downloadgentoo-2-c6c70ad8f67d4e3332caf04606eed264a1eabe0d.tar.gz
gentoo-2-c6c70ad8f67d4e3332caf04606eed264a1eabe0d.tar.bz2
gentoo-2-c6c70ad8f67d4e3332caf04606eed264a1eabe0d.zip
EAPI=5; compile warning patch
(Portage version: 2.1.11.50/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/gwiz/ChangeLog8
-rw-r--r--games-rpg/gwiz/files/gwiz-0.8-buffer.patch23
-rw-r--r--games-rpg/gwiz/gwiz-0.8.ebuild23
3 files changed, 40 insertions, 14 deletions
diff --git a/games-rpg/gwiz/ChangeLog b/games-rpg/gwiz/ChangeLog
index 52a4478891c3..9be4e9299c47 100644
--- a/games-rpg/gwiz/ChangeLog
+++ b/games-rpg/gwiz/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-rpg/gwiz
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/gwiz/ChangeLog,v 1.9 2011/07/27 17:56:13 pacho Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/gwiz/ChangeLog,v 1.10 2013/02/13 21:08:32 mr_bones_ Exp $
+
+ 13 Feb 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/gwiz-0.8-buffer.patch, gwiz-0.8.ebuild:
+ EAPI=5; compile warning patch
27 Jul 2011; Pacho Ramos <pacho@gentoo.org> gwiz-0.8.ebuild:
Install a menu entry, bug #160221.
diff --git a/games-rpg/gwiz/files/gwiz-0.8-buffer.patch b/games-rpg/gwiz/files/gwiz-0.8-buffer.patch
new file mode 100644
index 000000000000..7c9eb02cf503
--- /dev/null
+++ b/games-rpg/gwiz/files/gwiz-0.8-buffer.patch
@@ -0,0 +1,23 @@
+--- src/equip.c.orig
++++ src/equip.c
+@@ -120,7 +120,7 @@
+ return (i);
+
+ /* if we get this far, there are no equippable items before the current */
+- for (i = 8; i > offset; i--)
++ for (i = 7; i > offset; i--)
+ if (pawn->item[i].usage & USAGE_EQUIPPABLE)
+ return (i);
+ return (-1);
+--- src/shop.c.orig
++++ src/shop.c
+@@ -290,8 +290,7 @@
+
+ SDL_BlitSurface (name, NULL, area, &dest);
+
+- snprintf (price, sizeof(char)*8, "%d", pawn->item[i].sellfor);
+- price[9] = '\0';
++ snprintf (price, sizeof(price), "%d", pawn->item[i].sellfor);
+ profit = GwizRenderText (price);
+ dest.x = area->w - profit->w;
+ dest.w = profit->w;
diff --git a/games-rpg/gwiz/gwiz-0.8.ebuild b/games-rpg/gwiz/gwiz-0.8.ebuild
index a1ce1962db70..33b2cf59e593 100644
--- a/games-rpg/gwiz/gwiz-0.8.ebuild
+++ b/games-rpg/gwiz/gwiz-0.8.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/gwiz/gwiz-0.8.ebuild,v 1.10 2011/07/27 17:56:13 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/gwiz/gwiz-0.8.ebuild,v 1.11 2013/02/13 21:08:32 mr_bones_ Exp $
-inherit eutils
+EAPI=5
+inherit eutils games
DESCRIPTION="clone of old-school Wizardry(tm) games by SirTech"
HOMEPAGE="http://icculus.org/gwiz/"
@@ -13,18 +14,16 @@ SLOT="0"
LICENSE="GPL-2"
IUSE=""
-DEPEND=">=media-libs/libsdl-1.2.3
- >=media-libs/sdl-image-1.2.1-r1
+DEPEND=">=media-libs/libsdl-1.2.3[joystick,video]
+ >=media-libs/sdl-image-1.2.1-r1[png]
>=media-libs/sdl-ttf-2.0.4"
+RDEPEND="${DEPEND}"
-src_compile() {
- econf || die
- emake || die
-}
+PATCHES=( "${FILESDIR}"/${P}-buffer.patch )
src_install() {
- einstall || die
- doicon pixmaps/gwiz_icon.xpm
- make_desktop_entry gwiz Gwiz gwiz_icon.xpm
+ default
dodoc AUTHORS ChangeLog README doc/HOWTO-PLAY
+ newicon pixmaps/gwiz_icon.xpm ${PN}.xpm
+ make_desktop_entry gwiz Gwiz
}