summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-07-14 13:17:57 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-07-14 13:17:57 +0000
commitb9034bbdc2488034f88aa3778cf10fa9a9f00c88 (patch)
treeca3cdb0ee5caa9c9479f58448adc22667ee699fa /games-rpg
parentVersion bump. (diff)
downloadgentoo-2-b9034bbdc2488034f88aa3778cf10fa9a9f00c88.tar.gz
gentoo-2-b9034bbdc2488034f88aa3778cf10fa9a9f00c88.tar.bz2
gentoo-2-b9034bbdc2488034f88aa3778cf10fa9a9f00c88.zip
version bump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/arx-libertatis/ChangeLog7
-rw-r--r--games-rpg/arx-libertatis/arx-libertatis-1.1.ebuild98
-rw-r--r--games-rpg/arx-libertatis/metadata.xml40
3 files changed, 142 insertions, 3 deletions
diff --git a/games-rpg/arx-libertatis/ChangeLog b/games-rpg/arx-libertatis/ChangeLog
index f69ee796e259..23995c3fd40b 100644
--- a/games-rpg/arx-libertatis/ChangeLog
+++ b/games-rpg/arx-libertatis/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/arx-libertatis
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/arx-libertatis/ChangeLog,v 1.15 2013/03/14 01:02:50 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/arx-libertatis/ChangeLog,v 1.16 2013/07/14 13:17:57 hasufell Exp $
+
+*arx-libertatis-1.1 (14 Jul 2013)
+
+ 14 Jul 2013; Julian Ospald <hasufell@gentoo.org> +arx-libertatis-1.1.ebuild:
+ version bump
14 Mar 2013; Julian Ospald <hasufell@gentoo.org>
-arx-libertatis-1.0.2-r1.ebuild, -files/arx-libertatis-1.0.2-cmake2.8.patch,
diff --git a/games-rpg/arx-libertatis/arx-libertatis-1.1.ebuild b/games-rpg/arx-libertatis/arx-libertatis-1.1.ebuild
new file mode 100644
index 000000000000..17dea9346566
--- /dev/null
+++ b/games-rpg/arx-libertatis/arx-libertatis-1.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/arx-libertatis/arx-libertatis-1.1.ebuild,v 1.1 2013/07/14 13:17:57 hasufell Exp $
+
+EAPI=5
+
+CMAKE_WARN_UNUSED_CLI=yes
+inherit eutils cmake-utils gnome2-utils games
+
+DESCRIPTION="Cross-platform port of Arx Fatalis, a first-person role-playing game"
+HOMEPAGE="http://arx-libertatis.org/"
+SRC_URI="mirror://sourceforge/arx/${P}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="c++0x debug +unity-build crash-reporter static tools"
+
+COMMON_DEPEND="
+ media-libs/freetype
+ media-libs/libsdl[X,video,opengl]
+ media-libs/openal
+ sys-libs/zlib
+ virtual/opengl
+ crash-reporter? (
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtgui:4
+ )
+ !static? ( media-libs/glew )"
+RDEPEND="${COMMON_DEPEND}
+ crash-reporter? ( sys-devel/gdb )"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ static? ( media-libs/glew[static-libs] )"
+
+DOCS=( README.md AUTHORS CHANGELOG )
+
+src_configure() {
+ # editor does not build
+ local mycmakeargs=(
+ $(cmake-utils_use_build crash-reporter CRASHREPORTER)
+ -DBUILD_EDITOR=OFF
+ $(cmake-utils_use_build tools TOOLS)
+ -DCMAKE_INSTALL_DATAROOTDIR="${GAMES_DATADIR_BASE}"
+ -DCMAKE_INSTALL_PREFIX="${GAMES_PREFIX}"
+ $(cmake-utils_use debug DEBUG)
+ -DGAMESBINDIR="${GAMES_BINDIR}"
+ -DICONDIR=/usr/share/icons/hicolor/128x128/apps
+ -DINSTALL_SCRIPTS=ON
+ -DSET_OPTIMIZATION_FLAGS=OFF
+ -DSTRICT_USE=ON
+ $(cmake-utils_use unity-build UNITY_BUILD)
+ $(cmake-utils_use_use c++0x CXX11)
+ -DUSE_NATIVE_FS=ON
+ -DUSE_OPENAL=ON
+ -DUSE_OPENGL=ON
+ -DUSE_SDL=ON
+ $(usex crash-reporter "-DUSE_QT5=OFF" "")
+ $(cmake-utils_use_use static STATIC_LIBS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ elog "optional dependencies:"
+ elog " games-rpg/arx-fatalis-data (from CD or GOG)"
+ elog " games-rpg/arx-fatalis-demo (free demo)"
+ elog
+ elog "This package only installs the game binary."
+ elog "You need the demo or full game data. Also see:"
+ elog "http://wiki.arx-libertatis.org/Getting_the_game_data"
+ elog
+ elog "If you have already installed the game or use the STEAM version,"
+ elog "run \"${GAMES_BINDIR}/arx-install-data\""
+
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-rpg/arx-libertatis/metadata.xml b/games-rpg/arx-libertatis/metadata.xml
index e3e2655cdc2c..c431a978dbdf 100644
--- a/games-rpg/arx-libertatis/metadata.xml
+++ b/games-rpg/arx-libertatis/metadata.xml
@@ -7,19 +7,55 @@
<name>Julian Ospald</name>
</maintainer>
<use>
- <flag name='debug'>Enable asserts and debug logging.</flag>
+ <flag name='c++0x'>Build ROOT using the C++11 standard.</flag>
<flag name='crash-reporter'>Build a <pkg>dev-qt/qtgui</pkg>-based
tool that allows to submit crash information to the upstream
backtracker.</flag>
+ <flag name='debug'>Enable asserts and debug logging.</flag>
+ <flag name='static'>Link libraries statically, currently only
+ <pkg>media-libs/glew</pkg></flag>
<flag name='tools'>Build tools that can extract the game's data and
save files.</flag>
<flag name='unity-build'>Build everything in one big source file,
allowing for faster build times and better optimizations at
the cost of higher memory usage.</flag>
</use>
+ <longdescription lang='en'>
+ Arx Libertatis is a cross-platform, open source port of
+ Arx Fatalis, a 2002 first-person role-playing game/dungeon crawler
+ developed by Arkane Studios.
+ Arx Fatalis features crafting, melee and ranged combat, as well
+ as a unique casting system where the player draws runes in real
+ time to effect the desired spell.
+ Arx Libertatis updates and improves Arx Fatalis by supporting
+ modern systems, porting the game to new systems as well as
+ eliminating bugs and limitations.
+ </longdescription>
+ <longdescription lang='de'>
+ Arx Libertatis ist eine cross-platform, open source Portierung
+ von Arx Fatalis, ein Rollenspiel/Dungeon Crawler in Ego-Perspektive
+ aus dem Jahr 2002, entwickelt von Arkane Studios.
+ Arx Fatalist umfasst das Herstellen von Gegenständen,
+ Nah- und Fernkampf, sowie ein einzigartiges Magiesystem,
+ in dem der Spieler Runen in Echtzeit zeichnen muss, um einen
+ Zauberspruch auszusprechen.
+ Arx Libertatis aktualisiert und verbessert Arx Fatalis, indem
+ es moderne Systeme unterstützt, das Spiel auch zu neuen Systemen
+ portiert und bugs und Beschränkungen behebt.
+ </longdescription>
<upstream>
- <doc lang="en">http://wiki.arx-libertatis.org/</doc>
+ <maintainer status='active'>
+ <email>daniel@constexpr.org</email>
+ <name>Daniel Scharrer</name>
+ </maintainer>
<bugs-to>https://bugs.arx-libertatis.org/</bugs-to>
+ <changelog>
+ https://github.com/arx/ArxLibertatis/blob/1.1/CHANGELOG
+ </changelog>
+ <doc lang='en'>http://wiki.arx-libertatis.org/</doc>
+ <remote-id type='github'>arx/ArxLibertatis</remote-id>
+ <remote-id type='sourceforge'>arx</remote-id>
+ <remote-id type='freecode'>arx-libertatis</remote-id>
</upstream>
</pkgmetadata>