summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-07-19 15:32:30 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-07-19 15:32:30 +0000
commit99fadde06e71d0a2382395947ec6b6d17cfde992 (patch)
treedb8cf64dccd8a6cc72d963b5f64ffd2dffce6a84 /games-rpg
parentversion bump (diff)
downloadgentoo-2-99fadde06e71d0a2382395947ec6b6d17cfde992.tar.gz
gentoo-2-99fadde06e71d0a2382395947ec6b6d17cfde992.tar.bz2
gentoo-2-99fadde06e71d0a2382395947ec6b6d17cfde992.zip
version bump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/manaplus/ChangeLog7
-rw-r--r--games-rpg/manaplus/manaplus-1.3.7.7.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/games-rpg/manaplus/ChangeLog b/games-rpg/manaplus/ChangeLog
index 1cbbeab5cb0c..02c4fa91a946 100644
--- a/games-rpg/manaplus/ChangeLog
+++ b/games-rpg/manaplus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/manaplus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/manaplus/ChangeLog,v 1.10 2013/06/25 12:56:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/manaplus/ChangeLog,v 1.11 2013/07/19 15:32:30 hasufell Exp $
+
+*manaplus-1.3.7.7 (19 Jul 2013)
+
+ 19 Jul 2013; Julian Ospald <hasufell@gentoo.org> +manaplus-1.3.7.7.ebuild:
+ version bump
25 Jun 2013; Agostino Sarubbo <ago@gentoo.org> manaplus-1.3.6.9.ebuild:
Stable for amd64, wrt bug #474402
diff --git a/games-rpg/manaplus/manaplus-1.3.7.7.ebuild b/games-rpg/manaplus/manaplus-1.3.7.7.ebuild
new file mode 100644
index 000000000000..3e76db642b75
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.3.7.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/manaplus/manaplus-1.3.7.7.ebuild,v 1.1 2013/07/19 15:32:30 hasufell Exp $
+
+EAPI=5
+
+inherit games
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/manaplus-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls opengl"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ dev-libs/libxml2
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[png]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ net-misc/curl
+ sys-libs/zlib
+ media-libs/libpng:0
+ media-fonts/dejavu
+ >=dev-games/guichan-0.8.1[sdl]
+ media-libs/libsdl[X,opengl?,video]
+ media-libs/sdl-gfx
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ x11-misc/xsel
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e '/^SUBDIRS/s/fonts//' \
+ data/Makefile.in || die
+
+ rm -r src/guichan || die
+}
+
+src_configure() {
+ egamesconf \
+ --without-internalguichan \
+ --localedir=/usr/share/locale \
+ --disable-manaserv \
+ --disable-eathena \
+ $(use_with opengl) \
+ $(use_enable nls) \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}"
+}
+
+src_install() {
+ default
+
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-mono.ttf
+ insinto "${GAMES_DATADIR}"/${PN}/data
+
+ prepgamesdirs
+}