summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-07-29 21:25:23 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-07-29 21:25:23 +0000
commit7cabcbb85a832b78bf4d9c2dedbf55fa92055e3c (patch)
treeb7bab4953f95be7e3b69102061327865ad57dc10 /games-rpg
parentInitial import, bug 474036. (diff)
downloadgentoo-2-7cabcbb85a832b78bf4d9c2dedbf55fa92055e3c.tar.gz
gentoo-2-7cabcbb85a832b78bf4d9c2dedbf55fa92055e3c.tar.bz2
gentoo-2-7cabcbb85a832b78bf4d9c2dedbf55fa92055e3c.zip
fix bug 428316
(Portage version: 2.2.0_alpha190/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/mana/ChangeLog10
-rw-r--r--games-rpg/mana/files/mana-0.6.1-Fix-missing-virtual-destructors-and-guichan-use.patch53
-rw-r--r--games-rpg/mana/files/mana-0.6.1-Import-cstdint-for-int64_t.patch24
-rw-r--r--games-rpg/mana/files/mana-0.6.1-Trick-gcc-into-importing-C99-stdint.h-when-C-11-is-n.patch26
-rw-r--r--games-rpg/mana/mana-0.6.1.ebuild14
5 files changed, 121 insertions, 6 deletions
diff --git a/games-rpg/mana/ChangeLog b/games-rpg/mana/ChangeLog
index 7ef0bbcf1896..dfe0c5470d0a 100644
--- a/games-rpg/mana/ChangeLog
+++ b/games-rpg/mana/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/mana
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/mana/ChangeLog,v 1.14 2012/08/05 11:55:24 hasufell Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/mana/ChangeLog,v 1.15 2013/07/29 21:25:23 hasufell Exp $
+
+ 29 Jul 2013; Julian Ospald <hasufell@gentoo.org> mana-0.6.1.ebuild,
+ +files/mana-0.6.1-Fix-missing-virtual-destructors-and-guichan-use.patch,
+ +files/mana-0.6.1-Import-cstdint-for-int64_t.patch,
+ +files/mana-0.6.1-Trick-gcc-into-importing-C99-stdint.h-when-C-11-is-n.patch:
+ fix bug 428316
05 Aug 2012; Julian Ospald <hasufell@gentoo.org> metadata.xml:
add myself as maintainer
diff --git a/games-rpg/mana/files/mana-0.6.1-Fix-missing-virtual-destructors-and-guichan-use.patch b/games-rpg/mana/files/mana-0.6.1-Fix-missing-virtual-destructors-and-guichan-use.patch
new file mode 100644
index 000000000000..6cd99bf4262c
--- /dev/null
+++ b/games-rpg/mana/files/mana-0.6.1-Fix-missing-virtual-destructors-and-guichan-use.patch
@@ -0,0 +1,53 @@
+From b5dc2de418d6d06cce31d786862c5f548171a097 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 28 Jul 2012 15:52:35 +0200
+Subject: [PATCH 1/3] Fix missing virtual destructors and guichan use.
+
+---
+ src/gui/widgets/tabbedarea.h | 3 ++-
+ src/gui/widgets/textfield.h | 1 +
+ src/resources/itemdb.h | 2 +-
+ 3 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/gui/widgets/tabbedarea.h b/src/gui/widgets/tabbedarea.h
+index 45b092a..b43078a 100644
+--- a/src/gui/widgets/tabbedarea.h
++++ b/src/gui/widgets/tabbedarea.h
+@@ -98,7 +98,8 @@ class TabbedArea : public gcn::TabbedArea, public gcn::WidgetListener
+ int getContainerHeight() const
+ { return mWidgetContainer->getHeight(); }
+
+- using gcn::TabbedArea::setSelectedTab;
++ void setSelectedTab(unsigned int index)
++ { gcn::TabbedArea::setSelectedTab(index); }
+
+ void setSelectedTab(gcn::Tab *tab);
+
+diff --git a/src/gui/widgets/textfield.h b/src/gui/widgets/textfield.h
+index 2865403..94cada4 100644
+--- a/src/gui/widgets/textfield.h
++++ b/src/gui/widgets/textfield.h
+@@ -63,6 +63,7 @@ struct TextHistory {
+
+ class AutoCompleteLister {
+ public:
++ virtual ~AutoCompleteLister() {}
+ virtual void getAutoCompleteList(std::vector<std::string>&) const {}
+ };
+
+diff --git a/src/resources/itemdb.h b/src/resources/itemdb.h
+index 1531108..d7859ad 100644
+--- a/src/resources/itemdb.h
++++ b/src/resources/itemdb.h
+@@ -78,7 +78,7 @@ class ItemDB
+ mLoaded(false)
+ {}
+
+- ~ItemDB()
++ virtual ~ItemDB()
+ {}
+
+ /**
+--
+1.7.11.1
+
diff --git a/games-rpg/mana/files/mana-0.6.1-Import-cstdint-for-int64_t.patch b/games-rpg/mana/files/mana-0.6.1-Import-cstdint-for-int64_t.patch
new file mode 100644
index 000000000000..b7ab39d05cdc
--- /dev/null
+++ b/games-rpg/mana/files/mana-0.6.1-Import-cstdint-for-int64_t.patch
@@ -0,0 +1,24 @@
+From dfd304e93bb9010ef8226ee4d026d45c9bf9d2f5 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 28 Jul 2012 15:54:57 +0200
+Subject: [PATCH 3/3] Import cstdint for int64_t.
+
+---
+ src/net/download.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/net/download.h b/src/net/download.h
+index c0bdf20..b9ad17e 100644
+--- a/src/net/download.h
++++ b/src/net/download.h
+@@ -18,6 +18,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include <cstdint>
+ #include <cstdio>
+ #include <string>
+
+--
+1.7.11.1
+
diff --git a/games-rpg/mana/files/mana-0.6.1-Trick-gcc-into-importing-C99-stdint.h-when-C-11-is-n.patch b/games-rpg/mana/files/mana-0.6.1-Trick-gcc-into-importing-C99-stdint.h-when-C-11-is-n.patch
new file mode 100644
index 000000000000..fa752383c38a
--- /dev/null
+++ b/games-rpg/mana/files/mana-0.6.1-Trick-gcc-into-importing-C99-stdint.h-when-C-11-is-n.patch
@@ -0,0 +1,26 @@
+From bb92108fed0242f1a3509384faeb2234d007c05e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 28 Jul 2012 15:54:10 +0200
+Subject: [PATCH 2/3] Trick gcc into importing C99 stdint.h when C++11 is not
+ used.
+
+---
+ src/cpp0x_compat/cstdint | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/cpp0x_compat/cstdint b/src/cpp0x_compat/cstdint
+index d8d71d9..d430649 100644
+--- a/src/cpp0x_compat/cstdint
++++ b/src/cpp0x_compat/cstdint
+@@ -5,3 +5,8 @@
+ * compiles Mana fine so it apparently understands types like uint16_t by
+ * default.
+ */
++
++extern "C"
++{
++#include <stdint.h>
++};
+--
+1.7.11.1
+
diff --git a/games-rpg/mana/mana-0.6.1.ebuild b/games-rpg/mana/mana-0.6.1.ebuild
index 299ad0fcf6aa..ea69913831cf 100644
--- a/games-rpg/mana/mana-0.6.1.ebuild
+++ b/games-rpg/mana/mana-0.6.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/mana/mana-0.6.1.ebuild,v 1.3 2012/07/13 13:58:36 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/mana/mana-0.6.1.ebuild,v 1.4 2013/07/29 21:25:23 hasufell Exp $
-EAPI=2
+EAPI=5
inherit eutils cmake-utils games
DESCRIPTION="A fully free and open source MMORPG game client"
@@ -36,7 +36,12 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
DOCS=( AUTHORS ChangeLog NEWS README )
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-Fix-missing-virtual-destructors-and-guichan-use.patch
+ "${FILESDIR}"/${P}-Trick-gcc-into-importing-C99-stdint.h-when-C-11-is-n.patch
+ "${FILESDIR}"/${P}-Import-cstdint-for-int64_t.patch
+ )
src_prepare() {
base_src_prepare
@@ -59,6 +64,7 @@ src_configure() {
-DPKG_DATADIR="${GAMES_DATADIR}/${PN}"
-DPKG_BINDIR="${GAMES_BINDIR}"
-DWITH_BUNDLEDHEADERS=OFF
+ -DENABLE_CPP0X=OFF
)
cmake-utils_src_configure
}