summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-23 12:18:21 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-23 12:18:21 +0000
commit448012894eac6d7cb409bb3f72e0e0a1bab68dc9 (patch)
tree7192b50ad249ab1a044863247716f2c902a8c72f /games-rpg
parenthppa stable, bug #146855 (diff)
downloadgentoo-2-448012894eac6d7cb409bb3f72e0e0a1bab68dc9.tar.gz
gentoo-2-448012894eac6d7cb409bb3f72e0e0a1bab68dc9.tar.bz2
gentoo-2-448012894eac6d7cb409bb3f72e0e0a1bab68dc9.zip
old
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/adonthell/adonthell-0.3.3-r1.ebuild50
-rw-r--r--games-rpg/adonthell/files/0.3.3-configure.in.patch74
-rw-r--r--games-rpg/adonthell/files/digest-adonthell-0.3.3-r11
3 files changed, 0 insertions, 125 deletions
diff --git a/games-rpg/adonthell/adonthell-0.3.3-r1.ebuild b/games-rpg/adonthell/adonthell-0.3.3-r1.ebuild
deleted file mode 100644
index 86ae083f2637..000000000000
--- a/games-rpg/adonthell/adonthell-0.3.3-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/adonthell-0.3.3-r1.ebuild,v 1.10 2005/06/15 19:02:21 wolf31o2 Exp $
-
-inherit eutils games
-
-DESCRIPTION="roleplaying game engine"
-HOMEPAGE="http://adonthell.linuxgames.com/"
-SRC_URI="http://savannah.nongnu.org/download/adonthell/${PN}-src-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE="doc"
-
-RDEPEND="dev-lang/python
- media-libs/libsdl
- media-libs/libvorbis
- media-libs/libogg
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- doc? (
- media-gfx/graphviz
- app-doc/doxygen )
- sys-devel/autoconf"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PV}-configure.in.patch"
- aclocal && automake -a && autoconf || die "autotools failed"
-}
-
-src_compile() {
- egamesconf \
- --disable-dependency-tracking \
- --disable-py-debug \
- --enable-nls \
- $(use_enable doc) \
- || die
- touch doc/items/{footer,header}.html
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- keepdir "${GAMES_DATADIR}/${PN}/games"
- dodoc AUTHORS ChangeLog FULLSCREEN.howto NEWBIE NEWS README
- prepgamesdirs
-}
diff --git a/games-rpg/adonthell/files/0.3.3-configure.in.patch b/games-rpg/adonthell/files/0.3.3-configure.in.patch
deleted file mode 100644
index fd7ad893772c..000000000000
--- a/games-rpg/adonthell/files/0.3.3-configure.in.patch
+++ /dev/null
@@ -1,74 +0,0 @@
---- configure.in.orig 2005-03-12 18:01:25.000000000 -0500
-+++ configure.in 2005-03-13 00:12:26.000000000 -0500
-@@ -159,10 +159,8 @@
-
- dnl Extract the version using Python, check against 1.5+
-
-- changequote(<<, >>)
-- PYTHON_VERSION=`$PYPACKAGE -c 'import sys ; print (int(sys.version[0]) * 10 + int(sys.version[2]))'`
-- PY_VERSION=`$PYPACKAGE -c 'import sys ; print sys.version[0:3]'`
-- changequote([, ])
-+ PYTHON_VERSION=`$PYPACKAGE -c 'import sys ; print (int(sys.version@<:@0@:>@) * 10 + int(sys.version@<:@2@:>@))'`
-+ PY_VERSION=`$PYPACKAGE -c 'import sys ; print sys.version@<:@0:3@:>@'`
-
- if test $PYTHON_VERSION -lt 15; then
- echo "Sorry, you need to have Python 1.5+ installed - update your version!"
-@@ -172,9 +170,7 @@
- dnl Find the Python.h header file
-
- AC_MSG_CHECKING(for Python header files)
-- changequote(<<, >>)
-- PYINCLUDE=`$PYPACKAGE -c 'import sys ; print "%s/include/python%s" % (sys.prefix, sys.version[:3])'`
-- changequote([, ])
-+ PYINCLUDE=`$PYPACKAGE -c 'import sys ; print "%s/include/python%s" % (sys.prefix, sys.version@<:@:3@:>@)'`
-
- if test -r "$PYINCLUDE/Python.h"; then
- PY_CFLAGS="-I$PYINCLUDE"
-@@ -188,10 +184,8 @@
-
- AC_MSG_CHECKING(for Python library)
- PYLIB=""
-- changequote(<<, >>)
- PYPREFIX=`$PYPACKAGE -c 'import sys; print sys.prefix'`
-- PYLIBVER=`$PYPACKAGE -c 'import sys; print sys.version[:3]'`
-- changequote([, ])
-+ PYLIBVER=`$PYPACKAGE -c 'import sys; print sys.version@<:@:3@:>@'`
-
- py_paths="$PYPREFIX/lib/python$PYLIBVER/config $PYPREFIX/lib"
- py_suffix="$PYLIBVER.so $PYLIBVER.a .so .a"
-@@ -220,19 +214,9 @@
-
- dnl Get the libraries that python depends on
-
-- AC_PATH_PROG(haveldd, ldd)
- AC_MSG_CHECKING(for Python's dependencies)
-
-- if test x$haveldd != x ; then
-- changequote(<<, >>)
-- py_deps=`ldd $PYPACKAGE | sed 's/\( *.*lib\([^\/]*\)\.so.*=.*$\)/-l\2/p; d' | grep -v 'stdc++'`
-- for py_lib in $py_deps ; do
-- if test "$py_lib" != "-lm" && test "$py_lib" != "-lc" ; then
-- PY_DEPS="$PY_DEPS $py_lib"
-- fi
-- done
-- changequote([, ])
-- fi
-+ PY_DEPS="$PY_DEPS `python-config --libs`"
-
- case $target in
- *-sun-solaris*)
-@@ -280,11 +264,9 @@
- if test "$P_SWIG" != "no" ; then
- $P_SWIG -version &> swig.ver
-
-- changequote(<<, >>)
-- swig_major_ver=`more swig.ver | sed 's/.* \([0-9]*\)\.[0-9]*\.[0-9]*.*/\1/p; d'`
-- swig_minor_ver=`more swig.ver | sed 's/.* [0-9]*\.\([0-9]*\)\.[0-9]*.*/\1/p; d'`
-- swig_micro_ver=`more swig.ver | sed 's/.* [0-9]*\.[0-9]*\.\([0-9]*\).*/\1/p; d'`
-- changequote([, ])
-+ swig_major_ver=`more swig.ver | sed 's/.* \(@<:@0-9@:>@*\)\.@<:@0-9@:>@*\.@<:@0-9@:>@*.*/\1/p; d'`
-+ swig_minor_ver=`more swig.ver | sed 's/.* @<:@0-9@:>@*\.\(@<:@0-9@:>@*\)\.@<:@0-9@:>@*.*/\1/p; d'`
-+ swig_micro_ver=`more swig.ver | sed 's/.* @<:@0-9@:>@*\.@<:@0-9@:>@*\.\(@<:@0-9@:>@*\).*/\1/p; d'`
-
- rm -f swig.ver
-
diff --git a/games-rpg/adonthell/files/digest-adonthell-0.3.3-r1 b/games-rpg/adonthell/files/digest-adonthell-0.3.3-r1
deleted file mode 100644
index fbb7a051e786..000000000000
--- a/games-rpg/adonthell/files/digest-adonthell-0.3.3-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 93d6c13a07e0b319a04a971e8304fc8e adonthell-src-0.3.3.tar.gz 1023601